Jump to content
LaunchBox Community Forums

GridBlocked Startup Theme 1.0.1 + GridBlocked_Slow

   (1 review)

6 Screenshots

About This File

Decided to mess around some more looking at code and learning more. So I set out to look at adding gif, linking metadata, and linking images to metadata since I do not use the details screen in BigBox. So here is what I put in another little theme. Once again, I am not a coder so if anyone peaks at the xml file and sees some fixes or a better way please let me know. I am all ears. Or if you have ideas on how to make the theme look nicer fire away.

Icons used in the theme came from BigBox themes by @CriticalCid and @Mr. Retrolust so big thanks to them. (Slightly modified from their original versions.) 

I claim no credit to any artwork displayed or included in the theme.

IMPORTANT: Launchbox 9.3 or higher required for Startup Themes. 

Version 1.0

Theme will show fanart background blurred 20%, Metadata text contained in a view box, and 3 metadata logos (Favorite, Your Personal Star Rating, and ESRB), along with large 3D Box and Cart/Disc.

Startup theme view for non CD based games will show the cartridge image slide in from the right.

Startup theme for CD based games will show the CS slide in from the right and spin.

Shutdown view will show the fanart background blurred with blinking "Game Over" text.

Installation: 

Download the GridBlocked.zip and unzip it into the Launchbox/StartupThemes folder.

Install the supplied fonts. (Working on figuring out how to have it so the fonts do not need to be loaded. So once I can do that I will update the theme)

In Launchbox go to Tools>Options>Game Startup and choose the appropriate named theme. 

In Launchbox make sure for Cart Front Image Priorities you have "Disc" checked and listed as top item.

If you need to add other disc based systems to the startup theme simply copy any cd based xml file in the theme's folder and paste into the same folder then rename the file exactly as your platform name appears in Launchbox. 

 


What's New in Version 1.0.1 + GridBlocked_Slow   See changelog

Released

Fixed gif path that kept them from working. Looks like that old folder was still on the drive and the theme could access it so I missed the error. Just delete the old folder and redownload GridBlockedv1.1.zip

Addition: (GridBlocked_Slow)

Added a version of the theme with a slower disc spin for those that may prefer it. It can be added in addition to the normal GridBlocked theme so you can choose either or at any time. You do not need to delete the original unless you want to.

  • Like 17



User Feedback

Recommended Comments

This Startup Theme look awesome, I've been waiting for an animated loading graphic and integrated metadata info... but there's an error somewhere and won't launch a game.  I followed the installation instructions but I did notice an incorrect path in the xaml file listed below, but even after correcting it and removing the "Icons Test" folder from the path, it still didn't work. I'm assuming there might be an error somewhere else that's not as noticeable. Once I switched back to my previous theme, games launched as usual.


            <Image gif:ImageBehavior.AnimatedSource="{}pack://siteoforigin:,,,/StartupThemes/Icons Test/Images/Gifs/Default.gif" Grid.Row="0" Grid.RowSpan="3" Grid.Column="1" Grid.ColumnSpan="1" 
                VerticalAlignment="Center" HorizontalAlignment="Center" Stretch="Uniform" RenderTransformOrigin="0,0">
            </Image>

Edited by PanteraZombie

Share this comment


Link to comment
Share on other sites

@Retro808 I'm also having issues using this startup theme. The games won't start and my mouse-pointer also disappears. The only way I can get the pointer to reappear is by restarting the system. Maybe there's an error somewhere in the code?

Share this comment


Link to comment
Share on other sites
3 minutes ago, bundangdon said:

@Retro808 I'm also having issues using this startup theme. The games won't start and my mouse-pointer also disappears. The only way I can get the pointer to reappear is by restarting the system. Maybe there's an error somewhere in the code?

Download the updated theme, its fixed now.

 

  • Like 2

Share this comment


Link to comment
Share on other sites
4 minutes ago, bundangdon said:

@Retro808 I'm also having issues using this startup theme. The games won't start and my mouse-pointer also disappears. The only way I can get the pointer to reappear is by restarting the system. Maybe there's an error somewhere in the code?

Have you downloaded the new update I just put out? I had it tested by another mod and it is working for him. 

  • Like 1

Share this comment


Link to comment
Share on other sites
2 minutes ago, Retro808 said:

Have you downloaded the new update I just put out? I had it tested by another mod and it is working for him. 

Just downloaded now and it's working great. Thank you!

  • Like 1

Share this comment


Link to comment
Share on other sites
15 hours ago, Retro808 said:

Thanks @PanteraZombie. I guess I missed that as that folder still exists on my drive and the theme could access it. Will have a fix up in a few minutes.

No problem. So I just downloaded the corrected version and it is working great! The layout is awesome and it's really great to see some game stats with the images now. I wasn't totally sure that was going to be possible, but this theme really shows how good they can be while making RocketLauncher seem more irrelevant to use with LaunchBox. Thanks.

  • Like 1

Share this comment


Link to comment
Share on other sites

First of all big thanks to @Retro808 for this startup screen. It is just missing a little thing for my taste.

For ISOs which are in .zip or .rar I like to have a progression bar showing how the loading is going.

If you are interested

add :

          <Grid Grid.Row="3" Grid.Column="2" Grid.ColumnSpan="3">
                <Grid.RowDefinitions>
                    <RowDefinition Height="80*" />
                    <RowDefinition Height="5*" />
                    <RowDefinition Height="15*" />
               </Grid.RowDefinitions>
                <Grid.ColumnDefinitions>
                    <ColumnDefinition Width="{Binding LoadingWidth}" />
                    <ColumnDefinition Width="{Binding LoadingEmptyWidth}" />
                </Grid.ColumnDefinitions>
                   <TextBlock Grid.Row="0" Grid.RowSpan="2" Grid.Column="0" Grid.ColumnSpan="2" Text="{Binding NowLoadingText}" Foreground="#26CAF7"
                    HorizontalAlignment="Center" VerticalAlignment="Center" FontSize="30" FontStyle="Italic" FontWeight="Bold" Typography.Capitals="AllSmallCaps" />
                  <Grid Grid.Row="1" Background="#26CAF7" />
            </Grid>

at the bottom of the .xaml, just before

        </Grid>        
    </Canvas>
</UserControl>

Edited by R3615

Share this comment


Link to comment
Share on other sites

For anyone interested, I figured out how to modify the code for this Startup Theme to add "Play Count" to the game info portion. Modify these lines from "10*" to "8*"  and add 2 more lines at the bottom located at the top in  <!-- METADATA GRID --> section. This will reduce the space between game info lines to create more room for the new Play Count lines.

<Grid.RowDefinitions>
        <RowDefinition Height="8*" />
        <RowDefinition Height="8*" />
        <RowDefinition Height="8*" />
        <RowDefinition Height="8*" />
        <RowDefinition Height="8*" />
        <RowDefinition Height="8*" />
        <RowDefinition Height="8*" />
        <RowDefinition Height="8*" />
        <RowDefinition Height="8*" />
        <RowDefinition Height="8*" />
        <RowDefinition Height="8*" />
        <RowDefinition Height="8*" />

</Grid.RowDefinitions>

and add these lines at the bottom of the <!-- METADATA GRID --> section

<TextBlock Grid.Row="10" Grid.Column="1" Text="Play Count:" FontFamily="Bangers" TextWrapping="Wrap" FontSize="45" Foreground="Red" VerticalAlignment="Center" HorizontalAlignment="Center">
                    <TextBlock.Effect>
                        <DropShadowEffect ShadowDepth="4" BlurRadius="0.0" Color="#FF000000" RenderingBias="Quality"/>
                    </TextBlock.Effect>
                </TextBlock>
                <TextBlock Grid.Row="11" Grid.Column="1" Text="{Binding SelectedGame.PlayCount}" FontFamily="Gobold" TextWrapping="Wrap" FontSize="32" FontStyle="Italic" Foreground="White" VerticalAlignment="Center" HorizontalAlignment="Center">
                    <TextBlock.Effect>
                        <DropShadowEffect ShadowDepth="4" BlurRadius="0.0" Color="#FF000000" RenderingBias="Quality"/>
                    </TextBlock.Effect>

</TextBlock>

Edited by PanteraZombie

Share this comment


Link to comment
Share on other sites

I'm having an issue with the star ratings not showing up on this startup theme.  I have the community based star ratings downloaded but for some reason they are not showing up in the startup theme.  Help?

Also, Sega Saturn discs are not spinning for me

Share this comment


Link to comment
Share on other sites
6 minutes ago, arcan3kn1ght said:

I'm having an issue with the star ratings not showing up on this startup theme.  I have the community based star ratings downloaded but for some reason they are not showing up in the startup theme.  Help?

Also, Sega Saturn discs are not spinning for me

The rating in the theme is not community based ones. It is the ones you set personally. I do not use community ratings so I built the theme of personal ratings. It is listed as this in the description. I did not want to use community ratings with a logo since those rate in decimal places and that would be a ton of icons. 

Share this comment


Link to comment
Share on other sites
1 minute ago, Retro808 said:

The rating in the theme is not community based ones. It is the ones you set personally. I do not use community ratings so I built the theme of personal ratings. It is listed as this in the description. 

Ah, my fault.  Sorry about that.  Love the theme still!  Best startup theme out!

Share this comment


Link to comment
Share on other sites
Just now, arcan3kn1ght said:

Ah, my fault.  Sorry about that.  Love the theme still!  Best startup theme out!

No worries. Thanks. The theme can be edited to show the community rating up in the grid like the other metadata. If you do not want to use a field already there it is easy to edit one of them and replace it to pull Community Rating. 

Share this comment


Link to comment
Share on other sites

I'm having an issue. My fan art backgrounds aren't showing. Everything else. Does anyone knows why?

Share this comment


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Add a comment...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...