Jump to content
LaunchBox Community Forums

Lambda beta 1.1.1

   (4 reviews)

8 Screenshots

About This File

This theme attempt to be minimal and modern and maximise screen estate.

Note: this is a beta release and features may change in future releases.

Installation

  • Unzip into LaunchBox\LBThemes directory
  • In LaunchBox go to: Options -> Visuals -> Theme: Lambda beta

Windows 7/8 user: Microsoft's “Segoe MDL2 Assets” font ( SegMDL2.ttf ) is required for the buttons and icons to rendered properly. (If you have it it will work but it’s not included here because of licensing reasons.)

Settings guide

tl;dr:

  • You may have to tweak your Boxes aspect ratio and spacing. 
  • The top Details image is only visible when Fanart is available.
  • Button bar can't be hidden because of the licensing info.
  • Font and colour settings have no effect (font is based on system font).

Settings used in screenshots are:

Options -> Visuals -> Boxes -> Spacing:

Aspect Ratio: 0.6 * 
Horizontal Spacing: 2
Vertical Spacing: 2
Horizontal Padding: 8
Vertical Padding: 2
Text Spacing: 4
Text Lines to Show: 2

*) For horizontal box art you may need to use a higher value.

Options -> Visuals -> Boxes:

Align Text Vertically : enabled
Align Text Horizontally : enabled
Show Subline : enabled (for platform info)

Other recommended settings:

Options -> Legacy -> General -> Game Details:

Show Fanart: enabled
other options at your own preference

Options -> Legacy -> Images -> Background Priorities :

Fanart : enabled
other options disabled

Options -> Visuals -> Backgrounds:

Background Blur Amount : 100
Background Fade Amount : 0

(Imo. the theme looks best when blurred background Fanart and Details Fanart are the same image.)

Settings that don't have any effect:

  • Button bar can't be hidden because the license has to stay visible.
  • Colours are hard coded.
  • Font (including size and scaling) is based on your Windows system settings.

 

Thanks to Grila for allowing me to use his LBPlex theme code, Retro808, neil9000, C-Beats and Jason Carr for testing and everyone who supported this release on the forum.

Lambda beta theme CC BY-NC-SA 4.0 Shadowfire 2020


What's New in Version 1.1.1   See changelog

Released

  • Smooth background transitions
  • GameDetails: added Max Players, Release Type, Video URL, and Wikipedia URL fields
  • Like 19
  • Thanks 4
  • Unusual Gem 2



User Feedback

Recommended Comments



Thanks for this - I love minimal themes. Since this is a beta release, may I offer some suggestions? I've attached a screenshot of my setup, and there a couple of things I'd like to note.

  • The first are video snaps. I have snaps for all my games, and in your theme, they show up in the top right. It works great, but if my snap is 16:9 aspect ratio, I get gray bars above and below the video. 4:3 snaps take up the full frame. Is there any way to ensure 16:9 videos don't have those bars?
  • Second, is there any way to specify what details are shown in the text under each game thumbnail? I'd like to just have the game title and the year displayed, but I'm not sure where (or if) I can specify that.

Again, great theme, I love the clean style. Thanks!

 

lambda.png

Share this comment


Link to comment
Share on other sites
24 minutes ago, tycho1974 said:

Second, is there any way to specify what details are shown in the text under each game thumbnail? I'd like to just have the game title and the year displayed, but I'm not sure where (or if) I can specify that.

image.thumb.png.2feab7ea4f88bda0c25fbbff14071406.png

Share this comment


Link to comment
Share on other sites
40 minutes ago, neil9000 said:

image.thumb.png.2feab7ea4f88bda0c25fbbff14071406.png

I thought this section only applied to the Game Details window. If I uncheck unwanted details, then they'll disappear from both under the thumbnail and the Game Details section. Ideally, I'd like to keep those details in the side window, just not under the thumbnail...

Share this comment


Link to comment
Share on other sites
11 minutes ago, tycho1974 said:

I thought this section only applied to the Game Details window. If I uncheck unwanted details, then they'll disappear from both under the thumbnail and the Game Details section. Ideally, I'd like to keep those details in the side window, just not under the thumbnail...

 

1 hour ago, tycho1974 said:

Second, is there any way to specify what details are shown in the text under each game thumbnail?

Sorry i thought this was referencing the screenshots in the game details.

The only option is to not have "show subline" active.

image.thumb.png.ef0769afe82aab9a5b2118362ee47ab9.png

Share this comment


Link to comment
Share on other sites
7 hours ago, neil9000 said:

Sorry i thought this was referencing the screenshots in the game details.

The only option is to not have "show subline" active.

Yes, that did the trick. All that's listed underneath the thumbnail now is the game title. If I had my druthers I'd also like to have the year down there, but this works. Thanks!

Share this comment


Link to comment
Share on other sites
10 hours ago, tycho1974 said:

Yes, that did the trick. All that's listed underneath the thumbnail now is the game title. If I had my druthers I'd also like to have the year down there, but this works. Thanks!

Yes I can confirm that the Game Details settings only apply to the details panel and "show subline" controls the info below the thumbnails. If you wish to hide the developer below the thumbnails you could change the Boxes Spacing "text lines to show" to 1 (with subline enabled), that will only show the year and platform in the subline. The only caveat is that there is one line less space available for game titles so long ones get cut off.  (I personally don't care much for developer info there but I left it there as padding between title and year/platform info.)

Share this comment


Link to comment
Share on other sites
20 hours ago, tycho1974 said:

The first are video snaps. I have snaps for all my games, and in your theme, they show up in the top right. It works great, but if my snap is 16:9 aspect ratio, I get gray bars above and below the video. 4:3 snaps take up the full frame. Is there any way to ensure 16:9 videos don't have those bars?

I wish there was but I couldn't figure out how to do it. I'm not even sure if it's possible, it seems the video box has a forced 4:3 aspect ratio. But if someone with more XAML experience than me knows how to make the aspect ratio flexible, I'm open to suggestions...

EDIT (for devs): the issue is with determining the initial height of VideoControl before the video starts playing. The black bars can be made transparent but that won't solve the issue since it leaves empty space above and below the video.

 

Edited by shadowfire
  • Thanks 1

Share this comment


Link to comment
Share on other sites
8 hours ago, shadowfire said:

I wish there was but I couldn't figure out how to do it. I'm not even sure if it's possible, it seems the video box has a forced 4:3 aspect ratio. But if someone with more XAML experience than me knows how to make the aspect ratio flexible, I'm open to suggestions...

EDIT (for devs): the issue is with determining the initial height of VideoControl before the video starts playing. The black bars can be made transparent but that won't solve the issue since it leaves empty space above and below the video.

 

It does work if you set the video engine to Windows Media Player. Just remove the Height property of your video element and it will dynamically resize the video to fit in. Unfortunately this doesn't work with VLC at all.

Share this comment


Link to comment
Share on other sites
2 hours ago, CriticalCid said:

It does work if you set the video engine to Windows Media Player. Just remove the Height property of your video element and it will dynamically resize the video to fit in. Unfortunately this doesn't work with VLC at all.

I have WMP set as my video player in LB, and I can confirm that this does in fact work. I removed the height property in line 124 of GameDetailsView.xaml, and both 16:9 and 4:3 aspect ratio videos are showing no black bars. Screenshots attached.

4-3.png

16-9.png

  • Game On 1

Share this comment


Link to comment
Share on other sites

Love your theme! Is there any way to switch the date displays from mm/dd/yyyy to dd/mm/yyyy?

  • Thanks 1

Share this comment


Link to comment
Share on other sites
On 5/3/2020 at 1:10 AM, tycho1974 said:

I have WMP set as my video player in LB, and I can confirm that this does in fact work. I removed the height property in line 124 of GameDetailsView.xaml, and both 16:9 and 4:3 aspect ratio videos are showing no black bars. Screenshots attached.

@CriticalCid @tycho1974 does it also work with Auto-Play Videos turned off in the View menu? My WMP is currently broken so I can't test that myself.

Unfortunately I can't implement it if it doesn't work with VLC but feel free to modify your own version.

(My code is the same btw. as in other LB themes and they all show black bars so maybe it's just a limitation.)

Share this comment


Link to comment
Share on other sites
3 hours ago, Corkscrew said:

Is there any way to switch the date displays from mm/dd/yyyy to dd/mm/yyyy?

No, I don't think so... The date format is not handled by the theme layer but by Launchbox itself and as far as I know there's currently no option for date localization in Launchbox.

Share this comment


Link to comment
Share on other sites
13 minutes ago, shadowfire said:

@CriticalCid @tycho1974 does it also work with Auto-Play Videos turned off in the View menu? My WMP is currently broken so I can't test that myself.

Unfortunately I can't implement it if it doesn't work with VLC but feel free to modify your own version.

(My code is the same btw. as in other LB themes and they all show black bars so maybe it's just a limitation.)

Yes it does work with auto-play videos turned off, just tested it.

Btw. I really love your theme. I've made a few modifications here and there for myself and now It's my new go to theme for LaunchBox. Great job! :)

  • Like 1
  • Thanks 1

Share this comment


Link to comment
Share on other sites
2 hours ago, CriticalCid said:

Yes it does work with auto-play videos turned off, just tested it.

Btw. I really love your theme. I've made a few modifications here and there for myself and now It's my new go to theme for LaunchBox. Great job! :)

Agreed - After using it for almost a week now, it's become my favorite. Out of curiosity, what other modifications have you made?

Share this comment


Link to comment
Share on other sites
14 hours ago, tycho1974 said:

Agreed - After using it for almost a week now, it's become my favorite. Out of curiosity, what other modifications have you made?

Nothing big. I've changed the position of the year + platform and the developer row, changed the video height to be dynamic and re-arranged some fields in the side panel.

Share this comment


Link to comment
Share on other sites
CDBlue

Posted (edited)

1 hour ago, CriticalCid said:

Nothing big. I've changed the position of the year + platform and the developer row, changed the video height to be dynamic and re-arranged some fields in the side panel.

@CriticalCid Would you mind sharing your edited version?

Edited by CDBlue

Share this comment


Link to comment
Share on other sites
On 5/2/2020 at 10:10 PM, tycho1974 said:

I have WMP set as my video player in LB, and I can confirm that this does in fact work. I removed the height property in line 124 of GameDetailsView.xaml, and both 16:9 and 4:3 aspect ratio videos are showing no black bars. Screenshots attached.

Tycho, do you mind telling exactly what did you remove from line 124 (or sharing the xaml)? I tried with the entire height property, as well as specific fields in it, but I only got either an error of the theme, or the description text went over the video. Thanks!

Share this comment


Link to comment
Share on other sites
1 hour ago, Kondorito said:

Tycho, do you mind telling exactly what did you remove from line 124 (or sharing the xaml)? I tried with the entire height property, as well as specific fields in it, but I only got either an error of the theme, or the description text went over the video. Thanks!

Sure! Here's the original line in the file:

<controls:VideoControl x:Name="VideoControl" Background="{StaticResource LD_VideoBackgroundBrush}" Visibility="{Binding VideoVisibility}" Margin="0,-10,0,5" Height="{Binding Path=ActualWidth, RelativeSource={RelativeSource Self}, Converter={StaticResource VideoWidthToHeightConverter}}"/>

And here's the modified line:

<controls:VideoControl x:Name="VideoControl" Background="{StaticResource LD_VideoBackgroundBrush}" Visibility="{Binding VideoVisibility}" Margin="0,-10,0,5"/>

Hope that helps!

Share this comment


Link to comment
Share on other sites

Thanks @tycho1974; that is what I did previously. I tried copy/pasting your line just in case there was something different in it, but the same issue happens:

image.thumb.png.06b0791e49c2a8cbf9995c8577ead174.png

Share this comment


Link to comment
Share on other sites
1 hour ago, Kondorito said:

Thanks @tycho1974; that is what I did previously. I tried copy/pasting your line just in case there was something different in it, but the same issue happens:

 

Weird. All I can suggest is that you make sure:

  • You have WMP set as your video player inside LB
  • That you have videos selected to show up in Game Details
  • That a video for the game exists and is properly linked

Beyond this, I'm afraid I would be of no help, sadly.

 

 

rageG.gif

Edited by tycho1974

Share this comment


Link to comment
Share on other sites
5 minutes ago, tycho1974 said:

Weird. All I can suggest is that you make sure:

  • You have WMP set as your video player inside LB
  • That you have videos selected to show up in Game Details
  • That a video for the game exists and is properly linked

Beyond this, I'm afraid I would be of no help, sadly.

Dude! I was sure I had WMP selected in both LB and BB, but maybe I changed it in LB to test something before and forgot to revert it back. That was it. Cheers and sorry for the back and forth. 

@shadowfire really nice theme, looks sexy and has little to no dead space (I use LB as list, not images, and with this theme I can see a lot of items). Thanks for sharing.

  • Like 2

Share this comment


Link to comment
Share on other sites
On 5/5/2020 at 5:21 PM, CDBlue said:

@CriticalCid Would you mind sharing your edited version?

I'm not sure if you would have any need for that as I specifically edited for my own setup in which I have tons of Custom Fields and made room for them. It probably wouldn't look as nice on other setups.

Share this comment


Link to comment
Share on other sites

@tycho1974 @CriticalCid @Kondorito and others: I have found a workaround for the VLC video aspect issue which enforces a 16:9 video container. So 16:9 letterboxing is removed but  instead 4:3 are now pillarboxed. Maybe that's more acceptable?

I've also tweaked the metadata in the lower row to be a bit more space efficient. (Needs a Windows 10 test though since I've changed the stars/favorite assets font and size to Segoe MDL2 Assets. I'm still on Windows 7.)

P.S. Sorry @CriticalCid, I haven't thought about Custom Fields. I'll mark that down as an issue.

Launchbox_Lambda_video_aspect_fix.jpg

Edited by shadowfire
  • Like 1

Share this comment


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Add a comment...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...