Jump to content
LaunchBox Community Forums

16 Screenshots

About This File

Nostalgia uses the amazing platform videos created by @viking to create a per-system theme; thanks to viking for letting me derive from and name my theme after his work. It's designed for 16:9; tested at HD but not 4k since I don't have a 4k setup. Please let me know if you spot problems or have suggestions. It relies on a set of plugin controls I created, so you'll have to unblock either the entire zip file, or more specifically the DLL files in the theme's Plugins folder (see below). Due to its reliance on certain plugin features, the current version of this theme requires LB version 10+. Bundled with Nostalgia are some clear logos from viking's silver ring set, along with a few extras. Also bundled are platform banners created by @Grila and @Omen. For the best experience (including CRT curvature effects for videos), I recommend setting BigBox to use Windows Media Player.

  • Platform Views: Background as the current platform (from viking's video set) including a video playing within the arcade cabinet, TV screen, etc. If there is no video for the selected platform, category, or playlist, a random list of relevant game videos are played instead. If no vids are available, screenshots are used. Platform, category, or playlist details are displayed to the left of the screen.
  • Game Views: Selected game is displayed within a platform-specific background. If no game video exists, the game's screenshots are played as a slideshow while the game's soundtrack (if found in your LB setup) is played in the background. If neither game nor screenshots exist, a video of TV static plays. Game details are displayed to the left of the screen.
  • Filter Views: E.g., Genres, Series, etc -- in this view, a random list of game videos for the selected Series, etc. will play.

KNOWN ISSUES: (1) 3DS and DS videos do not display properly. This is due to how they were captured, i.e., with both screens on these dual screen devices being squished into a single video. A potential workaround is to crop out the auxiliary screen from these videos and use on the part from the main screen. If anyone knows how to do this, please let me know. I think handbrake would work for batch cropping. (2) There are missing platform backgrounds. I tried to include the most common platforms. Viking's background set is quite thorough; please send me any requests.

NOTE: Unblocking the ZIP file will also unblock the DLLs (e.g., Ao.Bigbox.Themer.dll and others) contained therein, giving your computer permission to run these DLLs. This is an issue with all plugins you might download from this forum. It's a Windows security feature. You basically have to vouch for a file before Windows will use it. I liken it to how a MS office document you download from an email runs in Protected Mode until you unblock it for printing, editing, etc. Below is the error you'll see if you don't unblock the file, as well as a screenshot of the solution.

5934737766ef0_PluginSecurityError.jpg.a7a39192a7887d8c342ac8a0a08a239d.jpg5934737219c73_ErrorFix.thumb.jpg.980d4fb15c165b106399b7899b39a6d5.jpg

 


What's New in Version 2.0   See changelog

Released

* FIXED: upgraded to Ao.Bigbox.Themer v3.9.6 (requires LB-10+)
* FIXED: deferring video engine implementation to BigBox setting
* FIXED: removed mediaplayer pooling, little/no utility as of now

Ao.Bigbox.Themer Changelog...
https://forums.launchbox-app.com/files/file/1747-aobigbox-customs/

  • Like 16
  • Thanks 9
  • Haha 1



User Feedback

Recommended Comments



4 minutes ago, eatkinola said:

@cvg @neil9000: That's an unusual error -- my plugin assembly cannot find the following method that is part of the LB plugin api:


Unbroken.Launchbox.Plugins.Data.IStateManager.get_BigBoxCurrentTheme()

The plugin api was introduced in LB 7.10, but I'm pretty sure that method was added to the api in a later release. @Jason Carr would you please confirm?

Are you sure your version of LB really updated successfully to 7.14, @cvg?

That is odd indeed; I would try reinstalling the latest version of LaunchBox. The error message clearly says version 7.14, but there does appear to be some kind of odd DLL conflict. I'm not sure what else could possibly cause this other than a corrupted file; it's pretty strange.

Share this comment


Link to comment
Share on other sites
Just now, Jason Carr said:

That is odd indeed; I would try reinstalling the latest version of LaunchBox. The error message clearly says version 7.14, but there does appear to be some kind of odd DLL conflict. I'm not sure what else could possibly cause this other than a corrupted file; it's pretty strange.

The original error was actually on 7.10, I asked him to update to7.14, and he says the issue persists, so I am out of ideas.

Share this comment


Link to comment
Share on other sites

Hi, is anyone having issues with platform category and platform videos taking a while to load and causing the front end to become unresponsive? I’m using the cinematix videos and have also tried resizing them with a much lower bitrate but still very unresponsive. When I get into a system the game videos play perfect and the front end is seamless and works perfect moving up and down through the games list. The issue only seems to be on the platform category and playform menu’s

Rob

Share this comment


Link to comment
Share on other sites
27 minutes ago, Robbyd78 said:

Hi, is anyone having issues with platform category and platform videos taking a while to load and causing the front end to become unresponsive? I’m using the cinematix videos and have also tried resizing them with a much lower bitrate but still very unresponsive. When I get into a system the game videos play perfect and the front end is seamless and works perfect moving up and down through the games list. The issue only seems to be on the platform category and playform menu’s

Yes, that is an active issue we're trying to fix. Discussion of it starts in the support thread here:

I'm adding you to a discussion between me, @Omen, and @neil9000 -- to see if we can solve this. I don't see this issue on my system, so it might only be noticeable with a larger collection. I'll need some help tracking this down and fixing it since I can't reproduce it on my end. Please look at the pm to which I'm adding you.

Share this comment


Link to comment
Share on other sites

This looks good - but is it possible to remove the huge year from the left of the screen, and instead have it in small text with the rest of the system info?

Share this comment


Link to comment
Share on other sites

@Dan: Yes, you can just comment out the aop:VertReleaseYear control in the views' xaml files. To add the date to the other details, look for controls aop:GameMetadataTable and PlatformMetdataTable; to property FieldOrder you can add GameReleaseYear or PlatformReleaseYear. I think I got all that right; don't have the code in front of me.

Share this comment


Link to comment
Share on other sites

@eatkinola - thanks for the advice. I just downloaded the theme though have not tried to modify it yet. I am having significant lag when going in an out of menus (ie. from "consoles" to the individual consoles, and back to the platforms menu. I have tried a number of other themes which do not have any lag. Any idea what might be going on here? I only have 3 platforms set up at the moment.

I just noticed something else odd - on the category selection videos, there are 3 machines (e.g. 3 different PCs on the PC category, and 3 consoles on the console category). Only the middle of the 3 machines has the game video playing - and instead of the game video, it has a picture of all 3 machines with the videos playing, if that makes sense. Don't know if this is part of the problem.

Edited by Dan

Share this comment


Link to comment
Share on other sites

Would love to be able to swap out the background and the cabinet for my own! Is that possible?

One thing I noticed is that when I scroll through the wheel there is a lot of lag, it'll just stop on a particular cabinet for 15 or so seconds, then load the video, the box art etc. Other themes seem ok so not sure what the issue might be? Is it doing a cache or something?

Great theme!!

 

Edited by Skirmy

Share this comment


Link to comment
Share on other sites

This doesn't seem to work with flv and webm videos. It seems I and at least another guy would love if it did. It's a great theme. 

  • Like 1

Share this comment


Link to comment
Share on other sites
6 minutes ago, Tony said:

This doesn't seem to work with flv and webm videos. It seems I and at least another guy would love if it did. It's a great theme. 

That is down to the individual video players, VLC or WMP, I know that WMP doesn't play webm by default for example you need to install a codec pack to activate it.

Share this comment


Link to comment
Share on other sites

I've been tearing my hair out trying to figure out the problem after upgrading from 7.1 and installing this theme. I thought the default VLC deprecated flv playback so I tried VLC standalone, different versions, nothing worked until I changed the theme back to the default and now those videos work. It seems this theme uses Ao.Bigbox.Themer-Meta.Vlc.dll, something to do with VLC, it's only playing nice with mp4 videos. 

Share this comment


Link to comment
Share on other sites
1 minute ago, Tony said:

I've been tearing my hair out trying to figure out the problem after upgrading from 7.1 and installing this theme. I thought the default VLC deprecated flv playback so I tried VLC standalone, different versions, nothing worked until I changed the theme back to the default and now those videos work. It seems this theme uses Ao.Bigbox.Themer-Meta.Vlc.dll, something to do with VLC, it's only playing nice with mp4 videos. 

Well I don't have any flv videos so I cant speak to that, but webm videos work just fine. And this theme does work with both video players not just VLC. @eatkinola would have to clarify on the flv video issue though.

  • Thanks 1

Share this comment


Link to comment
Share on other sites
12 hours ago, Tony said:

This doesn't seem to work with flv and webm videos. It seems I and at least another guy would love if it did. It's a great theme. 

Thanks, @neil9000. @Tony: VLC mode in this plugin will work with webm, but WMP mode (in general not just for this plugin) will only work with webm if you've installed codecs.

Can you send me some flv files for testing? I don't use that format, but I should be able to add support for the flv format. Thanks for the feedback!

Share this comment


Link to comment
Share on other sites
On 3/6/2018 at 8:53 PM, eatkinola said:

I should be able to add support for the flv format

FYI: support for FLV format added and will be rolled out with the next theme update (hopefully in April though tons of stuff going on)

...and thanks @Tony for supplying a sample FLV file -- that was very helpful

Edited by eatkinola
  • Thanks 1

Share this comment


Link to comment
Share on other sites

Great theme, but it has a lag issue for me. When I scroll down the list of my games, if the game I stop on has no screenshots or video, it lag spikes for a good 3-5 seconds.

Edited by Elmazz

Share this comment


Link to comment
Share on other sites
1 hour ago, Elmazz said:

has a lag issue for me. When I scroll down the list of my games, if the game I stop on has no screenshots or video, it lag spikes for a good 3-5 seconds

Thanks for the report. I'm not currently able to reproduce this issue on my end. Does it happen in both the wheel and text views? Does it also happen in MinimalX?

  • Like 1

Share this comment


Link to comment
Share on other sites
24 minutes ago, eatkinola said:

Thanks for the report. I'm not currently able to reproduce this issue on my end. Does it happen in both the wheel and text views? Does it also happen in MinimalX?

it happens in both views. it doesn't happen in MinimalX, thats why i use MinimalX instead atm.

  • Thanks 1

Share this comment


Link to comment
Share on other sites
1 hour ago, Elmazz said:

it happens in both views. it doesn't happen in MinimalX

Ok, thanks for clarifying. I'll let you know when I release a new version of Nostalgia (likely later this week); I'd appreciate you testing it when I do. If it occurs with the new version (which includes a newer version of Ao.Bigbox.Themer), then it's another theme element causing that slowdown.

  • Like 1

Share this comment


Link to comment
Share on other sites

thank you eatkinola for making this theme. I really love it. I would like to remove the scrolling game info in the game videos. How can I do this?

Share this comment


Link to comment
Share on other sites
12 hours ago, Nonamer66 said:

thank you eatkinola for making this theme. I really love it. I would like to remove the scrolling game info in the game videos. How can I do this?

Glad you like it. These instructions are in the bundled PDF, but I admit they're not that visible and do contain a mistake: "If you don’t like the platform or game notes scrolling across the bottom of the platform’s simulated screen, look for the text OverlayFlava4Bottom in Nostalgia.xaml (mistake said FluxCRT) and simply comment out that entire line." So, the file Styles\Nostalgia.xaml should be made to look like this (just use a text editor):

...
        <!--
        <Setter Property="OverlayFlava4Bottom" Value="Notes" />
        -->
...

That should do it, but please let me know if otherwise. I'll probably make it easier to configure in the future.

 

Share this comment


Link to comment
Share on other sites

mine looks nothing like the preview images what am I doing wrong I tried everything and cant get it to look like the preview images with the different tv styles and consoles  thanks

bad theme.png

Share this comment


Link to comment
Share on other sites
35 minutes ago, bdog019 said:

what am I doing wrong I tried everything and cant get it to look like the preview images

The screenshot you posted is of the default BIgBox theme. Did you: (1) right-click and unblock the Nostalgia zip file after downloading, (2) extract the Nostalgia folder from the zip file and copy it to the LaunchBox\Themes folder, and (3) start and BigBox go to Options -> Views and change the theme to Nostalgia?

Share this comment


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Add a comment...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...