Jump to content
LaunchBox Community Forums
Jason Carr

LaunchBox Beta Testing

Recommended Posts

I see. Sorry I missed your previous post. I guess all you can do is backup all your fanart and then remove it, leaving only a single image in the area I mentioned earlier.

Share this post


Link to post
Share on other sites
imdavid555 said I guess all you can do is backup all your fanart and then remove it, leaving only a single image in the area I mentioned earlier.
That would technically work yes; but uh...yeah no haha. I'll just wait for the option to be implemented natively. I've been experimenting with making some platform backgrounds to go with the other art that I've made for Big Box and I'd like to have the option to just disregard individual game fanart and always use the platform fanart for everything in that platform. I'm not sure what I would prefer in the long run, but I think it's worth implementing as an option. More options for customization are always good in my book.

Share this post


Link to post
Share on other sites
Thanks all. When I implement image and sound packs they will *optionally* be attachable to themes. So you'll be able to use the theme's defaults or specify your own theme packs.

Share this post


Link to post
Share on other sites
Hi Jason, The update fixed the default command-line parameters for Rocket Launcher for me as well! Great job with this, it takes a lot of the guess work out for new comers who have never used Rocket Launcher. Also, it would be extremely nice if using search there is a "No Results Found" dialog box or something similar. Right now it just kind of sits at a black screen. Even more of a Wish List item would be Suggestions or a Google style "Did You Mean?" For the search.

Share this post


Link to post
Share on other sites
Thanks @Jazzphone. I agree that we need to display a message or something for when there's no results. I like your "Did you mean?" idea as well, though that would take some significant work so that probably won't happen soon. We should put in a ticket for it though. :)

Share this post


Link to post
Share on other sites
Jason anyway we could add clearing the search results without having to back out of the platform.

Share this post


Link to post
Share on other sites
Hi @DOS76, potentially, yes. The question is how would it be best to implement it. Just using the back button you think?

Share this post


Link to post
Share on other sites
Well done on the search box @Jason Carr looks SO great, works better than I imagined and makes viewing a game you have on different platforms so easy, the amount of times I've said "oh really I didn't know that game came out on that...". Mario on the ZX Spectrum who would of thought. I came here to mention the no result issue but I see it's been picked up already, maybe leave the search box on-screen with "Name not found" above it then you can just try something else.

Share this post


Link to post
Share on other sites
Alright guys, new beta is out. We added platform-specific image types today, as well as animated gif support for Big Box and more frame rate options. I also fixed a few bugs. There is one glaring bug in 6.6 that unfortunately means we need to push out the official 6.7 release fairly soon (it's the incorrect screenshot bug in Big Box when using background videos). I'm hoping to push out the next official version in the next couple of days. I'll give this release a couple days of testing though before pushing it out. My focus tomorrow will be on recording a tutorial video for custom themes with a visual editor, etc. :)

Share this post


Link to post
Share on other sites
Jason Carr When I tried to update to the Lastest beta version, I received this message: http://i.imgur.com/h249niJ.png An error occurred while trying to replace the existing file Delete File Failed Code 32 The file is being used in another process

Share this post


Link to post
Share on other sites
Jason Carr said Alright guys, new beta is out. We added platform-specific image types today, as well as animated gif support for Big Box and more frame rate options. I also fixed a few bugs. There is one glaring bug in 6.6 that unfortunately means we need to push out the official 6.7 release fairly soon (it's the incorrect screenshot bug in Big Box when using background videos). I'm hoping to push out the next official version in the next couple of days. I'll give this release a couple days of testing though before pushing it out. My focus tomorrow will be on recording a tutorial video for custom themes with a visual editor, etc. :)
Hi Jason, I was curious if there was any progress made with Downloading Images and Metadata without changing the Platform the Game is associated with. Not sure if this can make it in time for 6.7.

Share this post


Link to post
Share on other sites
Hi @kanonopc, that issue is usually cause by LaunchBox or Big Box running in the background as you're trying update. Try rebooting or killing LaunchBox and/or Big Box with Task Manager. @Jazzphone, unfortunately I haven't gotten to that yet. I just moved it up on my list though; but yeah, it probably won't make it in before 6.7.

Share this post


Link to post
Share on other sites
Jazzphone said I was curious if there was any progress made with Downloading Images and Metadata without changing the Platform the Game is associated with.
The weird thing about this is...it's a relatively recent development. It was only a few betas prior to the latest official when it was working correctly. I didn't go all the way through the last batch of betas - I think I was on like 6.5 beta 5 and it was still working normally but when I went to the following official and beyond it started happening. I know this for sure because I was adding a lot of ScummVM games at the time and almost all of them were actually DOS entries in the DB and it remained what I had specified (ScummVM) even after scraping; now though, it overwrites it. @Jason, I don't know if this helps narrow it down much but it seems like it's a pretty recent issue.

Share this post


Link to post
Share on other sites
I'm running into a little issue I hope others have seen and found a workaround for. In BigBox, when I leave a platform with a video playing, the sound from that video plays over and over repeating. Even if I go into another game with a video or back into the same video, the sound from the video I left still plays repeating. It could very well be something on my end. Any ideas?

Share this post


Link to post
Share on other sites
What media player are you set on (VLC or Window Media Player in the options). Best to swap and see if it still happens

Share this post


Link to post
Share on other sites
Thanks @Zombeaver. Fixing it should be pretty easy but by request I'll need to add an option to allow for either situation going forward, so that's what will be tricky. I might tackle this tomorrow in the live development stream. @donarumo, that sounds like an issue with the VLC video playback engine. I didn't know that was still happening though, so thanks. I'll see if I can fix it tomorrow. Do try switching to Windows Media Player though to see if it's fixed for you, per @Rincewind. :)

Share this post


Link to post
Share on other sites
New beta is out guys, but all that changed is the translations for this beta. Spent the day working on two new tutorial videos for tweaking custom themes with a visual editor. Check them out here: https://www.youtube.com/watch?v=tYBvzuvtZ3k

Share this post


Link to post
Share on other sites
Thanks Jason! The tutorial taught me a bunch! Found out how to adjust the curve on the wheels by adjusting the "CurveAmount" value. Also discovered how to add shadows to text. Makes it really pop really nice! Before: Untitled2.png After: Untitled.png Quick question. Is there anyway we can have the Wheel fade-out when not in use?

Share this post


Link to post
Share on other sites
Awesome, David! That does look great! There should be a way to fade in the wheel, but that will be a complicated thing to play with, and may require some actual code. I'll be putting out some more tutorials here soon (one will be on animations soon, which will help), so we'll get there sooner or later. I have a feeling I'll have to custom code that myself though.

Share this post


Link to post
Share on other sites
New beta is out guys with a ton of bug fixes from the live stream this morning as well as my work this afternoon. This is the release candidate for 6.7, which I hope to put out tomorrow. Here's what I fixed for this beta (at least most of it): - Fixed: Videos could not be downloaded or replaced when they were selected and paused in the game details sidebar (was throwing an error) - Fixed: Scrape As platforms were using command-line parameters for "Scrape As" platform in the associated platforms for emulators instead of the proper platform name - Fixed: The mouse cursor in Big Box was automatically showing back up when switching between views and "hide mouse cursor" was enabled - Fixed: When "Auto-Play Music" is enabled and "Auto-Play Videos" is disabled in LaunchBox, music was not auto-playing if a video was available for the game - Fixed: Manually playing a video using the Windows Media Player engine in LaunchBox was not stopping any playing music - Fixed: The DOSBox configuration editor was not populating screen resolutions properly - Fixed: The default platform clear logos were being saved to disk as JPGs instead of PNGs - Fixed: Windows Media Player videos are now centered in Big Box in the games views (for vertical videos); however there's a glitch with the VLC playback engine so VLC videos are still not centered Let me know if anyone runs into any glaring issues before we put out the release tomorrow. :)

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...