Jump to content
LaunchBox Community Forums
Jason Carr

Emulator Settings for All Platforms

Recommended Posts

I've also been having tough time trying to get Atari Jaguar stuff to run right. VirtualJaguar's control settings are a mess to deal with, so I tried MAME, and I can't anything to run on it as if I need to know the proper commands for it to run through LaunchBox, and RetroArch seems to be running things much slower than VirtualJaguar did too. Not sure how to run Phoenix through LaunchBox either. All I can seem to get Phoenix to do is open up, but not load up and run a ROM through it when I click a game in LaunchBox

Share this post


Link to post
Share on other sites

@mcfilmmakers

try using :  apfimag -cart basic -cass

then when basic launches press 1 on your keyboard then type cload (enter)

run (enter)

 

Share this post


Link to post
Share on other sites
6 hours ago, harryoke said:

@mcfilmmakers

try using :  apfimag -cart basic -cass

then when basic launches press 1 on your keyboard then type cload (enter)

run (enter)

 

AS I mentioned on Sunday, I got this to work. I was wondering though, is there a way to get mame to autoplay the tape?

Share this post


Link to post
Share on other sites
Posted (edited)
19 minutes ago, mcfilmmakers said:

AS I mentioned on Sunday, I got this to work. I was wondering though, is there a way to get mame to autoplay the tape?

have you tried :   apfimag -autoboot_delay 4 -autoboot_command "cload\n\nrun\n\n" -cart basic -cass

Edited by harryoke
  • Like 1

Share this post


Link to post
Share on other sites
52 minutes ago, harryoke said:

have you tried

(Please don't take this the wrong way) Have you?

What I found with apfimag is that once MAME starts it, you need to press the keyboards Enter key (vs apfimag's  ]  key (which is their Enter key) first.  Then  cload ]  (which \n works in this case but not for the 1st Enter key press).  Next you need to load/run the tape  (F2).  Then when that's done comes   run ]   (again,  \n  works for the "]" keystroke).

Share this post


Link to post
Share on other sites
48 minutes ago, JoeViking245 said:

(Please don't take this the wrong way) Have you?

What I found with apfimag is that once MAME starts it, you need to press the keyboards Enter key (vs apfimag's  ]  key (which is their Enter key) first.  Then  cload ]  (which \n works in this case but not for the 1st Enter key press).  Next you need to load/run the tape  (F2).  Then when that's done comes   run ]   (again,  \n  works for the "]" keystroke).

That's correct.

What I find so frustrating is that while MAME has an autoboot command, you can't play the tape (requires pressing scroll lock and F2) with this method, which makes the autoboot command utterly pointless.

Share this post


Link to post
Share on other sites
1 hour ago, harryoke said:

have you tried :   apfimag -autoboot_delay 4 -autoboot_command "cload\n\nrun\n\n" -cart basic -cass

The \nrun doesn't autoplay the tape. 

Share this post


Link to post
Share on other sites
5 minutes ago, mcfilmmakers said:

while MAME has an autoboot command, you can't play the tape

It may be possible with hex/ascii/VK-whatever codes.  No idea for sure.

How are your lua programming skills?  I bet there's a way to do it from there, then set it up as the autoboot_script in the specific console/computer ini file. :D  I briefly looked into lua scripting once, but my personal interest level didn't want anything to do with it.  And it hasn't changed. ;) 

  • Haha 1

Share this post


Link to post
Share on other sites
1 hour ago, JoeViking245 said:

It may be possible with hex/ascii/VK-whatever codes.  No idea for sure.

How are your lua programming skills?  I bet there's a way to do it from there, then set it up as the autoboot_script in the specific console/computer ini file. :D  I briefly looked into lua scripting once, but my personal interest level didn't want anything to do with it.  And it hasn't changed. ;) 

I have no knowledge of lua whatsoever but thanks for mentioning it. Looks like I'm going to learn a new skill.

  • Like 1

Share this post


Link to post
Share on other sites
16 hours ago, JoeViking245 said:

(Please don't take this the wrong way) Have you?

What I found with apfimag is that once MAME starts it, you need to press the keyboards Enter key (vs apfimag's  ]  key (which is their Enter key) first.  Then  cload ]  (which \n works in this case but not for the 1st Enter key press).  Next you need to load/run the tape  (F2).  Then when that's done comes   run ]   (again,  \n  works for the "]" keystroke).

It was just an idea to try , i dont use mame to emulate APF , i use VAPF emu & vapf.txt to automate the loading process

  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)

Hi

I have a question about Demul emulator in LB. When I start a Demul game from LB, it doesn't directly run the game, but it appears this: 

Immagine.png

so i have to manually choose the game.  Is it possible to automatically start the game?  In the first page of this topic, the link related to the command line for Demule is broken...

Currently I have configured my Demul installation for Atomiswave in this way:

atomiswave.png

and it works, the game automatically start in fullscreen.

For my Demul installations for Dreamcast and Naomi, I have this configuration:

Immagine2.png

and it doesn't work, it appears the Demul UI as I show above.  I tried to modify these Demul installations in the same way of the Atomiswave one. But for Naomi/Dreamcast it doesn't work, the games don't automatically start...

can you help me? Whioch is the right configuration? I suppose the one that I have on Demul for Atomiswave. But I don't know how to configure in the same way the others Demul installation...

 

thanks!

 

 

Edited by legolas119

Share this post


Link to post
Share on other sites

Demul is a mess to deal with, but seen stuff on YouTube to make it only seem easy. I got all my Atomiswave stuff working, and some of my Naomi stuff going, and only 1 of the Naomi 2 games I have is working right, but Hikaru seemed iffy at one point but no longer works. I pretty much got rid of the ones saying it was missing something when I ran them, and I also have like 3 versions of Demul too for various controller settings, and what seemed like a game would run on one version, but not so much the other. My setups look like this:

image.thumb.png.266692607bed1fb3946ac26ee16d5d80.pngimage.thumb.png.ac17173e72b00b68d2e385befe1ba5d2.pngimage.thumb.png.10680a0063d6478bfb42ef0b158a7434.pngimage.thumb.png.924439463e20d919a8bc19a70277c96e.pngimage.thumb.png.b672190002b619cec2c51c9b51ebe27c.pngimage.thumb.png.f7fcd028b89b9c548a973ac3c92a78bd.png

Share this post


Link to post
Share on other sites

Finally downloaded one of those hyperspin sets

Hopefully much of the settings now are done on the emulators

Share this post


Link to post
Share on other sites
5 hours ago, Zeaede said:

Finally downloaded one of those hyperspin sets

Hopefully much of the settings now are done on the emulators

Hated Hyperspin...too unreliable, sticking with my 8TB LaunchBox collection. It's a labor of love, clearly.

Share this post


Link to post
Share on other sites
34 minutes ago, cleverest said:

Hated Hyperspin...too unreliable, sticking with my 8TB LaunchBox collection. It's a labor of love, clearly.

I downloaded a couple of sets, 2 of them have emulators setup ready

What i don't like with Launchbox i can't get all systems with their xml from Hyperspin

Shouldn't be that hart to integrate Hyperspin xml to Launchbox?

I have over 600 systems combined the hyperspin sets with each other

But if i try the same with Launchbox it's gonna be less systems

Now when i have the hyperspin sets, i can see how complicated settings is compared to Launchbox

What i can do with Launchbox and Retroarch i can't figure out how to do with Hyperspin

Pro's and con's for both systems

Edited by Zeaede

Share this post


Link to post
Share on other sites
15 minutes ago, Zeaede said:

What i don't like with Launchbox i can't get all systems with their xml from Hyperspin

Shouldn't be that hart to integrate Hyperspin xml to Launchbox?

Why would we provide compatibility with a old and outdated competitor? The way they handle there lists is archaic .

  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, neil9000 said:

Why would we provide compatibility with a old and outdated competitor? The way they handle there lists is archaic .

Just to compare them both

I know how to import Irem classics with Launchbox

But how do i import Irem M27, M52. M62, M72, M92, M97?

Share this post


Link to post
Share on other sites
Just now, Zeaede said:

Just to compare them both

I know how to import Irem classics with Launchbox

But how do i import Irem M27, M52. M62, M72, M92, M97?

Those are all just part of the Arcade platform, Import a MAME fullset and they are imported. I would hate to have them all broken out into separate playlists, which is what you would have to do.

  • Like 1

Share this post


Link to post
Share on other sites
Just now, neil9000 said:

Those are all just part of the Arcade platform, Import a MAME fullset and they are imported. I would hate to have them all broken out into separate playlists, which is what you would have to do.

I have downloaded one set where i have whole MAME HBMAME divided in their own categories, looks nice when it's done

But would like to have same setup wtih Launchbox

Obviously i could manually seperate those files

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...