Jump to content
LaunchBox Community Forums
Mute64

ePSXe closing issues

Recommended Posts

So some of you may allready know of this issue but when closing epsxe down with alt f4 or select start on x360 controller it closes the game down but the process still runs in the background. .. and you can still hear the game music.. anyfix for this??

Share this post


Link to post
Share on other sites
Hi @Mute64, I'll take a look and see if there's anything I can do to fix ePSXe. In the mean time, I've had good luck with Retroarch for PS1 games, if you want to give it a shot.

Share this post


Link to post
Share on other sites
Mute64 said So some of you may allready know of this issue but when closing epsxe down with alt f4 or select start on x360 controller it closes the game down but the process still runs in the background. .. and you can still hear the game music.. anyfix for this??
No, it all depends on how the emulator is closed. I think its just a bug and because that emulator has had 1 update in about 8 years... its safe to say its more or less dead. Your only option is to switch emulators (the PS1 core in RetroArch is good but hard to get started with so if you need help just ask or find the thread on that RetroArch core) or to close down the process in Process Manager. Ctrl + Shift + Esc.

Share this post


Link to post
Share on other sites
If the escape key works correctly, yes I could alter my script to always use Escape for ePSXe instead of Alt+F4.

Share this post


Link to post
Share on other sites
Jason Carr said If the escape key works correctly, yes I could alter my script to always use Escape for ePSXe instead of Alt+F4.
Should, mine works with Esc, I'm using ePSXe180. But I'm just using the Esc key myself. I will do ahk on HyperSpin when ever I do start to make an arcade cabinet. LB is for my own personal use because it's quick and easy to navigate. HyperSpin is pretty and flashy but if you want to play a game fast and you have 13,000+ games, it's time consuming. That is where the handy search bar you have is fantastic.

Share this post


Link to post
Share on other sites
The official documented way to exit ePSXe is via the ESCAPE key. This is a poor choice as most emulators use the ALT+F4 method and it's easy to forget and use ALT+F4 for ePSXe sometimes. On the subject of ePSXe being an abandoned project, nothing could be further from the truth. It's had several updates over the past 8 years, the most recent being in January 2015. The emulator, it's devs and their website are very much alive.

Share this post


Link to post
Share on other sites
Yea using the escape key for epsxe is much better than alt f4, i may need to set up a temporary xpadder profile to exit epsxe until this issue has been resolved.

Share this post


Link to post
Share on other sites
scree said The official documented way to exit ePSXe is via the ESCAPE key. This is a poor choice as most emulators use the ALT+F4 method and it's easy to forget and use ALT+F4 for ePSXe sometimes. On the subject of ePSXe being an abandoned project, nothing could be further from the truth. It's had several updates over the past 8 years, the most recent being in January 2015. The emulator, it's devs and their website are very much alive.
The site being live, which it has for years, and a one or two updates in 8 years doesn't make them alive necessarily. :P They made a 0.0.25 update which was... shocking. The emulator has been pretty much considered dead. Besides a few android developments. And yea, Escape works but hitting the X in the window should also just work. Alt + F4 isn't ... generally normal for most programs to utilize. I mean, it works in most / all programs regardless because it is built in to Windows. Some programs can disable it I believe, but even if they don't that doesn't mean it was the intended method to shut down the program.

Share this post


Link to post
Share on other sites
Jason Carr said Okay, I'll add a to-do to alter the AutoHotkey script to always close ePSXe with escape.
Hi, Was this alteration to the autohotkey script made? I encounter the same issue with epsxe, every time I try to exit via game controller, the prompt windows appears, disrupting my bigbox mode. regards,

Share this post


Link to post
Share on other sites
This is an old thread and we don't use AHK anymore, we have Controller Automation which is different. In ePSXe there is a check box to remove that closing dialogue, that is the only way to get around that. I also think that pressing the closing buttons again when that closing message pops up will also close that message and thus closing the emulator, but I don't know exactly, I haven't tested that but it should work. Other emulators that have this dialogue, there needs to be a way to turn it off or get around it.

Share this post


Link to post
Share on other sites
Unless they made changes you also need to switch your input plugin to a Lilypad one from PCSX2 in order to see that check box.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...