Jump to content
LaunchBox Community Forums

Issue AutoHot Key not working


AlonB
 Share

Recommended Posts

Good evening!Cool I need advice with AutoHotKey option with my xbox 360 controller. My Launch Box is on windows 8.1 64bit, it has few emulators, like Project64, Snes9x, VisualBoyAdvanced I play all the games in emulators on full-screen and using the BigBox option, but whenever I am in emulator, the combo buttons I set up, doesn't seem to work, and I can't exit the game through the controller, which make me to get up from the couch to the keyboard and do it Manually. I tired to make the AutoHotKey.exe file to run as adminstrator but without successes. This issue is true in case of all the emulators, I didn't find one emulator that does work. Expect this, I really love the progarm, it has huge potential. LaughLaugh Any Help will be appreciated.Surprised
Link to comment
Share on other sites

Hi @AlonB, welcome. The first thing I would do is reboot to see if it fixes the issue, because I've seen AutoHotkey get hung up before, due to multiple instances, etc. Beyond that, I'm not sure. I just tested to make sure everything is working right in 5.0, and I'm not seeing any issues. Do you have "use all controllers" checked or do you have it set to a specific controller?
Link to comment
Share on other sites

Jason Carr said Hi @AlonB, welcome. The first thing I would do is reboot to see if it fixes the issue, because I've seen AutoHotkey get hung up before, due to multiple instances, etc. Beyond that, I'm not sure. I just tested to make sure everything is working right in 5.0, and I'm not seeing any issues. Do you have "use all controllers" checked or do you have it set to a specific controller?
Hey again, I followed of what you said, but didn't make diffrenet. even if I checked "use all controllers". I tried other combo buttons but it's doesn't make different either . But the weird thing is, If I run AutoHotKey.exe as adminstrator, big box won't start up (it's just stuck on the start logo). On the other hand AutoHotKey.exe as adminstrator don't make issues to launchBox's desktop version but yet the combo buttons will fail to work.
Link to comment
Share on other sites

I've done some experimentation; any chance that either of you guys have more than one controller attached to your systems? I'm not certain, but I'm thinking there might be an issue with multiple controllers. Also, try switching between "Use All Controllers" and specifying a controller. Let me know if any of that helps.
Link to comment
Share on other sites

I have just tried it with the latest beta, and it seems to be working fine now. I did set the controller autohotkey option and set back as the hold key and start as the exit. I only have a single controller attached at any time, but windows 10 seems a bit strange with the way it handles the wireless xbox receiver. If it is not plugged into the same usb port as it was previously it needs the drivers reassigned to it and is sees it as a new controller, not sure if that might cause issues. Works great now!
Link to comment
Share on other sites

  • 3 weeks later...
Hey all, was just wondering if the issue that AlonB had was resolved because I have the exact same issue. No matter what I try, cannot get AHK to work in either bigbox or launchbox. I am currently using an xbox one wired controller and can see the AHK script running on my taskbar, probably something simple but I'm out of ideas, would greatly appreciate some help. CheersSmile
Link to comment
Share on other sites

Hi @JBourne21, welcome. You're obviously not alone; I have several reports of this for the moment. I'm working on identifying what might be causing the problem. Check to make sure you have only one copy of AutoHotkey.exe running in your Task Manager. It should show up when LaunchBox starts and shut down when LaunchBox exits (or Big Box).
Link to comment
Share on other sites

Yep, definitely one instance of AutoHotKey.exe runs when you start Launchbox or Bigbox then shuts down on exit. Another small strange thing, when trying to re-configure the input buttons for AHK control, sometimes it would not recognize button presses. That is, I'm in Options, Input, Gamepad/Joystick, Autohotkey and I click on the field under Hold this button: it says Press Button... so I press button 7, for example, and nothing happens. If I then press button 1 as the hold button it will accept that but then state: You've specified Button 1 for use as the Hold button, but it is in use elsewhere. Please either change the Hold button, or remove the duplicate binding. That make's sense and is fine, but when I click ok it throws up this error: System.IndexOutOfRangeException: Index was outside the bounds of the array. at LaunchBox.Forms.OptionsForm.okButton_Click(Object sender, EventArgs e) at System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent) at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks) at System.Windows.Forms.Control.WndProc(Message& m) at System.Windows.Forms.ButtonBase.WndProc(Message& m) at System.Windows.Forms.Button.WndProc(Message& m) at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam) Not sure if that help's or confuses the situationConfused.
Link to comment
Share on other sites

G'day, tried a variety of different emulators, dolphin, mame, Project64, SSF etc. with launchbox and bigbox and .......... Working Perfectly!SmileLaughKiss Outstanding work mate, show launchbox, volume adjust and exit game all working flawlessly. I've never dealt with anyone who fixes problems that quick, some of the bigger software companies could learn a lot from you! Thanks very much for your effort, if I come across anything else that I think could be of any use I'll let you know, Cheers! Cool
Link to comment
Share on other sites

Update: After some additional testing: PCSX2 - works fine but requires 2 presses of the Hold/Close combination to completely shut the emulator, once to exit fullscreen, then again to shut the emu. No big deal but thought you might like to know. MAME - Close combination not working, I didn't notice at first because I have the exact same closing string in Mame itself. Because you can set it through the Mame config, it negates the need for AHK ... again, no big deal. EPSXE - Closes the main window but leaves the exe running, this is probably the only one that's an actual problem. NullDC, Kega Fusion, Snes9x, PPSSPP, Dolphin, Project64, Nestopia, SSF all fine. I still have Vice, Winuae, Stella, Model 2 Emulator, and a couple of others to test, will report in when done. A slightly larger problem I discovered is when in BigBox mode if you use the Hold/Show Launchbox combination it throws up this error: System.IO.IOException: The process cannot access the file 'C:\Users\Jason Bourne\AppData\Local\Temp\AutoHotkey.Interop\x64\AutoHotkey.dll' because it is being used by another process. at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath) at System.IO.FileStream.Init(String path, FileMode mode, FileAccess access, Int32 rights, Boolean useRights, FileShare share, Int32 bufferSize, FileOptions options, SECURITY_ATTRIBUTES secAttrs, String msgPath, Boolean bFromProxy, Boolean useLongPath, Boolean checkHost) at System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share, Int32 bufferSize, FileOptions options, String msgPath, Boolean bFromProxy) at System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share) at AutoHotkey.Interop.Util.ExtractEmbededResourceToFile(Assembly assembly, String embededResourcePath, String targetFileName) at AutoHotkey.Interop.Util.c__DisplayClass6_0.b__0(String relativePath) at AutoHotkey.Interop.Util.LoadAutoHotKeyDll() at System.Lazy`1.CreateValue() at System.Lazy`1.LazyInitValue() at AutoHotkey.Interop.AutoHotkeyEngine..ctor() at LaunchBox.AutoHotkey.InitializeController(Boolean enabled, Int32 holdButton, Int32 closeButton, Int32 startButton, Int32 volumeDownButton, Int32 volumeUpButton) at LaunchBox.Forms.MainForm.MainForm_Load(Object sender, EventArgs e) at System.Windows.Forms.Form.OnLoad(EventArgs e) at System.Windows.Forms.Control.CreateControl(Boolean fIgnoreVisible) at System.Windows.Forms.Control.CreateControl() at System.Windows.Forms.Control.WmShowWindow(Message& m) at System.Windows.Forms.Control.WndProc(Message& m) at System.Windows.Forms.Form.WndProc(Message& m) at LaunchBox.Forms.CustomFormBase.WndProc(Message& m) at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam) Seems to occur on any emulator. Sorry if I was a bit over-enthusiastic with my earlier post Embarassed I was just pumped that you got it working, Still super happy with the progress you've made though, Thx again Smile
Link to comment
Share on other sites

Thanks @JBourne21, glad to hear there's progress at least. I believe the error you're getting in Big Box is due to running LaunchBox and Big Box at the same time, or running multiple instances of one or the other. I'm going to add some safety checks to make sure that can't happen; hopefully that will resolve the issue. Per PCSX2, one of the things I did with the AutoHotkey revamp was to add emulator-specific AutoHotkey scripts, so that those can be used to solve problems like that specifically for each emulator. So today I'm going to be working on coming up with those scripts. :)
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...