Jump to content
LaunchBox Community Forums
Lordmonkus

Windows 10 Controller "Guide" Button Fix

Recommended Posts

I don't know if there are threads on this topic but I just found this fix after "upgrading" to Windows 10 on my laptop. The first thing I noticed after upgrading and firing up Retroarch I noticed the "Guide" button on my controller (the Logitech button on a Logitech controller) no longer brought up the Retroarch quick menu. After searching around a bit there is a solution posted over on the RA forums about some setting in the GameDVR app but I don't have and don't want that app. I found another fix on a Steam forum thread with a simpler solution than installing some app just to get back the functionality of the button. Anyways here is the fix that should work for Xbox and Logitech controller and others. Go to the device manager to Xbox 360 peripherals. Right click and select properties. Go to the driver tab and click update driver, click browse my computer for driver software. Then select "Let me pick from a list". You should now see 2 drivers listed pick the one marked [2009-040-08], should be the bottom one. Reboot system if needed.
  • Thanks 2

Share this post


Link to post
Share on other sites

YES! Thank you so much, I lost this functionality when i reinstalled Win 10 a while back, and I never figured out why. This is awesome, many thanks!! 

Share this post


Link to post
Share on other sites
59 minutes ago, e2zippo said:

YES! Thank you so much, I lost this functionality when i reinstalled Win 10 a while back, and I never figured out why. This is awesome, many thanks!! 

You can just turn it off in settings these days.

image.thumb.png.d8156e347e3e461fa66fcde4382b92b4.png

Share this post


Link to post
Share on other sites
14 minutes ago, neil9000 said:

You can just turn it off in settings these days.

image.thumb.png.d8156e347e3e461fa66fcde4382b92b4.png

Do I have to have any Xbox-services enabled for this to work? 

Share this post


Link to post
Share on other sites

I dont think so, as you can see in the image i have the gamebar turned off. I do however have the xbox app on my PC which i use from time to time.

Share this post


Link to post
Share on other sites

This is the first time I've seen the solution of reverting to the older driver and after trying every other solution suggestion under the sun this one finally worked. HAHA screw you Microsoft...you tried to take your guide button back but we stole it back!! :P

Share this post


Link to post
Share on other sites
1 minute ago, voicesinthedark said:

This is the first time I've seen the solution of reverting to the older driver and after trying every other solution suggestion under the sun this one finally worked. HAHA screw you Microsoft...you tried to take your guide button back but we stole it back!! :P

Weird, the guide button works just fine for me in all games/emulators on the latest drivers, just by turning the gamebar setting of in settings.

Share this post


Link to post
Share on other sites
Just now, neil9000 said:

Weird, the guide button works just fine for me in all games/emulators on the latest drivers, just by turning the gamebar setting of in settings.

I'm not sure exactly where/what the conflict was but even using powershell to completely remove the xbox apps and then later on changing the gamedvr settings wasn't working. I use a program called Pinnacle Game Profiler for controller support for pc games that don't have it natively so I'm wondering if it was something within that program that wasn't allowing the other fixes to work.

Share this post


Link to post
Share on other sites
1 minute ago, voicesinthedark said:

I'm not sure exactly where/what the conflict was but even using powershell to completely remove the xbox apps and then later on changing the gamedvr settings wasn't working. I use a program called Pinnacle Game Profiler for controller support for pc games that don't have it natively so I'm wondering if it was something within that program that wasn't allowing the other fixes to work.

Possibly, i just turned it off in Windows and Steam and was all good. I dont use pinnacle though, i use controller companion. As i say though, it's never been a issue on by system.

Share this post


Link to post
Share on other sites
On 2/25/2016 at 6:45 PM, Lordmonkus said:

I don't know if there are threads on this topic but I just found this fix after "upgrading" to Windows 10 on my laptop. The first thing I noticed after upgrading and firing up Retroarch I noticed the "Guide" button on my controller (the Logitech button on a Logitech controller) no longer brought up the Retroarch quick menu. After searching around a bit there is a solution posted over on the RA forums about some setting in the GameDVR app but I don't have and don't want that app. I found another fix on a Steam forum thread with a simpler solution than installing some app just to get back the functionality of the button. Anyways here is the fix that should work for Xbox and Logitech controller and others. Go to the device manager to Xbox 360 peripherals. Right click and select properties. Go to the driver tab and click update driver, click browse my computer for driver software. Then select "Let me pick from a list". You should now see 2 drivers listed pick the one marked [2009-040-08], should be the bottom one. Reboot system if needed.

THANK YOU Monkus!
Updated to Win10 some time ago and this was driving me crazy (I still have my 360s for the FE miniPC).
Disabling the game bar did not do anything for me, so it seems that the 360s are not fully compatible with the 2018 driver.

In case somebody is facing this and they do not have more drivers to choose from in their machine, you need to go to the Xbox 360 Controller for Windows download page, and get the Win7 exe file (if you don't want to run the installer and stuff, easy way is to just open the exe with WinRAR, extract the Win7 folder from there and point the driver update to that folder).

Share this post


Link to post
Share on other sites

This isn't a good solution unfortunately. While it does work, it also makes some games not recognize the pad. For instance, Forza 7 doesn't work with the 2009 driver. It needs a later driver to see the pad and by having a later driver it means the guide button is held hostage again by Windows 10. So i have to juggle between drivers every time i want to use RetroArch or Forza.

It's just a mess.

Edited by Imgema

Share this post


Link to post
Share on other sites

Ahh ! So thats it..(removed everything related to xbox services)

In latest win10 old 2009 driver is removed , there are two options but both are from 2018

So i did..

pointing to driver file manually didnt work. Had to install that freaking xbox accesories for windows 7
Found here
https://www.microsoft.com/accessories/en-id/d/xbox-360-controller-for-windows
choose for x64 win7 . After install/reboot driver options look like this:
iLJiWXz.png
As u can see it states i am using drivers from 13 august 2009
After that just disable xboxstat.exe from windows startup. it will remove Click For Help Pop Up of Xbox 360 Home Button
Guide button works! one can even uninstall accessories from program files. Button will still work as long as it has 2009 drivers

(dualshock v2 using ds4windows)

Thanks!

 

P.S

i am curious about compatibility now. I guess ill do some testings , see if all new games work with old driver

Edited by Undertherainbow

Share this post


Link to post
Share on other sites
On 9/14/2019 at 4:00 PM, Undertherainbow said:

i am curious about compatibility now. I guess ill do some testings , see if all new games work with old driver

Forza 7 doesn't work with the old driver.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...