Jump to content
LaunchBox Community Forums
Antropus

Lightspeed: Ultra-Fast Mame Importer Tool

Recommended Posts

It also seems that there is a graphical issue with one of the pages/tabs. Also clicking "reset" on the Platforms page doesn't reset.

Edit: Let me be more specific. It doesn't reset the Arcade tab and specifically the "Bypass Filters" checkbox. It also doesn't deslect any of the built-in filters if they have been selected.

Capture.thumb.PNG.771548f69baf4c6e2e51415b0c6e9e4f.PNG

Edited by quazl

Share this post


Link to post
Share on other sites

@Antropus

Just tested beta 10 as well and I'm also getting the problem where the LaunchBox closing tag is inserted right after the opening tag rather than at the end of the file.1.thumb.png.69a0afe9896cd5d0468b5dd416d53295.png

I'm also sending you the corrupt Arcade.xml file along with the Lightspeed.ini should you wish to try and reproduce. I understand your frustration in trying to deal with these huge files. That would also drive me nuts ! :)

Arcade.7z

Lightspeed.ini

Share this post


Link to post
Share on other sites

I also got the same bug. One question: The software also introduced this problem to my already existing platforms, like Sony Playstation, Nintendo 64 etc. WHY is Lightspeed even touching these xml s?

Edit: I found other bugs: the Custom Values like "Number of buttons" are not assigned as a custom value, they just are in the regular notes of the games. Also consolidating clones does not work, although I told Lightspeed to include clones.

Edited by lones710

Share this post


Link to post
Share on other sites

Hi, I got an error with v 0.183 (plz check the attached image), I got all filtered roms but when I click to export It says "Please choose the output format from the drop-down menu", and, well, I clicked in all places and typed all possible thins related with output-format and Roms. I´m missing something?

Thx in advance.

1.png

 

Info: - Windows 10 (x64)

         -  Roms FB Alpha v 0.2.97.39 (Based on Mame 0.178/0.179)

         -  Mame.exe v 0.179

         -  Tryed to execute lightspeed.exe as administrator and with compatibility in most OS

         - Last time worked with lightspeed 0.7j but dont know why doesnt work now :S

Edited by Flop

Share this post


Link to post
Share on other sites

I'm quite new to the Launchbox, MAME, and Lightspeed world. I was waiting for the new version of LB and Lightspeed to be released. Congratulations on all your hard work as others have mentioned in the forum. I noticed that no new posts have been posted since March 24th and therefore wanted to ask a few questions before using Lightspeed. Does the new release of LB do what Lightspeed can do and that's why there haven't been further posts? Or is the memory and errors from the lastest release of Lightspeed causing issues? A final question does the version of control.ini support Ledblinky control format and the Ultimarc U360 controller?   

Share this post


Link to post
Share on other sites

The current beta of Lightspeed is still causing huge issues and @Antropus seems to be busy with life. There are no new posts because all we can do is to wait until he comes back and releases a new version.

Share this post


Link to post
Share on other sites

Are there any other ways to get Mame in Launchbox without it taking all day to import? I purchased a license ages ago and still haven't gotten Mame imported since I lack the patience :/

Share this post


Link to post
Share on other sites

I mean basically once you start the process you could just walk away from it and let it complete you really don't have to be there.

Share this post


Link to post
Share on other sites

Hi. I got question. I want to use Lightspeed Mame to put my Mame roms to LB.

When I match media catalogs - cover, videos, ets. they are going to by copy from MAME catalog on disc to LB catalogs (Images->Cover, etc.) or they stay in MAME catalog??? I want them to be move or copy from MAME to LB catalog on disc - is taht what program do?

 

Thanx in advance

Edited by vahacris

Share this post


Link to post
Share on other sites

Hello Everyone

I've been following this project elsewere, and surely I must have missed something big...

@Antropus: has something happened?

You used to post frequent updates on development, and all of a sudded.. everyone stopped.

Has the discussion moved to another thread?

Many thanks!

Share this post


Link to post
Share on other sites

I'm trying to use the Copy / Move functionality in order to create a separate culled set of ROMs for my MAME cab.  I'm noticing that for certain games it does not move related zip files that are required to run the game.  To cite a couple examples, Galaga requires some companion zip files named 'namco5X.zip' and Dimahoo needs 'qsound.zip'.  It seems these zips don't even show up in the export step -- so I'm guessing that's why they're not being copied.  Am I missing something or is there a way to ensure Lightspeed has visibility to these required files and knows to copy them to the destination dir?

Much Thanks!

Share this post


Link to post
Share on other sites

MushroomHunterI don't think this was working. Lightspeed should for this check dependancies.

Personally I use LightSpeed for MAMEWAH list creation based on already created custom roms directory. I'm using my own script that copies necessary files based on MAMEUI/ARCADE64 favorites list.

 

There are still one problem with MAMEWAH list export. Program exports at the beginning small string                that makes think MAMEWAH that first game on list in for example ď»ż005 instead of 005. Those signs (which is strange) are not visible in notepad.

Usefull option would be also removing or moving to end of line word "The" since many games have this at the beginning of it's name. Right now I have to do this manually.

Edited by haynor666

Share this post


Link to post
Share on other sites
On 2-7-2017 at 6:05 PM, orkoapprentice said:

This program broke every single one of my console XML files. Bizarre.

same here. very sad. I don't even understand why it did that.. why did it touch my scummVM xml...I'm very dissapointed,

Share this post


Link to post
Share on other sites

I don't know if this software is even working anymore with newer versions of Launchbox. It certainly isn't necessary anymore, this program was made a while back before Jason implemented the Mame Import filtering window that's the last step of the Mame roms import process.

I could be wrong about this being broken though, I never used and never felt the need to either because when it came out I had imported and cleaned mine the old and slow manual way. But since Jason put in the filter tool it does a very good job.

If someone can confirm that this is truly broken now I will lock the thread and put a warning on it on first post.

Share this post


Link to post
Share on other sites

What I see is that it fails to properly close the <LaunchBox> element of the xmls it touches. it's a minor inconvenience

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...