Jump to content
LaunchBox Community Forums

My approach on using Amiga (FS-UAE) with Launchbox


Recommended Posts

9 hours ago, orac31 said:

I have to say I use whd games as you don't need to config them they work as is but i give your way a try for a few games i would like save state suppoet

That's only kinda true. Yes, typically they'll "work" without configuration, but not necessarily ideally. In my experience you need to have PRELOAD enabled in nearly all cases with WHDLoad games in order to keep them from going into full-blown seizure-inducing mode whenever it's loading data. Just try loading up say Defender of the Crown without any configuration - the screen flashes about 15 times before you even get to the character selection screen. Many WHDLoad games do this without PRELOAD enabled.

The beauty of this method is that it's hooking into all of the premade community configurations so that for any of them that already have a community config, it pulls that config and uses it with your files. I will say that there are some games that just don't have an existing config so you'll still need to have a non-UUID FS-UAE emulator entry in LB because the "no quotes" and "no file extension" checkboxes make it unusable with anything other than UUIDs. In those cases I just use a default config that I made, add in the WHDLoad file in the hard drive section, add in PRELOAD in the WHDLoad Arguments section, and save the config as the name of the game. Then I use the config as my "rom" in LB and use the non-UUID FS-UAE emulator entry.

The default config that I use as a starting point uses A1200, 8mb Fast RAM, Empty Floppy Drive Volume: 0

These were the settings that basically all of the community configs for WHDLoad games use. They would be different if you're using floppies. 

FS-UAE config.jpgFS-UAE config 2.jpg

Link to post
Share on other sites
2 hours ago, Zombeaver said:

That's only kinda true. Yes, typically they'll "work" without configuration, but not necessarily ideally. In my experience you need to have PRELOAD enabled in nearly all cases with WHDLoad games in order to keep them from going into full-blown seizure-inducing mode whenever it's loading data. Just try loading up say Defender of the Crown without any configuration - the screen flashes about 15 times before you even get to the character selection screen. Many WHDLoad games do this without PRELOAD enabled.

The beauty of this method is that it's hooking into all of the premade community configurations so that for any of them that already have a community config, it pulls that config and uses it with your files. I will say that there are some games that just don't have an existing config so you'll still need to have a non-UUID FS-UAE emulator entry in LB because the "no quotes" and "no file extension" checkboxes make it unusable with anything other than UUIDs. In those cases I just use a default config that I made, add in the WHDLoad file in the hard drive section, add in PRELOAD in the WHDLoad Arguments section, and save the config as the name of the game. Then I use the config as my "rom" in LB and use the non-UUID FS-UAE emulator entry.

The default config that I use as a starting point uses A1200, 8mb Fast RAM, Empty Floppy Drive Volume: 0

These were the settings that basically all of the community configs for WHDLoad games use. They would be different if you're using floppies. 

FS-UAE config.jpgFS-UAE config 2.jpg

Yep agreed after giving this a try agree it's the perfect way to add and run amiga games

Thanks again op

  • Like 1
Link to post
Share on other sites
  • 4 months later...

Eirulan, I think youre great......smiled like a.....baby?!?.....when I tried it and it worked. If anyone else is like me, then use fs-uae LAUNCHER, NOT the program itself!!!! I only just noticed in the instructions above that it was set to launcher.exe FILE. Mine was just fs-uae without the launcher. Dont worry chaps....it still goes straight through to the (now full screen, coz that wasnt working when bypassing the launcher either) game, not the menu stuff (as i expected it to).

Link to post
Share on other sites
  • 1 year later...
  • 2 years later...

hi  

please, i need your help. I have configured FS-UAE and now i can play my .adf and WHLOAD games with Model = Amiga1200 and my AmigaCD 32 games with Model = CD32.  After that, I imported the FS-UAE.exe emulator on LB, without any issue: I'm able to play all .adf and WHLOAD games. 

Now I imported Amiga CD32 in LB, using the same FS-UAE installation (I mean, same Launcher.exe used for Amiga emualation).  I tried to import 2 AmigaCD32 games: one of them in folder format, with bin, cue, img, sub files: I added the .cue file in LB.  The other one is in .zip format (it included .wav files, .cue and .bin).  LB correctly detected them, but if i run them, the emulator starts but:

1) when i play the game in folder format, it appear a blue screen, with AMIGA DOS information. I think that I have understood the issue: if I play this game, the emulator doesn't start with Amiga CD32 model. If I push START on my joypad, it appears at the upper left side: Amiga 500".

2) when i play the game in zip format, it appears only the AMIGA CD 2 logo. Here if I push START, it doesn't happen anything

I suppose that I have to do something of particular in order to correctly start the FC-UAE emulator for CD 32 games... can you help me, please?

 

I also tried to create 2 different FS-UAE installation folder: one used in LB only for Amiga games and the oter one only for Amiga CD32 games. But i don't solve the issue. It seems that in order to load in LB the Amiga CD 32 games, it is necessary an additional step...

can you help me please?

 

thanks

thank you very much

Edited by legolas119
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...