Jump to content
LaunchBox Community Forums
Zombeaver

Amiga Emulation / FS-UAE: A Comprehensive Tutorial + Launchbox Integration

Recommended Posts

Guess i found the solution of not loading F18 Interceptor in launchbox.

yesterday i ran into the same problems with lemmings. I had a custom config of lemmings working in launchbox before but decided to replace it with the stock version. I deleted the custom config version from the launchbox GUI and imported the stock one and it didn‘t work. It only started the fsuae launcher window but nothing else.

I deleted the not working version .thought i did something wrong and started the import procedure again with no luck.

but then i had a look into the launchbox games Amiga folder and found several lemmings files left even if launchbox told me before that it will delete everything if i delete the game.

so i found a couple of files with the same number like aa888xxxxxxxx and a 1 up to 3 at the end of the filename (guess everytime i tried to install the game it adds the number at the end because the former file wasn‘t deleted) and i also found a file called lemmings (that must have been the custom config one.

After deleting all files i imported the game again in launchbox and now it works.

Share this post


Link to post
Share on other sites

Apologies if this has come up before and already been answered, I've been trawling the forum since yesterday trying to find an answer and have been stuck on this for weeks,

I have an external drive with LB set up to be completely portable so that all of the games/media etc do not rely on having a set drive letter. This is working great on everything but FS-UAE and WHDload. I thought I had cracked it yesterday but when I tested in on a different machine I noticed that the SQL database still uses a drive letter to list the location of the UUIDs and doesn't work unless the external drive has that letter.

Is there any way at all I can get this to work entirely with relative paths, I'm using FS-UAE Dev version 2.9.7(dev2). 

Any suggestions appreciated.

Cheers

Share this post


Link to post
Share on other sites

Honestly, that's something you'd have to ask Frode, the developer. Assuming you've tried using relative paths of something like .\Data\Databases etc. and it didn't work, there might not be a way to do it currently. I would suggest contacting Frode via either his Discord or his section on EAB.

https://discord.gg/SEWwjUJ

http://eab.abime.net/forumdisplay.php?f=122

Share this post


Link to post
Share on other sites

Can someone help me with re-mapping CD32 controls?

I have the following (which indicates the mapping I want), and as far as I can tell Player 1 (Joy_1) is working, and player 2 direction keys are working, but no other buttons:

keyboard_key_5 = action_joy_1_cd32_play
keyboard_key_6 = action_joy_0_cd32_play
keyboard_key_a = action_joy_1_cd32_green
keyboard_key_c = action_joy_1_cd32_ffw
keyboard_key_d = action_joy_1_cd32_rwd
keyboard_key_escape = action_quit
keyboard_key_f = action_joy_0_left
keyboard_key_g = action_joy_0_down
keyboard_key_h = action_joy_0_right
keyboard_key_i = action_joy_0_cd32_yellow
keyboard_key_j = action_joy_0_cd32_blue
keyboard_key_leftbracket = action_joy_0_cd32_ffw
keyboard_key_lshift = action_warp
keyboard_key_n = action_joy_0_cd32_red
keyboard_key_o = action_joy_0_cd32_rwd
keyboard_key_s = action_joy_1_cd32_yellow
keyboard_key_t = action_joy_0_up
keyboard_key_u = action_joy_0_cd32_green
keyboard_key_x = action_joy_1_cd32_blue
keyboard_key_z = action_joy_1_cd32_red

I havent found a game where I can test everything clearly, so not 100% sure all mappings are working on P1 but i at least have green and red working as far as I am able to tell

 

Any help appreciated!

Cheers

Share this post


Link to post
Share on other sites
25 minutes ago, amiga_brigand said:

@Zombeaver Opened an account to say thank you for your tutorial. Absolutely brilliant. No fluff, clear, concise, logical. I salute you

Happy to help! :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×