Jump to content
LaunchBox Community Forums

Amiga Emulation / FS-UAE: A Comprehensive Tutorial + Launchbox Integration


Recommended Posts

1 hour ago, Pixelpiper said:

This is precisely why I used exported UUID.

But I'd really love to have the source code for the exporter to make a new applet that stores the LHA inside its correctly named folder - then stop using the UUID files. :)

 

 @Eirulan actually released the source code for it when he made it. I believe it's in the thread he made for it (and probably in this one somewhere). I can take a look later and see if I can find it but he definitely did release that here.

Link to post
Share on other sites
  • Replies 350
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

 

Hi, I registered here so I could give some feedback to the video. First off, I think it's great that people are creating videos about FS-UAE I'm adding a

.ipf is a floppy disk format that was created by the Software Preservation Society (formerly CAPS) for the preservation of original, unaltered (ie non-cracked) Amiga game disks. It's sortof similar to

Posted Images

Off topic but somewhat related. Does anyone have a working portable version of FS-UAE?

I see that it can use relative paths and I have the portable.ini file set in my root directory, but for the life of me, I can't break out of absolute paths. There seems to be a little documentation on it but its not clear to me. If anyone has working relative paths, I would love to see some examples. 

Link to post
Share on other sites
54 minutes ago, TheCodeMan said:

Off topic but somewhat related. Does anyone have a working portable version of FS-UAE?

I see that it can use relative paths and I have the portable.ini file set in my root directory, but for the life of me, I can't break out of absolute paths. There seems to be a little documentation on it but its not clear to me. If anyone has working relative paths, I would love to see some examples. 

I have a couple installers for some Amiga games on my site that are using an (at this point) older version of FS-UAE but they're completely portable/using relative paths. You might want to take a look at those. The only thing the installer is doing is creating desktop/start menu shortcuts.

Shadow of the Beast Collection

Elvira Collection

Perihelion: The Prophecy

Link to post
Share on other sites
1 hour ago, Zombeaver said:

Here you go, it's in this post.

Sweet! I'll take a look on the weekend - I have no experience with anything .NET, but I'll look into installing the necessary dev environment. Confident I'll figure out the syntax, just worried about getting anything to compile/build. :)

Link to post
Share on other sites
  • 2 weeks later...
25 minutes ago, Centimetro said:

Hello, thanks for the guide, very clear explanations up until the end -- which I figured out the source of my confusion.  The file "Launcher.sqlite" is no longer used in current build of FS-UAE, so I cannot figure out how to setup the UUID Explorter program :(

It still uses it, but now you have to go into the extras folder and move the Portable.ini into main folder (next to Launcher.exe). This will make it portable and put all the files into the folder (including Launcher.sqlite). By default it puts that stuff in an external folder now. You'll have to re-do your setup / re-import your games in FS-UAE afterwards, but then you'll be good to go.

  • Like 1
Link to post
Share on other sites
23 hours ago, Zombeaver said:

It still uses it, but now you have to go into the extras folder and move the Portable.ini into main folder (next to Launcher.exe). This will make it portable and put all the files into the folder (including Launcher.sqlite). By default it puts that stuff in an external folder now. You'll have to re-do your setup / re-import your games in FS-UAE afterwards, but then you'll be good to go.

Thanks, I got that sorted out and have now completed the steps in your guide!  The only other thing I had to adjust for the newer version was the location of the .prefs file.

After getting LaunchBox setup, the only issue I now have is that SOME of my games (lets say about 10%) are not loading via Launchbox, even they work fine in FS-UAE standalone.  They are UHDLoads, .lha file.  Here is an example error message if I try to load them with Launchbox:

image.thumb.png.9d9efeb9b6beb33e9b76623a7972a995.png

They are all similar errors (just substituting their respective filenames).  Any idea what I should look at?  It says to check WHDLoad arguments, where I am just using the defaults from the database, and I don't see anything out of the ordinary

I must say, Launchbox + FS-UAE has revived the Amiga for me by bypassing the tedious front end of WinUAE.  I also didn't know about UHDLoads until I saw your guide, so that's new and exciting as well. Can't wait till I get it all working!

Edited by Centimetro
Link to post
Share on other sites

If they're not loading through LB but are in the emulator by themselves there's probably something wrong with what you have in LB. Edit one of them in LB and show me the Launching section, the Emulation section, and the Emulator entry.

As an example:

image.thumb.png.672f962924a0d7729b4e4411eb225580.png

image.thumb.png.fa914e376b0582e8d977d0ff6c3761e1.png

image.thumb.png.314678335eb5d0ff8a4dcbc0ff2d403a.png

And if you could provide the names of some specific games where you're seeing it, that could help as well.

  • Like 1
Link to post
Share on other sites

Hey, I'd love to have provided more info in case it helps anyone else out in the future, but now before you replied what I did was I just redid my Launchbox implementation -- so I delted all the games, and set them up using FS UAE UUID again.  It works now, so I can no longer figure out exactly what caused my issue.  Weird though, because I had treated all games the same, and I couldn't find any common ground between the ones that weren't working and the ones that were (vast majority were working)

I'm guessing you're right and there was some sort of problem with my Launchbox settings, and if I had to guess it probably had something to do with the fact that I didn't complete the setup of the FS UAE UUID on the first pass.  I went back and did that after you helped me with it, and I might have overlooked something that was hard for me to detect in the process.  But just starting fresh seems to have worked. Exciting

Edited by Centimetro
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...