Jump to content
LaunchBox Community Forums

Recommended Posts

I added the application to the download-page, which automatically generated a new topic. For questions / remarks, please go to:

 

 

 

 

 

 

Edited by Brian
new topic
  • Like 4

Share this post


Link to post
Share on other sites

Hi Brian, This sounds like something along the lines of what I am looking for which is to have MOVIE & MUSIC categories at Main screen with all other platforms & then launch all my personal mp4 videos & mp3 music tracks from a library with controller support without the need of KODI ect. Is this possible with this.

Share this post


Link to post
Share on other sites

Yes, it does require 2 things:

  1. that you do first set-up the Movies platform and attach a default emulator to it (not 100% sure if the emulator is required)
  2. that you get a personal API key from TMDb or use a97d897e0144c78efcf616fb5a355ecf

I attached a zip that should contain the application for Windows 64bit. Not 100% sure if it will work from anywhere.

I attached the zip to the first post.

 

Edited by Brian

Share this post


Link to post
Share on other sites

It's the first desktop application I've shared, so please let me know how / if it works on other pcs.

Share this post


Link to post
Share on other sites

Created a small update to automatically download the trailer as well (optionally). It tries to find an download the 360p mp4 from YouTube. So far, it seems to be handling this without much problems.

Share this post


Link to post
Share on other sites

Could you send me the Data\Platforms\Movies.xml file? I'll look into what went wrong.

To fix the error you can remove the same Data\Platforms\Movies.xml file.

Share this post


Link to post
Share on other sites

Did one of the movies have a &, < or > in the title? I seem to have forgot to escape these. :-\

I'll upload a new version asap.

Edited by Brian

Share this post


Link to post
Share on other sites

@andyco47

Uploaded the new version. I quite sure I fixed the XML bug, but you'll have to remove the old XML anyway, before attempting to import with the new version.

Share this post


Link to post
Share on other sites

Hmmm... 2 questions:

  1. Have you tried a second time? One of the APIs seems to be failing sometimes.
  2. Is it blocking after the 'Select platform and emulator' or 'Ready to import' screen?

I'll try to add some safe fails and a log, but it's difficult to reproduce. Hang in there and thanks for the feedback! ^_^

Share this post


Link to post
Share on other sites

I'll add this, but you wouldn't be able to play the movies. I just use rocketlauncher for everything, so I can set-up the emulators / programs at a later date.

Share this post


Link to post
Share on other sites

A new version was uploaded. Some of the new fixes were added + the option to add tv show.

Share this post


Link to post
Share on other sites
1 hour ago, spektor56 said:

github link?

Uploaded it in the first post. I'll probably upload it to GitHub soon. (still need to remove some humiliating redundant code)

Edited by Brian

Share this post


Link to post
Share on other sites

I ran this, seemed to run fine, but nothing changed in my launchbox...did I not run it in the correct location? Where should it reside? Thanks.

Share this post


Link to post
Share on other sites
17 minutes ago, cleverest said:

I ran this, seemed to run fine, but nothing changed in my launchbox...did I not run it in the correct location? Where should it reside? Thanks.

Try over here.

 

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...