Jump to content
LaunchBox Community Forums
jdubst

SNES Games in RetroArch Play Slow

Recommended Posts

Hello all,

First off, this is my first post! So long story short, I built a family PC that is hooked up to a 4k TV with a Intel i5 6500, 8GB of DDR4 RAM (PC4 17000), and an SSD. I didn't buy any graphics card for it, so it's using the Intel HD Graphics 530. I've been using this to run Project64, and have been able to play Mario Party 1/2/3, as well as Super Smash Bros. and Mario Kart 64, all with very little to no problems. Recently, I purchased a bluetooth SNES controller from RetroBit, and thought it would be great to get the SNES games going for my parents. 

So what I did was disconnect the computer from the living room, and brought it into my room, and hooked it up to my monitor via HDMI. I downloaded RetroArch, got some ROMS, set up RetroArch into LaunchBox, as well as the controller, and all games were playing well. So after all was said and done, I moved it back into the living room and hooked it back up to the 4k TV. While trying to run a game though, it was slowed down considerably. I tried downloading the other cores and changing it within LaunchBox, but to no avail. I tried using BSNES Balanced and Accuracy, as well as Performance, all with the same result. Nothing changed, in fact. I tried opening RetroArch outside of LaunchBox, and running a game like that, and still got the same issue. What was odd, though, is that I downloaded SNES9x, and ran it outside of LaunchBox, and it ran at normal speed. I tried putting SNES9x into LaunchBox, but couldn't figure it out. 

Could someone shed some light as to why RetroArch would slow down after moving it to the 4K TV in the living room? It played well on my monitor, which is 1080, but I doubt the resolution is the cause. Any ideas?

Share this post


Link to post
Share on other sites

I'm heading off to bed but give this a try and post back with your results. I will check in tomorrow and see how it went and if anything else needs to be done.

First what is the clock speed of your CPU ?

Until I check back tomorrow use the Snes9x core (not one with a year in the name). Load up a game like Super Mario World, then bring up the quick menu and go to the Video settings and scroll down. Check and see if Hard GPU Sync is On or Off, it should be On for lower input lag. Next look for Hard GPU Sync Frames and set it to 1 if it is set to 0. If this still doesn't work turn off Hard GPU Sync and see if that fixes your issues.

Share this post


Link to post
Share on other sites

Yea it sounds like a potentially odd setting in RetroArch. If you could pull a clean RetroArch.cfg (Or update to the latest nightly) and try with completely default settings too, that might shed some light on to what's been changed.

Share this post


Link to post
Share on other sites

Hey guys,

So I downloaded the newest RetroArch Nightly, and added it into LaunchBox, and it didn't change. 

lordmonkus, I also tried going into the settings like you recommended, and I'm still getting the same issue. My processor is clocked at 3.2GHz, so I'm really confused as to why it's so slow. It played fine on my 1080 monitor, but slows down on the 4K TV. Really confusing.

Share this post


Link to post
Share on other sites

Ok if you don't know then most likely you aren't using any shaders at all. To double check load up a game and in the quick menu under shaders look for "shader passes" it should be 0 if there are none. I was kind of thinking that maybe if you were using a shader that rendering it at 4k maybe causing a performance bottleneck.

Did you set Hard GPU Sync to Off ?

I found one thread on the Retroarch forums where a user reported that hooking up to a TV caused bad performance and setting Hard GPU Sync to Off fixed it. On is the preferred setting to reduce input lag.

Share this post


Link to post
Share on other sites

Unfortunately I am really at a loss for why you would have performance issues swapping from the monitor to a TV. I Have a PC hooked up to my TV (1080) and it runs the Snes9x core  just fine. The PC is nothing special either, it's an older 2.2 Ghz AMD CPU with 2 gigs ram. I even run it with Hard GPU Sync On though I have to set the frames to 1.

You could try turning Threaded Video On but that really is not a preferred option as it introduces some input lag. It's really meant for low end hardware and it is sort of a last resort to getting things playable.

You may want to try posting over on the Retroarch forums and hopefully someone like hunterk of one of the other real experts over there can help you out with it. If you are just using stock

Share this post


Link to post
Share on other sites

Could the TV be causing issues itself does it have a game mode setting

Share this post


Link to post
Share on other sites

lordmonkus, I actually turned on the Threaded Video after going through all the options under the Video settings. It started running the games fine. As for having input lag, is that with actually playing the game? I'll play for a little bit and see how it is.

DOS76, it honestly shouldn't matter. It plays N64 emulators with the Project64 emulator with no issues. I don't see why it would be any different for running RetroArch.

Share this post


Link to post
Share on other sites

I guess it could be the TV itself, I have zero experience with 4K TVs. Game mode usually just turns off some video processing shit that causes input lag but I guess it could be possible it does more shit on 4K TVs that might cause issues.

Share this post


Link to post
Share on other sites

Yeah Threaded Video can cause some input lag in the game itself. It's certainly not an ideal setting to have on and judging by your CPU it really shouldn't have to be on. My system I mentioned I have hooked to the TV doesn't need it on to run the Snes9x core.

Share this post


Link to post
Share on other sites

I have a Samsung 1080p and it isn't worth shit unless gaming mode is on games run choppy and input lag is beyond noticeable once in game mode its all smooth

Share this post


Link to post
Share on other sites

I think I turned on Gaming Mode on my TV almost immediately so I never saw any gaming related issues with it at all.

Share this post


Link to post
Share on other sites

I know nothing also about 4K TV's, but I know that a lot of TV's of that nature upscale lower quality pictures to 4K, maybe that might be the issue?

I know also having looked for ages for the right 1080p tv some years ago that some TV's had really bad input lag, but as far as I understand this would only be an issue for high end pc gaming and I would think running SNES shouldn't  cause any problems.

Anyway, food for thought!

I hope you figure it out

Edited by InfinityFox

Share this post


Link to post
Share on other sites

The input lag is because of the way it processes the image and it's there for everything, it's just a matter of how much is there and for gaming the TV should definitely be set to gaming mode.

Share this post


Link to post
Share on other sites

So there is a game mode for my tv, but I'm not able to turn it on for whatever reason. I think it needs to recognize a console to activate it, but I'm not entirely sure.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...