Jump to content
LaunchBox Community Forums
jdubst

SNES Games in RetroArch Play Slow

Recommended Posts

It's a Samsung UHD 4k 6290.

EDIT: So I found out how to enable Game Mode. I had to make the TV recognize it as a console... which is a bit odd, but it works. Now when I try turning off Threading, it crashes RetroArch and doesn't save it... how can I turn this off without it crashing on me?

EDIT 2: So I just redownloaded RetroArch and put it in the same location. So Threading is off; however, still getting the crazy lag. So for now, I'll just stick with it being on.

Edited by jdubst

Share this post


Link to post
Share on other sites

Just a quick search on google I came across someone experiencing loads of lag. Granted they are using consoles, but they touch on up scaling being part of the problem. I wonder If upscaling is enabled in gaming mode? Can you turn it off?

I'm not sure about Retroarch, but maybe popping into the forums over there and seeing if anyone has had similar problems there would be beneficial.

 

Share this post


Link to post
Share on other sites

If the computers chosen resolution is really large, maybe RetroArch has issues with some cores rendering above a certain threshold? It certainly sounds like a RetroArch issue, and it could be related to the resolution it wants to pump out at.

Share this post


Link to post
Share on other sites

I recently had this same problem. I hooked my gaming pc up to my 4k tv and suddenly all retroarch cores started running very slowly. Finally I found that if I went to to retroarch.exe and disabled dpi scaling it fixed the problem. I have found that this solves a lot of problems I've been having since I upgraded to Windows 10

Share this post


Link to post
Share on other sites

I think that's more a 4K issue than Windows 10. I use Windows 10 without issues but I have heard of lots of minor problems when using 4K TVs, like framerate and refresh rates.

Share this post


Link to post
Share on other sites

That could be, I did switch both around the same time. I did notice that with the scaling on my refresh rate was dropping to around 30, which was causing the issues. With dpi disabled it went back to normal.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...