Jump to content
LaunchBox Community Forums
noiseordinance

Bigbox lag

Recommended Posts

Alright, sigh. Back to the drawing board then I guess. Can you all try turning off Use All Controllers in the options to see if that makes any difference?

Share this post


Link to post
Share on other sites
1 hour ago, Jason Carr said:

Alright, sigh. Back to the drawing board then I guess. Can you all try turning off Use All Controllers in the options to see if that makes any difference?

Thanks for your work @Jason Carr, I will give this a spin for you tonight and update again tomorrow. Just to confirm as well mine is identical with the video still playing behaviour mentioned by @noiseordinance

Share this post


Link to post
Share on other sites

Ok tried turning off all controllers and bingo!!  smooth as with either repeated up or down presses on controller or holding down and rapid scroll through. I did try this setting on previous versions and it made no difference (not sure if that anecdote is useful to diagnosis).

What does this setting do exactly, just means only one controller can operate Big Box?

thanks

Share this post


Link to post
Share on other sites
20 minutes ago, Rjay said:

What does this setting do exactly, just means only one controller can operate Big Box?

Yes.

Share this post


Link to post
Share on other sites
1 hour ago, Rjay said:

Ok tried turning off all controllers and bingo!!  smooth as with either repeated up or down presses on controller or holding down and rapid scroll through. I did try this setting on previous versions and it made no difference (not sure if that anecdote is useful to diagnosis).

What does this setting do exactly, just means only one controller can operate Big Box?

thanks

Good to hear. The Use All Controllers option is certainly more resource-intensive. What it does is searches the computer for new controllers every so often, which may be causing the hiccups, as well as the previous threading issue that I fixed. So that is good to know. Let me know if you start to see any issues again with that option turned off.

@thetwistedblue @noiseordinance Please try turning off Use All Controllers in the options to see if it fixes it for you as well. If Use All Controllers is the issue, I might be able to fix it, but I might not, since it's just the nature of parsing the system for new controllers.

Share this post


Link to post
Share on other sites

i'm using Nostalgia theme, and I get quite bad lag going through my theme, and I don't use a controller.. only keyboard

Share this post


Link to post
Share on other sites
2 minutes ago, Kovu1102 said:

i'm using Nostalgia theme, and I get quite bad lag going through my theme, and I don't use a controller.. only keyboard

This would be caused by system performance issues then.

Share this post


Link to post
Share on other sites
3 minutes ago, Kovu1102 said:

i'm using Nostalgia theme, and I get quite bad lag going through my theme, and I don't use a controller.. only keyboard

The Nostalgia theme is one of the heaviest ones we have in the download section, so yes that could certainly be a performance issue rather than a controller issue.

Share this post


Link to post
Share on other sites
3 minutes ago, neil9000 said:

The Nostalgia theme is one of the heaviest ones we have in the download section, so yes that could certainly be a performance issue rather than a controller issue.

I have a i7 4790 3.6Ghz, 8gb Ram, GTX 780ti and Windows 10 Pro.. I didn't think I would get that much of a performance drop

Share this post


Link to post
Share on other sites
1 minute ago, Kovu1102 said:

I have a i7 4790 3.6Ghz, 8gb Ram, GTX 780ti and Windows 10 Pro.. I didn't think I would get that much of a performance drop

Certain themes can tax even relatively well-equipped systems. Unfortunately that hardware is no longer considered high-end. 8 gigs of RAM can be limiting in Big Box, as well as the 780ti. It also could be a hard drive performance issue if you're not using an SSD.

Share this post


Link to post
Share on other sites
Just now, Jason Carr said:

Certain themes can tax even relatively well-equipped systems. Unfortunately that hardware is no longer considered high-end. 8 gigs of RAM can be limiting in Big Box, as well as the 780ti. It also could be a hard drive performance issue if you're not using an SSD.

okay thanks :) my Win 10 is on a SSD yeah.. maybe I just need more ram and new gpu

  • Like 1

Share this post


Link to post
Share on other sites
2 minutes ago, Kovu1102 said:

okay thanks :) my Win 10 is on a SSD yeah.. maybe I just need more ram and new gpu

I would start with the RAM upgrade if you can, and see how it performs. :)

Share this post


Link to post
Share on other sites
2 minutes ago, Jason Carr said:

I would start with the RAM upgrade if you can, and see how it performs. :)

thanks for the help Jason :) greatly appreciated 👍

  • Like 1

Share this post


Link to post
Share on other sites

Thanks @Jason Carr, if @noiseordinance can confirm the fix with the Use all controllers tick box then yeh I would say we have narrowed it down and you can try a software fix :)  obviously one of the other changes in the new version of Big box has assisted with the fix as I had definitely tried this setting before.

I will double check again tonight that the issue is gone as well for my own sanity :)

  • Like 1

Share this post


Link to post
Share on other sites
8 minutes ago, Rjay said:

Thanks @Jason Carr, if @noiseordinance can confirm the fix with the Use all controllers tick box then yeh I would say we have narrowed it down and you can try a software fix :)  obviously one of the other changes in the new version of Big box has assisted with the fix as I had definitely tried this setting before.

I will double check again tonight that the issue is gone as well for my own sanity :)

I just acquired a GPD Win 2 (which is amazing BTW) and I'm seeing the same thing; hiccups are there, but only with Use All Controllers enabled. I'll look to see if there's anything I can do to fix that, if possible. :)

Share this post


Link to post
Share on other sites
1 hour ago, Jason Carr said:

I just acquired a GPD Win 2 (which is amazing BTW) and I'm seeing the same thing; hiccups are there, but only with Use All Controllers enabled. I'll look to see if there's anything I can do to fix that, if possible. :)

 

Awesome, definitely will make it easier now you have a test platform presenting the issue. I actually had to google what that device was, pretty crazy it looks like the DiNovo Mini Keyboards that used to be used for media centres but with a computer stuffed inside :)

Share this post


Link to post
Share on other sites
51 minutes ago, Rjay said:

 

Awesome, definitely will make it easier now you have a test platform presenting the issue. I actually had to google what that device was, pretty crazy it looks like the DiNovo Mini Keyboards that used to be used for media centres but with a computer stuffed inside :)

It's a pretty sweet little device. Runs Big Box butter smooth without that controller issue. Having MAME on the go is amazing.

Share this post


Link to post
Share on other sites

I just put out beta 6 which does have some minor controller performance improvements, but I still doubt it will fix the lag with Use All Controllers. I'm going to be doing some more testing with my GPD Win 2, but feel free to let me know if there's any difference.

The way the "Use All Controllers" feature works is that it parses the system for new controllers every five seconds, and if you want LaunchBox to automatically find new controllers, there's not really any way around it that I can see. So beyond what I've done, we might be out of luck. At least most people will be able to just turn that feature off if they're experiencing lag.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...