Jump to content
LaunchBox Community Forums
kpop

no mednafen saturn in retroarch

Recommended Posts

im trying to setup sega saturn trough retroarch and saw thatit rs alot better on mednafen core compared to yabause, but my retroarch doesn't seem to have, i have followed brads saturn vid to update retroarch to the nightly, but still no luck.

Share this post


Link to post
Share on other sites

It should be there, try updating the core info using the online updater, the core is labeled "Sega Saturn (Mednafen Saturn)"

Share this post


Link to post
Share on other sites

i updated all the files on 1.40 and 1.36 of retoarch and all there is coming up is yabuse saturn core.

Share this post


Link to post
Share on other sites

putting it in manually has fixed it, cheers, just got to get the right bios now. thanks

Edited by kpop

Share this post


Link to post
Share on other sites

Weird. I had the same issue with a freshly downloaded 1.6.  The mednafen cores including the Saturn one I wanted specifically to try, were simply not there in the updater. Thought I was going mad, searched online, ended up here. Followed Lord Monkus's advise to add the core manually. But - then the core sure enough showed up in Load Core, but wouldn't run. Restarted retroarch and now the mednafen core does not show up, but now RA shows the beetle Saturn core is installed - which I never installed. Very odd.

Well, then I DLd 1.5...same thing. No mednafen cores listed. WTF? They just aren't there. Finally I got the latest nightly, the Mednafen Saturn core still not listed. Installed core manually and this time I could load it. But. Loading cue files...no. "Failed to load content". Several known working games tried. *sigh* Not having any luck at all with anything, at the mo. Grrr. As a relative newb with emulators I have found you just run into a streak of being snakebitten sometimes while at other times it's smooth as butter. Tired, cranky, going to bed.

Incidentally, the reason I even want to try the Mednafen Saturn core is that in the stand alone Mednafen, all my Saturn games run, in fullscreen,  in a window - i.e. black bars on all four sides. On the sides it's fine, I want the native aspect ratio. But black bars top and bottom also, making the image smaller. I have scoured the internet and tried some things, poked around in the config file, to no avail. To try to alter the resolution, etc. to fix the issue and get true fullscreen with the 4x3 ratio. Anyone have any suggestions for that as well?

Cheers, it's 12:21 am here, work tomorrow...Haven't actually played one game this evening... G'night!!

Share this post


Link to post
Share on other sites

You're fracking kidding me. Why???? Okay well thanks for the very quick response. Why can't they just be called Mednafen for the love of all that is holy??

Share this post


Link to post
Share on other sites

Not really sure of the reason for the name change but my guess would be to differentiate ?? I don't know why the Retroarch guys do some of the things they do, I just accept it and deal with it, lol.

As for your black bars, try turning off aspect ratio in the video settings if you have it set to on. If that doesn't work you may have to set up a custom aspect X by Y to get as close to the edges as you want.

Personally I like aspect ratio on because it works best for CRT shaders and I have a 1440p monitor so the bars at the top and bottom are small and not very bothersome at all. At 1080p though the top and bottom bars can be quite noticeable.

As for games not work but working before were they working in Mednafen before or another emulator like SSF ? If another version of Mednafen they should work in the new ones but if SSF you may need new disk images or repair the ones you got. I have posts on the forums on how to do it.

  • Like 1

Share this post


Link to post
Share on other sites

Yeah...I've noticed the way the Retroarch folks go about doing things can be quirky at times. And confusingly you can still get the Mednafen cores to install manually. That's why I've dabbled in RA but ultimately stuck with the individual ems with LB.

Thanks for all your help and info. I do have a 1080p setup. In fact, it's a 110" projector so the games are far from small, I should probably just deal with it, but it's just something that started to bug me so I've been devoting time I probably should've spent on actually playing games trying to solve or work around it.

It is for games that are known to work, in Mednafen stand alone. In fact for Radiant Silvergun it worked in Yabause but not Mednafen, I finally got it working by using CDmage to rengenerate the bin and cue, I probably came across your info on that so thanks again. Unfortunately the Beetle core is still showing failed to load content. I give up for now. I'll take some of your kind suggestions and try to fix the Mednafen stand alone tomorrow.

Share this post


Link to post
Share on other sites

Weird that Radiant Silvergun failed for you using the RA Beetle core, it works for me. Maybe you need a new image, Mednafen is pickier over the quality of the disk dumps than Yabause and SSF.

  • Like 1

Share this post


Link to post
Share on other sites

Yeah tried several known working games in stand alone Mednafen, but with RA 1.6.0 and the Beetle Saturn core, failed to load or just straight up crashed. Went back to my previous 1.2.2 Retroarch, installed Saturn Beetle. Crashes every time when loading games. I dunno...black bars...who cares?? My Saturn setup with LB and Mednafen stand alone is brilliant except for that.

Share this post


Link to post
Share on other sites

That is very strange that a game would work in the stand alone but not in RA core unless maybe they were the PAL region ones since those were kind of problematic at first.

Share this post


Link to post
Share on other sites

RetroArch 1.2.2 predates mednafen saturn core so doubt it works there.

Share this post


Link to post
Share on other sites

Okay! Well thank you Lordmonkus for the suggestions, they were perfect. I was able to get true fullscreen with the stand alone Mednafen. If anyone else has the same issue of black bars on all four sides I did the following in the config file:

Set [system].stretch, for the Saturn, ss.stretch to 0.

;Stretch to fill screen.
ss.stretch 0

It had been set to aspect_mult2 and I had the pretty severe windowbox effect in fullscreen. Changing to aspect helped some. But I put it to zero which made it the native resolution, very tiny on a 1920x1080 monitor. I adjusted the scaling factor settings and was able to get it perfectly sized. In my setup the perfect setting was:

;Scaling factor for the X axis in fullscreen mode.
ss.xscalefs 4.85

and

;Scaling factor for the Y axis in fullscreen mode.
ss.yscalefs 4.85

You could play with increasing the x axis for a more widescreen effect. I did the same thing with Turbografx as that had the same issue.

Now it's perfect! Thanks again!

p.s. - sorry for sort of hijacking and re-routing the original thread

Edited by usuallee76
p.s.

Share this post


Link to post
Share on other sites

Beetle isn't a made up name. It is a code name, or an alt name for Mednafen, but I don't know why they chose to switch to it either. (sorry, getting out late responses).

Share this post


Link to post
Share on other sites

I updated my cores and I don't have anything called Beetle... it's still mednafen as far as I can tell... at least in my cores folder.

I am having trouble loading discs.  It goes to the Saturn disc load screen.  Is the name of the BIOS supposed to be the same as the standalone Mednafen?  sega_100a.bin?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...