Jump to content
LaunchBox Community Forums
Retro808

zSNES not exiting game

Recommended Posts

I have been setting up LB and BB for the past week and so far I have been able to search and find answers to any issues I have had. However, this one I am stumped and I am sure the answer is on the forum just the keys I am searching for are not turning up an answer.

From either LaunchBox or BigBox I cannot get zSNES to exit a game and return to the frontend. All other systems work fine. I am running zSNES off the standalone. It was one of the second emulators I loaded before I started using Retroarch to run most systems. 

zSNES buttons are configured to my 8Bitdo controllers and both LB and BB have the controller automations set. I can exit NES run off of standalone virtuanes and playstation which is run off eSPXe standalone just fine. All the systems on Retroarch exit fine as well. 

Grateful for any help from this awesome group!

Share this post


Link to post
Share on other sites

I would suggest just going with RetroArch if you are already using it. ZSNES is supposed to be a fond remembrance now days not your go to SNSE emulator. 

Edited by DOS76
  • Like 1

Share this post


Link to post
Share on other sites

Thanks @DOS76 

That's what I was thinking of doing. Just have not messed with changing emulators yet. Figured I would see what came of my post query first.

Would you mind letting me know if I am correct....

Just go into LB tools and edit the emulator path/details in the "manage emulators" options? 

Share this post


Link to post
Share on other sites
3 minutes ago, Retro808 said:

Thanks @DOS76 

That's what I was thinking of doing. Just have not messed with changing emulators yet. Figured I would see what came of my post query first.

Would you mind letting me know if I am correct....

Just go into LB tools and edit the emulator path/details in the "manage emulators" options? 

Correct, you would also need to change the emulator for your snes games. Click on the platform, then a game, ctrl a to highlight them all, right click, edit, choose emulator from the dropdown then retroarch from the second dropdown.

  • Like 1

Share this post


Link to post
Share on other sites
10 minutes ago, neil9000 said:

Correct, you would also need to change the emulator for your snes games. Click on the platform, then a game, ctrl a to highlight them all, right click, edit, choose emulator from the dropdown then retroarch from the second dropdown.

@neil9000 Thanks for the tip. 

One last question. I think. In the associated platforms tab do I leave all the ones that are with check marks checked making sure the Super Nintendo one is checked as well? Or do I uncheck all except the SNES one?

Likely that was a noob question, but well I am. :D

Share this post


Link to post
Share on other sites
24 minutes ago, Retro808 said:

@neil9000 Thanks for the tip. 

One last question. I think. In the associated platforms tab do I leave all the ones that are with check marks checked making sure the Super Nintendo one is checked as well? Or do I uncheck all except the SNES one?

Likely that was a noob question, but well I am. :D

No, leave them all checked, that will make it easier if you decide to use retroarch for other platforms as well. Also bare in mind that there are several snes cores in retroarch, so you need to make sure that the one you are using is the one specified in the associated platform list. I think it defaults to snes9x, but I use bsnes accuracy, so I had to amend the associated platform snes core to say bsnes rather than snes9x.

Share this post


Link to post
Share on other sites

Bsnes Balanced is just as good too if you get any performance hits. Accuracy requires a fairly beefy CPU. Just make sure to download the core and change the command line if you switch.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...