Jump to content
LaunchBox Community Forums

MAME exits


Recommended Posts

Hey everyone

first of all: I really love this software and I am gonna buy (soon enough, as everything is going to work fine) Big Box - so i am probably gonna ask many more questions since i am not really good with this kind of stuff (sorry).

Anyhow, I've come to the terrible moment when I need to make the MAME work (i did it a few times during the years, and yeah i still suck at it).
I've decided to change this old server from a Lakka distribution to Windows with LaunchBox and - for that - i have a 2003 MAME romset. All my roms are compatible with version 0.78 of MAME (with Lakka i used MAME2003 core to run games).
I tried to import just a game (Metal Slug 2, to be precise) and when i launch it with LaunchBox I get a black screen and then it goes back in the LaunchBox dash.
I followed the Youtube guide, so pretty much i had to browse to the .exe of mame and that's all. I've also already tried to download the latest version and the 0.78 version, pointing to both the .exe but i get pretty much the same result with both emulators.

I remember, back in the day, that mame needed a lot of different Bios to work with every game (i can talk about bios stuff right? I am always worried it could be against the rules, sorry in that case) so maybe i am missing that?

So, anyways, what can i do?

Thanks!
Keep up the good work.
Alessio

Link to post
Share on other sites
29 minutes ago, lordmonkus said:

You can check out the guide I made here:

 

Hi! Thank you for your answer.

I actually did what you told in your tutorial, so i used the prompt.

Anyhow when i try to launch mslug2 i wrote: 

mame64.exe mslug2

but after a black screen and loading i got this:

Error creating DirectSound: 88780078
sfix.sfix NOT FOUND (tried in mslug2 neogeo mslug2)
000-lo.lo NOT FOUND (tried in mslug2 neogeo mslug2)
sp-s2.sp1 NOT FOUND (tried in mslug2 neogeo mslug2)
sm1.sm1 NOT FOUND (tried in mslug2 neogeo mslug2)
Fatal error: Required files are missing, the machine cannot be run.

Uhm... i am guessing a thing - not sure if it helps.
I didn't install - yet - driver sounds for this pc (i installed windows 7 today).
Could that be the problem? 

Edited by Smilator
Link to post
Share on other sites
Just now, lordmonkus said:

Yeah that rom set is way out of date for that version of Mame.

You should either look into updating your romset or use a version of Mame to match your roms.

Well i don't care about updating my roms, so i am gonna go trying with an older Mame.
What about the 2004 update?

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...