Jump to content
LaunchBox Community Forums
Zombeaver

Zombeaver's Retroarch PSX and Saturn Overrides

Recommended Posts

Hi again,

 

I have tried these and its all working, just doubled the numbers for my 4k screen and that worked, looks good! 

 

I want to add an overlay, but it now doesn't fit correctly because of the adjustments to the screen position.

 

Are you able to help on how i fix it?

Share this post


Link to post
Share on other sites

You won't be able to use overlays with these - the amount of unused screen space to the left and right of the image varies greatly from one game to another because of all the different resolution modes the PSX used (which is kindof the whole reason this project was needed in the first place). In some cases they can be in a nearly 16:9 format already. Just take a look at the gif in the opening post and notice the amount of blank space to the left and right of each one and see how much it can change from one game to the next. Overlays do not adjust to the size of the video - they're literally just static images (with fixed dimensions) placed on top. If you were to use one you'd end up cutting off the sides on some games or having blank space beside them on others because of how much the size varies.

Share this post


Link to post
Share on other sites

Just found this thread and once again a big Thanks to you Zombeaver!

I was looking to fix my PSX games but you did it already and shared your work! And by doing so you are saving me and others a LOT of time and frustration. It's really amazing and I can't express it enough.

Thank You! :)

 

By any chance, do you plan on porting your deinterlacing shaders to Slang so we can use them with the new DX11 or Vulkan drivers?

Edited by Nocta

Share this post


Link to post
Share on other sites

Tried this out tonight and on PSX games, I'm getting this line of bright pixels along the very right edge of the viewport. This goes away when I turn off the crt hylian shader. Any idea what the problem is here?

 

 

Klonoa.jpg

Share this post


Link to post
Share on other sites

So just FYI, for anyone that's updated to RA 1.7.4, these will probably be messed up as it would seem that they've added a new aspect ratio number for something and it's shifted all the numbers up 1 (so whereas core-provided used to be aspect_ratio_index = "21" in override terms, it's now 22, and custom used to be 22, and is now 23). This should be an easy fix with Notepad++ so I'll take care of this tonight and upload a new version of them.

  • Like 1

Share this post


Link to post
Share on other sites

Alright, if anybody has any issues let me know, but they should be good to go now with the new numbers. The opening post has been updated with the new files.

These will not work correctly if you're using versions of Retroarch prior to 1.7.4. The older versions of the overrides are still available for older versions of Retroarch.

Share this post


Link to post
Share on other sites

Hi Zombeaver,

I just upgraded to a 4K screen and I'd like to keep your configs at least for the proper controller settings.
Could you maybe guide me on what I have to remove or change in your settings for it to work in 4K?

Also have you seen this article about Beetle HW and did you try the SSAA implementation? It seems very nice!

 

Thank you!

Share this post


Link to post
Share on other sites

You would have to adjust numbers in all of them. 4k is double 1080p, so in theory you would double the width and height resolutions, but the other issue would be the x and y position adjustments - I'm not sure how much those would need to be adjusted. Unfortunately it's not something I can test as I don't have access to a 4k monitor currently.

Share this post


Link to post
Share on other sites

Ok I’m wondering if it makes sense to fiddle with it then, I now have a 42inch screen so I can loose some part of the screen, it should still be big enough or is it doing something else I’m not aware of?

Share this post


Link to post
Share on other sites
Posted (edited)

Hello all.  I am currently tinkering with a saturn game, called Zero Divide, the final conflict, using beetle saturn core on retroarch. Problem is that it suffers from heavy interlacing, like Fighting Megamix and other 2d fighting games. I downloaded the beetle override pack from here, replaced the fighting megamix one with the name of thie game..and now it looks and plays much better! the only issue though? the windows size is the same of a postcard....see screenshot 01.

 

i tried going to video > Aspect ratio, but all the other aspect ratio like 16:9 etc just makes the game looks muddy and blurry. see screenshot 2. any help?

 

 

 

screenshot 01.jpg

screenshot 02.jpg

Edited by Solstar

Share this post


Link to post
Share on other sites

You would have to adjust the width, height, x, and y coordinates. Judging from your screenshot, it doesn't show those unless you have advanced settings visible. They can be enabled in Settings > User Interface > Show Advanced Settings.

Then, underneath Aspect Ratio, you should see:

"Custom Aspect Ratio X Pos"
"Custom Aspect Ratio Y Pos"
"Custom Aspect Ratio Width"
"Custom Aspect Ratio Height"

You can adjust these to get the right width, height, and position. Once you get the right setting, go to Quick Menu > Overrides > Save game override.

Rather than individually changing dimensions/position, you could alternately 1) set it to 4:3 (though there may be some blank space at the top and bottom) or you could 2) set it to custom, turn integer scaling on, and then increase the width/height integer until it touches the top and bottom of the screen (though it may cut off some of the top and bottom of the image if you do this). If you do this, you will again need to go to Quick Menu > Overrides > Save game override to save it.

Share this post


Link to post
Share on other sites
Posted (edited)
3 hours ago, Zombeaver said:

You would have to adjust the width, height, x, and y coordinates. Judging from your screenshot, it doesn't show those unless you have advanced settings visible. They can be enabled in Settings > User Interface > Show Advanced Settings.

Then, underneath Aspect Ratio, you should see:

"Custom Aspect Ratio X Pos"
"Custom Aspect Ratio Y Pos"
"Custom Aspect Ratio Width"
"Custom Aspect Ratio Height"

You can adjust these to get the right width, height, and position. Once you get the right setting, go to Quick Menu > Overrides > Save game override.

Rather than individually changing dimensions/position, you could alternately 1) set it to 4:3 (though there may be some blank space at the top and bottom) or you could 2) set it to custom, turn integer scaling on, and then increase the width/height integer until it touches the top and bottom of the screen (though it may cut off some of the top and bottom of the image if you do this). If you do this, you will again need to go to Quick Menu > Overrides > Save game override to save it.

Thank you! the first method works, though as i moved ratio width\height, the screen got some weird green flueo tint, one width yes, and the other not. setting it to 4:3 just make the screen with that weird green tint (and the shape is way too small), the third one seems to works better, but the colors seems to be "fluorescent"

Edited by Solstar

Share this post


Link to post
Share on other sites

The shader presets used in each override are designed for 1080p. If you're using higher than that, you'd have to adjust scaling in the shader preset itself to something higher. I couldn't tell you to what exactly as 1080p is the only thing I have at my disposal. You'd need to adjust the scaling of the first pass. I'd try using a different version of the preset first - the #X corresponds to the scaling: 2X, 3X, or 4X. The one specified in the Fighters Megamix override is CRT-Deinterlacing-Soft-3X.glslp

  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)

ok i tried 2 , and so far seems to be good, but maybe something's messed up...for better in my case. seems like now automatically it will load the shader "bob and interlace", but the effects are the ones loaded from the shader preset..and now i have the correct full screen view, without scalines or other interlacing artifcats. so, uhh, GG ? XD

Edited by Solstar

Share this post


Link to post
Share on other sites

Just installed 1.7.8 of retroach, seems lihe the preset shaders cannot be loaded anymore :(

Share this post


Link to post
Share on other sites

no they changed something in the config file and I can't remember what it was now but you may be able to find posts about it on the forums.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...