Jump to content
LaunchBox Community Forums

Retroarch and Commoroe 64 : 3 new cores! 3rd one - VICE 3.0 (Commodore 64 emulator)


Recommended Posts

This is going to be really dumb, but I don't know anything about GIT and I'm having trouble downloading those files for the "data" folder. Any suggestions?

 

Update: If you're having the same issue, you can go to this website: https://minhaskamal.github.io/DownGit/#/home

Input the address for the data folder, should be: https://github.com/libretro/vice-libretro/tree/4ef3e4f6b4b9f52b15444f7e4cd53e93c73c948e/vice/data

And click download. This can take a minute, but it will download a zip of the data folder.

 

However, even with this in place, I can't personally get the core to work properly. It'll load up the core, but it give an error Cannot locate Device*  and not load the game. May you have better luck. :D 

Edited by fromlostdays
Link to post
Share on other sites
8 hours ago, fromlostdays said:

However, even with this in place, I can't personally get the core to work properly. It'll load up the core, but it give an error Cannot locate Device*  and not load the game. May you have better luck. :D 

Make sure that in retroarch-core-options.cfg you have these settings:

vice_Statusbar = "disabled"
vice_Drive8Type = "1541"
vice_DriveTrueEmulation = "enabled"
vice_RetroJoy = "disabled"
vice_Controller = "keyboard"

  • Like 2
Link to post
Share on other sites
Make sure that in retroarch-core-options.cfg you have these settings:

vice_Statusbar = "disabled"
vice_Drive8Type = "1541"
vice_DriveTrueEmulation = "enabled"
vice_RetroJoy = "disabled"
vice_Controller = "keyboard"

@Crush you're a genius. Worked like a charm.

Sent from my SAMSUNG-SM-N910A using Tapatalk

Link to post
Share on other sites
  • 11 months later...

Sorry for refreshing an old thread, but I came across this thread when looking for an answer for my problem with a gamepad in VICE core and I found a solution by accident so I decide to share it here. Maybe someone who went the same way would find it useful.

Commodore 64 uses second port for the first player, so you need to use the second gamepad or use the following setting to have it on first port:

Quick Menu > Options > Retro joy0 [ON]

  • Like 1
  • Thanks 1
Link to post
Share on other sites
  • 1 year later...
On 3/20/2018 at 7:37 PM, siggard said:

Sorry for refreshing an old thread, but I came across this thread when looking for an answer for my problem with a gamepad in VICE core and I found a solution by accident so I decide to share it here. Maybe someone who went the same way would find it useful.

Commodore 64 uses second port for the first player, so you need to use the second gamepad or use the following setting to have it on first port:

Quick Menu > Options > Retro joy0 [ON]

retro joy in not avaiable in VICE :(

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...