Jump to content
LaunchBox Community Forums
Maul83

PCSX2 save states won't work if playing in Launchbox

Recommended Posts

When I play any game in PCSX2 from Launchbox, if I press the save state or load state buttons (F1 and F3) it won't work. If I load the emulator first, and load the game, I can use these buttons.

My configuration is I launch launchbox through Steam, then launch what ever game in launchbox. I don't think Steam is the issue, as the save states will work if I either launch the emulator from steam, or open the emulator instead of the game in launchbox. 

I rather just be able to open the game in launchbox and have it work, as I use a steam link often and navigating the emulator menus is a pain when doing that. 

 

Update: 

After trying again, save states worked for a whole session. About an hour. 

I then exited out and went right back in, and it loaded the last state at start up fine, but after that it stopped accepting the commands, either on key board or using the shortcuts on the controller. 

It seems like sometimes, the savestate/loadstate buttons will work momentarily upon loading the emulator from launchbox, and then stop accepting those buttons. And other times, it accepts the commands everytime. 

 

Update 2:

I think I figured out a fix, will keep this up in case it helps anyone. Launchbox makes two windows, a PCSX2 window, and the game.  If I alt-tab to the PCSX2 window, then back to the game window, it will work for the whole session.

Edited by Maul83

Share this post


Link to post
Share on other sites

This is an old topic, but i just had to say thank you! I've been searching for a way to fix this all day and this absolutely works 100% of the time.

I'm curious though if this is a bug within PCSX2 or Launchbox though? Either way not the most convenient solution but definitely better than nothing at all.

Share this post


Link to post
Share on other sites
46 minutes ago, JamesBond@ge said:

Do you launch LaunchBox through Steam? Like the OP does?

No I don't. I launch my games right from BigBox and I have BigBox setup to run at windows logon.

32 minutes ago, CTRL-ALT-DEFEAT said:

You might try also suppressing PCSX2's UI:

In Manage Emulators, add --nogui to the command line parameters for PCSX2

Yes I do have the --nogui and --fullscreen parameters set for PCSX2. I'm also running the latest dev build of PCSX2 (1.5.0 2456)

Unfortunately no matter what i did to re-enable my hotkeys it just wouldn't work. So I set up Joy2Key to set my left thumb click to be "alt" and a double click of the right stick to be "tab" so I could alt+tab to the PCSX2 log window and then back and now the hotkeys work again. Not sure why this works but it does.

UPDATE: This seems to be a problem with either PCSX2 in general or my specific install/build. I just launched a game from commandline without using Launchbox or BigBox and the problem continues to persist. Maybe the --nogui parameter is messing with it (since it disables the interface that the hotkey menus are located), but I can rule out Launchbox\Bigbox as the culprit...

Edited by SonsofOcelot

Share this post


Link to post
Share on other sites

I was going to blame Steam, but I can't now :-)

I do the same as you, BigBox launches at startup. Erm. I'm a bit stumped because PCSX 1.4 and the Nightly builds don't mess about like this for me.

I'm not at my Games PC now so I can't check, but try removing that --nogui parameter and see what happens? I don't think I have that on mine because the two little windows pop up when I run it. It probably won't do anything. Just curious though.

Share this post


Link to post
Share on other sites

Nope, removing --nogui changes nothing. It still refuses to use the hotkeys.

Would you mind checking to see if your PCSX2 setup in Launchbox maybe has an auto hotkey config? I ask because escape still works for me and it is the only thing setup in my auto hotkey tab. I doubt this has anything to do with it either but I figure it couldn't hurt to check.

UPDATE: Wow I feel kinda dumb. So what was happening was GeForce Experience was showing a notification when the emulator was launching the game causing the emulator to lose focus and thus break my hotkeys... Turned off those notifications and like magic hotkeys work again haha. Something so simple causing so many problems. Thank you JamesBond@ge and CTRL-ALT-DEFEAT.

Edited by SonsofOcelot

Share this post


Link to post
Share on other sites

I have the Auto-Hotkey script for using to Escape to close the emulator and can still use save states. I'm also using version 1.4 (I had some other non-related issues with the dev builds after re-imaging my PC a while ago, so reverted back to the release version, so maybe it's the dev build that's causing this weirdness).

Probably not related either, but I also prevent PCSX2 from opening it's log window.

 

Oops! Nevermind. Just read your update. Glad it's working properly again!

Edited by CTRL-ALT-DEFEAT

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...