Jump to content
LaunchBox Community Forums
latin625

DEMUL No fullscreen

Recommended Posts

2 minutes ago, lordmonkus said:

I guess that could be possible but I really don't know, I wouldn't think that would cause that issue though.

Yeah to be honest everything in MAME looks absolutely awesome but everything in Demul looks a bit...off. Even though I have the resolution set to 320x240. Of course this has nothing to do with LaunchBox. Just putting it out there that Demul really is a pain in the neck with a genuine cabinet. 

Share this post


Link to post
Share on other sites

Demul is a pain in the ass for everyone but unfortunately it is the best overall Dreamcast emulator we got for now, hopefully Redream can replace it soon.

Share this post


Link to post
Share on other sites
1 minute ago, lordmonkus said:

Demul is a pain in the ass for everyone but unfortunately it is the best overall Dreamcast emulator we got for now, hopefully Redream can replace it soon.

Agreed...we can "dream" of Redream replacing Demul soon!

  • Haha 1

Share this post


Link to post
Share on other sites

DUDES! I cant believe this! I was trying everything to make it work then FINALLY I tried turning off Teamviewer, cause I had a hunch (i was not working through it it was just running in the background on the tray), and now DEMUL runs fullscreen! xD lol

Share this post


Link to post
Share on other sites
On 10/17/2017 at 2:26 PM, Progre555 said:

DUDES! I cant believe this! I was trying everything to make it work then FINALLY I tried turning off Teamviewer, cause I had a hunch (i was not working through it it was just running in the background on the tray), and now DEMUL runs fullscreen! xD lol

Do you know why Demul looks terrible in 320x240? I am using a standard-res arcade monitor. In demul I told Naomi to use the dip switch for 15khz. But it looks TERRIBLE. Weird lines everywhere. 640x480i does not have this issue, but I don't want to use 640x480i! 320x240 is supposed to look better on this monitor! Any ideas??

Share this post


Link to post
Share on other sites
19 hours ago, Arcade1993 said:

Do you know why Demul looks terrible in 320x240? I am using a standard-res arcade monitor. In demul I told Naomi to use the dip switch for 15khz. But it looks TERRIBLE. Weird lines everywhere. 640x480i does not have this issue, but I don't want to use 640x480i! 320x240 is supposed to look better on this monitor! Any ideas??

I have no experience with arcade CRT monitors but according to this: https://www.arcade-museum.com/monitor.html the standard res is 336x240 not 320x240. This small difference can can make all kinds of sync errors. I guess the reason why 640x480i works fine is that it's overdefined, and gets downscaled at one point, so it looks better on the standard resolution.

But then again, Im just guessing here. :)

Share this post


Link to post
Share on other sites

Since few days, my demul is not launching in fullscreen.

It looks like its because of reshade, but Im not sure (Maybe also because of the last Windows 10 update)

Is anybody using Demul + Reshade, and manage to launch it straight in Fullscreen (with the last Windows 10 Creators Update) ?

Thanks

Share this post


Link to post
Share on other sites

Unsure if this will work for you but for me in Windows 10 Demul launches somewhat fullscreen but with the menu at the top still this is very annoying to stop it I went to the Demul folder and right clicked on the .exe file then went to properties from there you go to the compatibility tab and check the box for Turn off fullscreen optimization then the program launches in true full screen for me.

  • Like 1

Share this post


Link to post
Share on other sites

Thank you for your answer DOS76, its exactly what happen to me : Demul is fullscreen but with the menu bar at the top.

I did what you explain (turn off fullscreen optimization in the properties) but nothing change for me.

I Don't understand why. Do you also use Reshade ?

Share this post


Link to post
Share on other sites

no reshade for me hitting F3 also removes the menubar but that sucks to have to keep doing

 

Share this post


Link to post
Share on other sites
On 27/11/2017 at 10:04 PM, DOS76 said:

Unsure if this will work for you but for me in Windows 10 Demul launches somewhat fullscreen but with the menu at the top still this is very annoying to stop it I went to the Demul folder and right clicked on the .exe file then went to properties from there you go to the compatibility tab and check the box for Turn off fullscreen optimization then the program launches in true full screen for me.

Thanks a lot! This worked for me; no menu bar in fullscreen!

Share this post


Link to post
Share on other sites

I got the menu bar to disappear but unfortunately when using my AimTrak light guns to play House of the Dead 2, the menu bar eventually shows up again. Probably because the guns are acting like mouse clicks and if someone clicks in the right spot it will make it pop up again. Is there any way to disable it? 

Share this post


Link to post
Share on other sites

I couldn't get CAVE to run in fullscreen using demul at first although dreamcast/naiomi/atomiswave were all fine. ended up adding this ahk script to do it for me...not fantastic but it does work. 

run,"E:\Tools\nomousy\nomousy.exe" "/hide";
sleep 2000
Send {F3};
sleep 500
send !{Enter};
Esc::
Send !{f4} ; Simulates the keypress alt+f4
run,"E:\Tools\nomousy\nomousy.exe" "/hide"
return ;
 

Share this post


Link to post
Share on other sites
On 11/27/2017 at 8:04 AM, DOS76 said:

Unsure if this will work for you but for me in Windows 10 Demul launches somewhat fullscreen but with the menu at the top still this is very annoying to stop it I went to the Demul folder and right clicked on the .exe file then went to properties from there you go to the compatibility tab and check the box for Turn off fullscreen optimization then the program launches in true full screen for me.

This worked for me. However, when I tried it on a laptop where Dreamcast is about the highest system I can get to run smooth there was a substantial dip in performance. i5-7200U 2.5GHz, integrated graphics, 8 GB RAM.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...