Jump to content
LaunchBox Community Forums
chrisdv98

Getting a specific game to launch through retroarch dosbox

Recommended Posts

Hi guys, 

I'm hoping someone can help.  I have an old dos game (European Championship 1992) and when I try to play it in Launchbox the window appears and then closes almost immediately. When I run the same game in retroarch it plays absolutely fine. 

I either need to work out what I can do to get it running natively in Launchbox or how I can get one specific game to launch retroarch and then the game in retroarch automatically (presumably some command line).

Please help. 

Thanks

Chris

Share this post


Link to post
Share on other sites

Yeah DOSBox is one of those cores where it is recommended to use the stand alone or any variation of the standalone over the RA core so it may be harder to get assistance. Have you gone into Manage Emulator and edited your RetroArch settings in the associated platform tab you will have to enter The name of your platform and then the command to launch it as DOSBox isn't configured by default in the LB RA section. If it doesn't need anything special it will be  -L "cores\dosbox_libretro.dll"

Share this post


Link to post
Share on other sites

Hi, 

thanks for the reply.  I have added Retroarch in manage emulators section and in the associated platform tab I have entered 'MS-DOS' as the associated platform and -L "cores\dosbox_libretro.dll" as the command line parameter and ticked as default emulator but launchbox still launches it's own version of Dosbox.  Is there something else i'm missing?

  

Share this post


Link to post
Share on other sites

Yeah right click the game and go to edit then go to the emulator tag and change the emulator to Retroarch that checkbox will only make RA the default on any new games you import all the one imported prior will still be hooked to the original emulator you imported them into. Well actually since they are DOS games when you imported them they don't have an emulator. Damn this isn't my area of knowledge since I don't really mess with DOS at all changing the emulator or adding one may fix the problem though

Share this post


Link to post
Share on other sites

You need to bulk edit that they're even using an emulator. They by default don't use one because DOSBox is included with LaunchBox. I personally even replaced that with DOSBox Daum, as it's much better than that even. Using the RA DOSBox core is ok, but Daum and -x, and other variants, are much much better.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...