Jump to content
LaunchBox Community Forums

Demul and Launchbox


Echorion
 Share

Recommended Posts

11 hours ago, DOS76 said:

you need to have certain checkboxes checked and the proper command line entries per-system which should all be covered in the tutorial.

Yeah I can get it to launch the dreamcast ones no problem it's the Atomiswave ones and other arcade titles I am having trouble with. That tutorial shows me the dreamcast launch options I was already using for the other demul folder. He says they would cover those games in a future tutorial but I couldn't find it on youtube. 

Edited by Echorion
Link to comment
Share on other sites

For the arcade stuff in Launchbox you will want to create a 2nd instance of your Demul emulator called something like Demul Arcade for example. You can still use the same Demul install and setup, just create a 2nd instance of it in LB.

The reason is it requires a different setting to function. You want "Use file name only without file extension or folder path" turned on.

2017-05-07 15_58_59-Edit Emulator.png

  • Thanks 1
Link to comment
Share on other sites

Tbh I didn't really need much a tutorial for it anyways, I got how demul works and such it was just I didn't know what command line/options launchbox wanted for it, that was all I needed to know :)

If there was trouble with the emulator itself there are usually dozens of tutorials for those.

Edited by Echorion
Link to comment
Share on other sites

  • 3 years later...

I am able to get my Sega Naomi 2 games working directly through Demul (demul07_280418), but cannot get them to launch through Launchbox.

My bios files are in "Launchbox\Emulation\Demul\roms" and my roms are in "Launchbox\Games\Sega Naomi 2".  Demul points to both directories within the "Path..." section of Demul

Launchbox points to the Demul.exe, whih is located as noted above. The only items checked are "No space before ROM (primarily for nullDLC)" and "Use file name only without file extension or folder path (Sega Model 2 Emulator, etc. compatibility)".

In the "Associated Platforms" tab, the Platform is named "Sega Naomi 2".

The default command line parameters is " -run=naomi -rom=" and it is the default emulator.

When I launch a game (that works through Demul by itself) within Launchbox, it simply opens Demul and nothing else.

The roms are from the latest MAME 0.228 set.

I feel I am missing something relatively simple.

Should/can I run it through Retroarch instead?

Thanks for any assistance you can provide.

 

John

 

Link to comment
Share on other sites

  • 8 months later...

Not sure if you still need it, but here is my solution.  I had the same issue.

1. Open Notepad

2. copy and paste this: demul.exe -run=naomi -rom=put_name_of_the_rom_here     
Do not add the rom extension, only the name of the file (it is CaSe Sensitive)

3. Save as (rom name).bat in the same directory as Demul

4. Test by clicking on the .bat file , it should launch the game

5. If it works, go to LB and point the game to the .bat file. Uncheck Emulator (No Emulator).

Good Luck!

Link to comment
Share on other sites

2 hours ago, latin625 said:

Not sure if you still need it, but here is my solution.  I had the same issue.

For me Naomi 2 works fine from LaunchBox. If you like I can walk you through my setup because using bat files for this, you bring a lot of troubles on yourself. Exiting Demul, startup/shutdown screens and pause screens won't work as easily. For Demul arcade emulation make sure you have roms from a Mame romset as Demul uses that naming scheme and does a check on the included roms in a .zip. Also make sure you have the appropriate bioses.

1. Add the bios and rom paths to Demul. (Demul > Config > Plugins and Paths > Roms and Bioses Paths.)

2052593824_Schermopname(115).thumb.jpg.17466a3ae928b04d02b907a5e89bb6f4.jpg

2. In LaunchBox add a "Demul Emulator" with the checkboxes "Remove file extension and folder path" and "Remove space before ROM" ticked. If you emulate multiple systems with Demul leave the "Default Command-Line Parameters" field empty. Else (in this case) put in: -run=naomi -rom= 

2103046718_Schermopname(116).thumb.jpg.632c71d5ddf48d4a7da853ffa58003c6.jpg

If you emulate multiple systems with Demul, go to the "Associated Platforms" tab. Enter your platform name *exactly* as you have named it in LaunchBox. With the appropriate command-line parameters, in this case: -run=naomi -rom=

455482839_Schermopname(117).thumb.jpg.09723c074a019132af901c3bf3af3ba3.jpg

For exiting Demul, in the "Running Script" tab add:

$Esc::
{
WinClose, ahk_exe demul.exe
}

1463982205_Schermopname(118).thumb.jpg.512c815fb861108286749e2d72ff24e7.jpg

P.s. At the time of writing this, I am on LaunchBox version 12.0 beta-2. So my screenshots are of that version.

Edited by Koroth
  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...