Jump to content
LaunchBox Community Forums

Recommended Posts

1 minute ago, slipsystem said:

Yes this is definitely possible, this was a thought when I was updating the plugin but for some reason I skipped over it. I will put this in the next release

That's awesome!! Thanks so much. :) 

Link to post
Share on other sites
  • Replies 63
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Movie Scraper Plugin View File This Plugin Is Currently Broken   Downloads Information and Images for Movies.    

hey guys,   sorry for not being there. I have been focusing on my band and not been doing much after hours coding. I will have a look at what caused this to break but I cant commit as many h

yes this is possible, I will be doing some work on this after office hours.   My update schedule is as follows.   add the ability to check if the artwork files exists in the movies

Posted Images

@slipsystem Sorry me again. Here is a strange one, i thought now that i have the your plugin working that i would delete all my movies and start from scratch importing and scraping them all. They all imported fine as usual i then used ctrl a to highlight them all scraped with your plugin, and it turned every single movie (all 660!!) into Zootopia!!! lol. :) Any ideas??

 

Screenshot (137).png

Link to post
Share on other sites
3 minutes ago, neil9000 said:

@slipsystem Sorry me again. Here is a strange one, i thought now that i have the your plugin working that i would delete all my movies and start from scratch importing and scraping them all. They all imported fine as usual i then used ctrl a to highlight them all scraped with your plugin, and it turned every single movie (all 660!!) into Zootopia!!! lol. :) Any ideas??

 

Screenshot (137).png

woops this is what I get for not doing proper testing. I think I need to reset the variables to null, give me a sec I will try fix this and also implement file names.

Link to post
Share on other sites
Just now, slipsystem said:

woops this is what I get for not doing proper testing. I think I need to reset the variables to null, give me a sec I will try fix this and also implement file names.

lol :), no worry's i thought it was quite funny, Zootopia is the last film alphabetically so i assume that has something to do with it. Thanks for your continued help and support. :) 

Link to post
Share on other sites

I love that you are working so hard on this plugin because I can see it being the best thing ever once it's all set. One issue I'm currently having once it scrapes and says it's good and I refresh. The art that it found in the popup, doesn't show up. I've only tried it with 3 films so far. The first two I tried were 9 and Pee Wee on Broadway before I updated the plugin. I added the posters myself. I saw there was an update just now and decided to try again. I've included a picture of it working and showing the movie poster for Fear Inc, but like I said after I refresh, it doesn't actually update the pic though it did grab the details.

I'm also not entirely sure I'm adding the movies the right way. In the plugin description it says, Simply add the movies to launchbox. But since there isn't an option for "add movies" I've added them under "add roms". If there is a correct way to do this could anyone let me know please. I'm very new to launchbox. 

LB Movie Scrape.JPG

Link to post
Share on other sites
8 hours ago, EndlessMIke said:

I love that you are working so hard on this plugin because I can see it being the best thing ever once it's all set. One issue I'm currently having once it scrapes and says it's good and I refresh. The art that it found in the popup, doesn't show up. I've only tried it with 3 films so far. The first two I tried were 9 and Pee Wee on Broadway before I updated the plugin. I added the posters myself. I saw there was an update just now and decided to try again. I've included a picture of it working and showing the movie poster for Fear Inc, but like I said after I refresh, it doesn't actually update the pic though it did grab the details.

I'm also not entirely sure I'm adding the movies the right way. In the plugin description it says, Simply add the movies to launchbox. But since there isn't an option for "add movies" I've added them under "add roms". If there is a correct way to do this could anyone let me know please. I'm very new to launchbox. 

LB Movie Scrape.JPG

I think it is to do with punctuation in the names, i had a lot also with no artwork, but the artwork is actually there but named incorrectly. For example i had "2001: A Space Odyssey" which scraped but didn't have art in launchbox, turned out the artwork WAS in the image folder however it had dropped any text before the : so in my image folder it was called "A Space Odyssey" therefore didn't match the movie name so wasn't showing in launchbox. I spoke to slipsystem about this via a PM and he is aware of it but not sure how to deal with it, this was his response.

"its because of the safe name conversion. the : is not supported by windows so launchbox uses a convertor to change the name. im not 100% sure how Jason does this but it beats the script crashing.i will look into this properly thogh as soon as i get a chance."

 

Link to post
Share on other sites
4 hours ago, neil9000 said:

I think it is to do with punctuation in the names, i had a lot also with no artwork, but the artwork is actually there but named incorrectly. For example i had "2001: A Space Odyssey" which scraped but didn't have art in launchbox, turned out the artwork WAS in the image folder however it had dropped any text before the : so in my image folder it was called "A Space Odyssey" therefore didn't match the movie name so wasn't showing in launchbox. I spoke to slipsystem about this via a PM and he is aware of it but not sure how to deal with it, this was his response.

"its because of the safe name conversion. the : is not supported by windows so launchbox uses a convertor to change the name. im not 100% sure how Jason does this but it beats the script crashing.i will look into this properly thogh as soon as i get a chance."

 

this is because Imbd has artwork but Fanart.tv doesnt. 

the preview is comming from imdbs listing and not fanart.tv I will code in the image collection for imdb.

as for the safe naming conversions this issue should be fixed @neil9000 can you please confirm this is still an issue?

 

sorry I meant so say moviesdb the script only uses the imdbid to scan fanart.tv

Edited by slipsystem
Link to post
Share on other sites
3 minutes ago, slipsystem said:

this is because Imbd has artwork but Fanart.tv doesnt. 

the preview is comming from imdbs listing and not fanart.tv I will code in the image collection for imdb.

as for the safe naming conversions this issue should be fixed @neil9000 can you please confirm this is still an issue?

I would love to test for you but unfortunately my HDD died and i lost everything, so i have nothing to test with. :( Maybe someone else in this thread can have a look for you. Sorry.

Link to post
Share on other sites
13 hours ago, EndlessMIke said:

I love that you are working so hard on this plugin because I can see it being the best thing ever once it's all set. One issue I'm currently having once it scrapes and says it's good and I refresh. The art that it found in the popup, doesn't show up. I've only tried it with 3 films so far. The first two I tried were 9 and Pee Wee on Broadway before I updated the plugin. I added the posters myself. I saw there was an update just now and decided to try again. I've included a picture of it working and showing the movie poster for Fear Inc, but like I said after I refresh, it doesn't actually update the pic though it did grab the details.

I'm also not entirely sure I'm adding the movies the right way. In the plugin description it says, Simply add the movies to launchbox. But since there isn't an option for "add movies" I've added them under "add roms". If there is a correct way to do this could anyone let me know please. I'm very new to launchbox. 

LB Movie Scrape.JPG

I have updated the plugin. it will now download artwork from moviedb as well as fanart.tv, this will fix the issue you where facing.

thanks for the report.

  • Like 1
Link to post
Share on other sites
  • 1 month later...

Feel free to ignore this, but I have a bit of a request. I don't know anything about coding or I would do this myself. Hopefully it won't be much trouble...

Could you write a modified version of this plugin which downloads only actor metadata, and uses that metadata in the "Series" field in LaunchBox?

Link to post
Share on other sites
  • 3 months later...

Hi just curious, this is a great plugin, But is it possible to also scrape a "Screenshot" or make fanart "screenshot" my theme I use, uses a basic Movie cover, a screenshot and a blurred fanart. But its predominantly the screenshot that's seen, not fanarts.

 

Is it possible to get a version that instead of it downloading a fanart, it downloads it as a "Screenshot?"

Link to post
Share on other sites
  • 1 year later...
  • 1 month later...
  • slipsystem changed the title to Movie Scraper Plugin [Broken]

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...