Jump to content
LaunchBox Community Forums
PowerCooker

Need Help - Windows 10 ruined everything

Recommended Posts

guys ive tested a lot of the other emulators in  my launchbox and it seems most r working on since I turned game mode off

 

HOWEVER my demul is still fucked and wont work right no matter what I try and do. Ive tried the dreamcast emulator - slow when I go fullscreen yet runs ok when I make it a small screen

AM2,£ and Naomi seem the same (yes I know there running on the same dreamcast emulator)

I cant figure out whats wrong with it or why its doing this when I go fullscreen....its been a long time since I messed with it but how do you change the directx on it? I want to see if I change it if it will run any better. It says DX11 but if I remember right cant u tell it to run in 9 or something?

Also how can I tell again if I have the latest direct x? I'm pretty sure that should have just happened when my nvidea installed the latest drivers shouldn't it



Sorry, I don't use Demul & am not familiar with how it works.

You can check your directx versions by typing "dxdiag" (no quotes) in the run utility (cmd+r).

Sent from my SM-N900T using Tapatalk

Share this post


Link to post
Share on other sites

sayd I'm running directx12 so same as it was before this whole screw up

DemUL is the dreamcast emulator - it also runs sega model 2 ,3 and noami boards (aka am2 and am3)

 

Share this post


Link to post
Share on other sites

Demul doesn't run Model 2 and 3 stuff as far as I know it runs Naomi Naomi GD Naomi 2 Naoim 2 GD Sammy Atomiswave Sega Hikaru Gaelco and Cave stuff. That's the 1st I've heard about it running Model 2 and 3

Share this post


Link to post
Share on other sites

apologies your right

its coz it runs Naomi I forgot am2 and 3 stuff doesn't work on it.......right well its also my Naomi that's not working right either......I get extreme slowdown with that when I go fullscreen as well

 

I changed the DX11.old file to the DX11 normal file and that didn't help - if anything it made the game look worse so went back to the dx11.old file

 

I don't understand why it runs ok in a small window yet the second I fullscreen it goes slow and craps out on me

Share this post


Link to post
Share on other sites

Yeah I'm at a loss if it worked good before I'm unsure why it wouldn't now you could probably go into Windows 10 settings and roll back to the previous build as long as it hasn't been longer than 10 days (or at least that's how the Insider Preview works I've never needed to roll back a mass release build before.

Share this post


Link to post
Share on other sites

that's not really going to fix tho issue tho really is it....my pc is just going to force a windows 10 update in any event..........

I just don't understand WHY it wont run in fullscreen at full speed now

every other emulator I have seems to work aside from Naomi and the dreamcast emulator now. they just wont work in fullscreen anymore when they worked perfectly yesterday before this wank windows 10 update shite

 

ive already updated to the latest 970 drivers (which I'm sure are actually running my card harder as before it was around 30oc and not its 40oc without the fans on) so its either these shitty windows 10 settings or the nvidea drivers which I doubt.

I'm reight near the end of Shenmue 2 ffs and fheres other dreamcast and Naomi games I wanted to play. I'm at a total loss on what the hell is wrong here

Share this post


Link to post
Share on other sites

Sounds like you have narrowed the issue down to Demul & windows 10. Have you tried posting on the Demul forums to see if anyone has experienced your issue?

Sent from my SM-N900T using Tapatalk

Share this post


Link to post
Share on other sites

is DemUl working fine for everyone else in fullscreen?

 

the guy I got my 2TB hdd says its working ok for him but he hasn't been forced to update his windows yet. I think that might be a different story once he has updated however

I wanted to contact MetalliC on the deamul forums but he says himself in a thread he doesn't test/play games on it so I don't think he could be much help if he never uses it himself these days. I just feel stuck and I cant figure out why the hell it isn't working yet everything else seems to be working fine now

Share this post


Link to post
Share on other sites

Guys I THINK ive found whats causing the issue but do not know how to fix it

when the emulator boots up its starting at 24HZ instead of 60hz

any idea why its doing this or how I can fix it

Share this post


Link to post
Share on other sites

Hi there, windows 10 creators update kind of broke some things in my pc too (win 10 pro 64 bit, launchbox 7.9), the full screen problem is pointed in some forums outside launchbox as a common problem. In my case the startup video transition to the big box windows kind of froze, and had to use alt + tab to let the big box app to get focus and work normally (in the end changed the video engine to windows media player instead of vlc, but it worked really good before the update).

Please Try enabling "disable full screen optimization" on the compatibility options for the emulator or app exe file properties (right click then properties then compatibility tab). It looks like the creators update made some additional features to how full screen works and some games and apps in general that use full screen are having issues with this.

Please dont take my word as a universal truth as I am no expert on windows 10, but this maybe or maybe not help you to solve the problem. This is information found on outside forums but I truly hope that you can solve your problem.

  • Like 1

Share this post


Link to post
Share on other sites

i was really hoping this would fix it but sadly - NOPE...........

 

I just found the settings and changed them and it didn't change anything.

I'm not 100% sure if the DPI scaling thing would do anything or not either

so I'm still stuck were I was before

Typical micosoft....lets release something we haven't fully tested and fuck a lot of things up for people in the process.

Edited by PowerCooker

Share this post


Link to post
Share on other sites

Well if you like you can post me a pm with the zipped emulator with your configs and I may try tonight to reproduce the problem and if by chance I step over a solution I will share it with you.

Another thing in the other forums talk about full screen problems with g sync. Would you mind sharing with me your specs? Do you have an nvidia graphics card? You could try connecting it to a tv instead of a monitor, and try full screen over hdmi or vga or display port and share if theres any difference?

Share this post


Link to post
Share on other sites

My specs are as follows

 

GTX 970
16Gb Ram
500Gb HDD
2TB HDD (were all the emulators are ect
I7 930
 

not sure what else should be needed info wise....

I have my pc connected upto a TV downstairs which is why I don't understand how the hell the dreamcast emulator does to 24hz when in fullscreen as everything else runs PERFECTLY in 60hz

Ive attached a pic so people can see its connected upto my tv and has no issues at all but when I boot up the dreamcast emulator in fullscreen mode it jumps to 24hz and is in-usable.

 

desk.JPG

Its an old pic I know -last xmas

 

I cant be the only person using DemUL and had it working perfectly, did the windows 10 update and now its fucked. I looked on the Demul forums and no one else has said anything about it....it cant JUST be me

Edited by PowerCooker

Share this post


Link to post
Share on other sites

First, love the pic xD, now could you try to connect the pc to the tv using a different port? If you are using hdmi try a vga or displayport cable (not sure if the tv in the pic support display port) that way we could see what the problem is sensitive to...

Again, if you can, you could send me the emulator zipped with allthe config files to try and replicate the problem in my pc (got a nvidia 1050 and a very lower processor than yours on one pc, and a 1060 and corei5 on another one, both on win 10 creators update, I know theres a lot of difference on the specs, but maybe we can find some trigger to the problem).

Just for curiosity, can you turn off or disable the cinema mode of your tv? Its an option that allows the using of 24 frames per second when framerates from the source approx to that. In my case it happens when i'm watching movies on media player classic on mi lg tv via hdmi (such feature i had to activate on both the media player and the tv).

I will try to assist you as much as possible and I really think at the end you will be able to sort it out.

Share this post


Link to post
Share on other sites

I don't even have an option for 24 hz on this tv.........that's why I'm so confused....

the pc is connected via a hdmi cable to my pc to the tv. my kodi box is connect via the other hdmi and both run at 60hz. Right now I'm running at 60hz

IF I open the dreamcast emulator up and then minimize it then it runs at 60hz, if I then go to the settings and set it to 1920x1080 it still stays at 60hz only I have the menu at the top of the screen and the image is a tad squashed. Yet the second I THEN press alt/enter to go into fullscreen..........bam........24hz mode and slow as hell mode begins

Open dolphin, play sonic colors for wii - runs 60hz perfectly, same for ps1 games and psp etc etc its just the dreamcast one. I feel like an idiot because I KNOW this is going to be something like the ps2 emulator (pcpsx2 or whatever it is) were you have to in-tick a box for the games to run properly in the video settings

Share this post


Link to post
Share on other sites

Hi there, just found a forum about a game that a lot of people had the same problem as you describe, when goind to full screen in that game, pc and tv switch to the lowest refresh frame as posible, capping the frames per second of the game.

The solution was to remove the lower refresh rates from the valid refresh rates available in the control panel of the graphics adapter. Theres a catch, this was on 2016 and windows 10 pro I think.

Could you try that if the emulator does not let you remove lower refresh rates?

I will keep trying to find more about it.

Share this post


Link to post
Share on other sites

Man this stuff makes me almost scared to fire up my LB now. I recently was forced into the creator update too. I plan on blocking my EmuPC at the router to not be able to hit the internet anymore since you can't disable windows updates.

Sent from my XT1635-01 using Tapatalk

Share this post


Link to post
Share on other sites
40 minutes ago, Fnkngrv said:

Man this stuff makes me almost scared to fire up my LB now. I recently was forced into the creator update too. I plan on blocking my EmuPC at the router to not be able to hit the internet anymore since you can't disable windows updates.

Sent from my XT1635-01 using Tapatalk
 

Welcome to the club hehe... I read somewhere that you can stop the update service on windows 10 but not from the ordinary menus of the control panel (nor system settings)... at least i havent found how to do it using "normal user intended methods".

Well not everyone has problems with the updates, whe got the short straw but I think at least there are workarounds... its just that they are harder to find when really needed xD.

The good thing is here in the forums we usually find the solutions working together, and usually the people does not limit the talk about launchbox... this is a very nice community if you ask me :D

Edited by JuanHeSi

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...