Jump to content
LaunchBox Community Forums
MCGodzilla

Mednafen standalone emulator won't launch in launchbox

Recommended Posts

Hey guys. I didn't see anyone else having this issue and I need help. I tried using the latest Beetle/Mednafen core for sega saturn, and unfortunately many of the games have sound issues when ran through that core and retroarch. But I downloaded mednafen standalone and they work fine.

I added the Mednafen emulator to launchbox, set the application path to the mednafen app, checked the box to be default for Sega Saturn. It will not run. In fact, it still runs off of retroarch. So I tried just deleting that line in retroarch, which gave me nothing working.

I feel like I'm missing something here, but I followed the instructions for adding emulators to a T. Any help is greatly appreciated.

 

Share this post


Link to post
Share on other sites

You need to bulk edit all your saturn roms to use the new emulator. Just click a saturn game then ctrl A to highlight them all, then right click, edit. From the dropdown choose emulator then the emulator you want to use.

Share this post


Link to post
Share on other sites

Yes, if you've already imported the games into your library it's not going to change the currently assigned emulator of your existing library entries. You'll need to change it as @neil9000 said.

Regarding "sound issues" with the core, my suggestion would be to go to your settings -> video and reducing your frame delay (assuming it's not already 0). Mednafen Saturn is fairly demanding and it'll be difficult for most PCs to handle a frame delay that would otherwise be considered normal for most cores. If it's set higher than your PC can handle you'll get audio stuttering. Personally, most of my cores are set to a delay of 5 or so and I believe I had to reduce Mednafen Saturn to around 1 or 2. I've got quite a few Saturn games (100ish) setup to use the Mednafen Saturn core in RA and don't have any audio issues with them... once I reduced the frame delay. You want it as high as you can get it (to reduce input latency) without impacting performance (sound stuttering).

Share this post


Link to post
Share on other sites

Depending on your system you may also need to enable threaded video in the video settings of Retroarch if you choose to use that core over the stand alone.

Share this post


Link to post
Share on other sites

Yep, that's another good tip. It has some impact on vsync behavior and input latency but can also improve performance. Generally you want it off if things are running smoothly without it but it can be a good option if you're running something particularly demanding and your hardware isn't quite up to snuff.

Share this post


Link to post
Share on other sites

Cool, thanks for the help. I'll try that with the cores and see if that doesn't help, and if not I'll use the standalone as a back up.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...