Jump to content
LaunchBox Community Forums

Recommended Posts

@letstalkaboutdune If I'm reading that right, yes.  After the Title and Platform are entered, if there's a similar or the same game in the database, a page will come up asking for you to pick the existing game, or click the button to add the new game.  The automation will pause there for up to 5 minutes while you make your selection -- either an existing game or new game -- and then the automation will resume when it detects that a selection has been made.

Share this post


Link to post
Share on other sites
33 minutes ago, UnderwoodNC said:

@letstalkaboutdune If I'm reading that right, yes.  After the Title and Platform are entered, if there's a similar or the same game in the database, a page will come up asking for you to pick the existing game, or click the button to add the new game.  The automation will pause there for up to 5 minutes while you make your selection -- either an existing game or new game -- and then the automation will resume when it detects that a selection has been made.

Awesome, in that case I think it's working perfectly as far as I can tell. Thank you so much for the hard work!

Share this post


Link to post
Share on other sites

@UnderwoodNC First of all, thanks for creating this and staying on it. :-)  I really appreciate it.

Now, I just started trying to add games again and it started giving me the "missing disk error" again. So I deleted the plugin and installed the latest version that you just posted and I'm still getting it. But everything works after I hit continue twice.

As for the multiple genre error, I can see it try to add all of the genres, but only the first one stays, the rest enter and then disappear.  I could screen capture it if you'd like to see what happens with that.

2017-07-04 (2).png

Share this post


Link to post
Share on other sites

The no disk in drive error most likely means that something was downloaded in Chrome to a removable drive that is not connected anymore, or may have changed.

Try opening Chrome and clearing all the downloads.  You can access the downloads page by pressing CTRL + J in Chrome, or typing chrome:downloads in the address bar.

Unfortunately it's something to do with the browser automation driver itself, so I don't think it's something I can handle in code, but based on what I'm reading, that should take care of it.

  • Like 1

Share this post


Link to post
Share on other sites

@UnderwoodNC I tried out the new plugin and I did not get the steam banner error as before. The game I tried to upload with the plugin was a new game and it uploaded the images fine that I had associated with the game to the database but it did not pull any of the information like publisher, developer and stuff like that even though I had that information available. I think the only thing it pulled info wise was (Cooperative- False). I also clicked back on LaunchBox to see what was going on there and I just got the windows blue spinning busy circle. I waited for a while to see if the blue spinning circle ever stopped but I just had to ctrl-alt-delete out of LaunchBox to exit. 

I guess I can try with another game and see if I get same result.

Share this post


Link to post
Share on other sites

I`ve just got this error "unknown error: cannot find Chrome binary", I don't use chrome but I`ve got firefox installed as my default browser.  I thought firefox was ok?

Any suggestions?


 

Share this post


Link to post
Share on other sites

@dita Firefox should be okay, but true enough, I didn't uninstall Chrome to test that it worked without Chrome even being installed.  I'm posting another quick plugin, then I'll check it into it directly.

Share this post


Link to post
Share on other sites

I seem to be having an intermittent problem with it entering the year. It happened with once last night entering Space Taxi for C64. I have the correct date in, 01/01/1984, but it ended up entering 2017 (year only.) It just happened again with M.U.L.E. for MS-DOS. The year in LaunchBox is 01/01/1983, but it entered in 2017 with "Year Only" ticked again.  It's also entering Max Players: 1 when there is no field in Launchbox for that. M.U.L.E. would be Max Players: 4. Might be better if it didn't enter Max Players, than enter possibly incorrect info.

This really is one of, if not THE best plugin for LaunchBox though. Thanks for making it and working on it. :D

Edited by Ranthalion75
  • Like 1

Share this post


Link to post
Share on other sites
11 hours ago, UnderwoodNC said:

@dita Please replace this file and let me know if that helps.

 

Had a quick look, still the same error message....Capture.JPG.044d3c5ff753ea357704ff17080bd121.JPG

 

 

Share this post


Link to post
Share on other sites

I've been trying to use this plug in and I click to add a game it goes through the process closes out google so it seems to work but then when I go to my submissions page there is nothing there waiting for approval.  Anyone else having this issue?

Share this post


Link to post
Share on other sites

Hi @heelsinc, there may be something in the log if there's an error, or if you can send me the log, I'll be glad to take a look and put together a fix.  Is the submission successful screen showing up before the browser closes?

Share this post


Link to post
Share on other sites

 

55 minutes ago, UnderwoodNC said:

Hi @heelsinc, there may be something in the log if there's an error, or if you can send me the log, I'll be glad to take a look and put together a fix.  Is the submission successful screen showing up before the browser closes?

How do I get the log?  I'll try to add one tonight and see if the successful screen shows up.  I want to say that yes it is going off memory but can't be sure

Share this post


Link to post
Share on other sites

no Idea what I've changed on my system but now it works flawless with Chrome. Thank you so much. I already send hundreds of games to the DB for approval. Now we can have a large set of NeoGeo CD Games and so on :-)

  • Like 1

Share this post


Link to post
Share on other sites

don't know why but from all in a sudden the plug in has an issue.

 

every time I want to add a new game chrome opens it, start everything but then failed with this error message

59cbeb7d4e39c_Bildschirmfoto2017-09-27um20_17_47.png.65229fb8c2c438d56ca3f1e3b4555829.png

Share this post


Link to post
Share on other sites

I came to post the same as Chris Kant above.  Chrome seems to have changed something in the most current update.  Anything we can do to fix it or use another browser that isn't set to default maybe?

Share this post


Link to post
Share on other sites

Yeah, it's most likely either something changing in Chrome in its latest versions, or something changing in the submission form..  Please try replacing chromedriver.exe with this version (updated), and I'll also check the form for any changes.

chromedriver.exe

Edited by UnderwoodNC
  • Like 2

Share this post


Link to post
Share on other sites

It seems to work with that chromedriver.exe file.   Thanks so much for the quick response!!!  This is the most useful addon here, by far.  You'd get my vote for best addon of the year (hint, hint)

 

EDIT - I do notice that it isn't adding more than one genre.  example:  I add action and racing and it only adds action and disregards the rest.

Edited by Evil_Orko

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×