Jump to content
LaunchBox Community Forums

Games Exit When Pressing Start On Controller


Recommended Posts

Hello everybody. So I'm really new to Launchbox, just downloaded and bought premium today, and I can't figure out my controller issue. Every game I've tried through Wii, PSX, & NES so exits the game anytime I press the start/options button on my DS$ controller. Also if I press the right trigger the screen flashes and the controller won't work in the game anymore.

I've searched the internet and also the forums and couldn't find anything mentioning these problems. I've gone through the pad configs on the emu and in LB and still can't fix it. Any help would be greatly appreciated.

Thanks for any help.

Link to post
Share on other sites

A PS4 controller needs InputMapper or equivalent ideally (DS4 Windows is outdated). Steam is the only program that detects it really, by default, but the PS4 controller really needs the extra help ideally. The buttons ID's can be very off from what the PS4 controller expects, and whats there. It's kind of hard to explain. If it's still doing that after you install InputMapper, then I would look at Controller Automation and see if it's mapped properly. You might have the close game button on start. If it's not set to start, the ID's being different might still be at play, which is why I think to look there first. It may be set up on normal buttons otherwise, but to the PS4 that's the start button. With it installed, you might see two devices, but that's normal. Set programs to use the new device name. You might need to tell windows to default using the new one too.

Link to post
Share on other sites

Ya I don't think it's the PS4 controller as I tried my 360 pad and it does the same exact thing. I've also had the buttons in automation remapped to different buttons and the close game button has never been on the start button. It's drivining me crazy. I'm wondering if something in windows 10 is doing it?

Link to post
Share on other sites

Hell ya I finally figured out what the problem was. It was Steam. I did a lot more digging around on the internet and found someone mentioning closing Steam. Well of course mine is pretty much always open so I closed it and lo and behold it doesn't do it anymore.

Thanks for trying to help guys. My world just got a lot better. lol

Edited by DazeOfWar
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...