Jump to content
LaunchBox Community Forums
Jason Carr

7.11-beta-1 Released

Recommended Posts

Just updated on a tester install of LB with only a single platform and 18 games and performance is absolutely abysmal.

Going into the options and changing settings and then back to the platforms list completely stalls out LB to the point of having to kill it in the task manager and restarting it.

I know the new wall view is a very early version but my immediate issue with it is that it only displays some of the box art and which art it shows changes each time I start up BigBox.

Share this post


Link to post
Share on other sites

Just tried out the new beta with no issues so far and I do notice some speed inprovements especially when navigating through the menus. My collection is about 14K games and I am using Windows 10 with all the newest updates including creators update. 

Share this post


Link to post
Share on other sites

@Jason Carr Just tried out the new wall view LOVE IT.  Only thing i know its at early stages yet but when you get to THE bottom off THE wall it does not go back to the start which it would need to with a large platform such as arcade.  Added the view to a theme and the new line for showing the wall view to the theme ThemeSettings.xml, went into visual Studio set the curve amount to 0 but the default overides any setting changes you make in your theme to the wallview.  Like i said i know it is an early beta but for what its worth once you iron out these little quirks what a fantastic view.  KUDOS working really good no problems with it apart from what mentioned.  Thank you for that nice suprise.  Again MAJOR MAJOR KUDOS.

Share this post


Link to post
Share on other sites

@Jason Carr Did a bit more playing around with the new theme;  When you change views and come back to the wall view it does not show the background artwork until you go to the next game.  When background video is selected to show it neither shows background video or any background artwork, but it does show the game boxes.  Again i know it early stages but none the less KUDOS to you another wonderful view.

Edited by Maddoc1007
left out some info

Share this post


Link to post
Share on other sites

@Jason Carr I have an important request for the next LB release as my new theme is dependable on it for some of its views:

Add the ability to set the ImageType for the Flowcontrol to Steam Banner for both platform and game views:

Currently i'm using "Screenshots" ImageType for some of my game views and while they look acceptable there is a room for better potential here:

Game view with ImageType set to Screenshots

5943f4f43133f_Desktop06_14.2017-02_52_08_24.thumb.png.33c16e9eea95d5a9d3bc42effbcdbbec.png

Game view with some screenshots manually replaced by banners (very tedious process)

Desktop_06_14.2017_-_02_48_34_23.thumb.png.647a59a4d4ebeab517c40e093c9288a3.png
The banners really enhances the looks of the theme significantly and I do have more than 1 GB of artwork compiled over the years that i'm planning to upload here once the feature has been added

5943f6633b290_preview3.thumb.jpg.517bce3c1abf7ab3b784daa03c3a36db.jpg
 

  • Like 3

Share this post


Link to post
Share on other sites
7 hours ago, martinconroy said:

Is this based on speed of the standard view in LB @lordmonkus?

For me it's lightening quick with about 20 platforms and 12k games.

Yes, this is based off the standard view and performance is something I have never had any real issues with in the past aside from certain betas where there was a problem which Jason fixed.

Share this post


Link to post
Share on other sites
9 minutes ago, lordmonkus said:

Yes, this is based off the standard view and performance is something I have never had any real issues with in the past aside from certain betas where there was a problem which Jason fixed.

So this is in LaunchBox right? Is it scrolling performance? I have an idea as to what might be happening.

Share this post


Link to post
Share on other sites

Beta 5 is out and hopefully it fixes @lordmonkus's performance issues in LaunchBox. It's a shot in the dark but I'm hoping so. I won't be back to this thread until tomorrow night now unfortunately, so I can address any further issues then (and the rest of the thread). I'm out for now. :)

 

  • Like 2

Share this post


Link to post
Share on other sites
1 hour ago, Jason Carr said:

So this is in LaunchBox right? Is it scrolling performance? I have an idea as to what might be happening.

BigBox mode.

Edit:
Updated and much better now but still the problem of when coming back to the platforms from the options BigBox has a problem. It doesn't freeze in the sense that it crashes or hangs but it just sits there with the platform name and no games showing and I cannot go forward or backwards in the menus.

Also wall view seems to work now at least.

 

2017-06-16 14_20_30-LaunchBox Big Box.png

  • Like 3

Share this post


Link to post
Share on other sites

I posted this via the Report a Bug feature...

 

Prior to this latest update (7.11 Beta 5) whenever my machine would boot and auto launch BigBox Mode, my Arcade Favorites platform would be my default view and its video would display. However, since the upgrade to the latest beta, when my machine auto launches Big Box Mode, it no longer displays anything on the screen (other than a black screen) for my Arcade Favorite default view. If I move my joystick around I can hear BigBox Mode functioning, but nothing is displayed. After about 20 secs., BigBox Mode will go to my games and display everything properly. Now, if I go back to the BigBox Mode menus and then re-launch my Arcade Favorites platform view, it loads everything fine. If I completely exit out of BigBox Mode and re-launch it, it works fine. This only seems to happen when the app launches for its initial time on a restarted machine.

Latest beta (7.11 beta 5),

Windows 10

Everytime since the upgrade (only when booting up the machine)

Please advise. Thank you.

Share this post


Link to post
Share on other sites

Hey @Jason Carr, I might of just found a little bug. I updated my mame romset today and also moved them so decided to delete the platform and re-import. When going through the import wizard i chose Retroarch as my emulator as that's what i want to use, however doing so meant that the mame import screen didn't show in the wizard (the one where you choose to import clones, choose a region, exclude adult etc.) so i cancelled the import. Then i started the import again this time choosing MAMEUI as the emulator and the mame importer screen showed this time and i was able to set the options i wanted, so I had to import with mame as the emulator then bulk edit to retroarch after the import. Is that the expected behaviour or a bug?  

Thanks Jason.

Share this post


Link to post
Share on other sites

I'm pretty sure that is how it works which is crude but its not to much work to change it afterwards.

  • Like 1

Share this post


Link to post
Share on other sites
Just now, DOS76 said:

I'm pretty sure that is how it works which is crude but its not to much work to change it afterwards.

OK, it's the first time i imported mame with retroarch so wasn't sure. Basically though if i hadn't of stopped it, it would of imported every single rom which in my case is a non-merged and full chd set, so would of been a total mess after import.

Share this post


Link to post
Share on other sites

Oh you know what there is a checkbox that forces MAME data and I think it would have worked if you used that actually. Can't believe I didn't remember that.

Edited by DOS76
  • Like 1

Share this post


Link to post
Share on other sites

Oh OK, i didn't see that though i also wasn't looking for it either, i was just waiting to get to the screen i assumed would show up at the end of the wizard. Though as i had already told launchbox that i was importing arcade (i just chose it from the dropdown) shouldn't it know it's arcade and give me that screen anyway?

Share this post


Link to post
Share on other sites

I think that using MAME as the emulator is the key since Arcade also describes nonMAME arcade emulators.

Share this post


Link to post
Share on other sites
Just now, DOS76 said:

I think that using MAME as the emulator is the key since Arcade also describes nonMAME arcade emulators.

That's true, now i think about it. Yeah didn't bother me much as i just went the bulk edit route. Newcomers adding mame for the first time and trying to use retroarch though could end up with a very messy platform if the import wizard just adds everything. They will have adult games for starters, which should probably be a action you have to turn on rather than just being imported as standard, which is what will happen if they import mame with retroarch.

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...