Jump to content
LaunchBox Community Forums
heartofdestany

Mageslayer needs dos prompt but incompatable with dosbox

Recommended Posts

Dosbox can be a bit tricky, I had to use START in the batch to avoid a CMD confict. 
But it worked when you used dosboxportable as an additional app so it should of worked. 

Share this post


Link to post
Share on other sites
3 minutes ago, syntax_X said:

Dosbox can be a bit tricky, I had to use START in the batch to avoid a CMD confict. 
But it worked when you used dosboxportable as an additional app so it should of worked. 

I changed it back to the way I had it before and it's throwing the same error

Share this post


Link to post
Share on other sites

Its something you've done then :P

get it working the way you had it then try the batch again, you can test it by opening the game then manually starting the .bat
It shoud tell you its monitoring magslay.exe, then try closing magslay and dosboxportable should close with it.

All I can suggest to edit with that .bat is increase the first timeout to about 4-5.

2 seconds is a bit fast

Share this post


Link to post
Share on other sites

It's not mounting the game, it seems like the game needs to be mounted.

when I drop the mageslay.exe onto the dosbox icon it starts displaying lines of code that get added as actions are performed ingame, this dosen't happen when I use the batch file.

Share this post


Link to post
Share on other sites

do this

Make a shortcut for dosboxportable.exe call it MageSlayer and keep it in the portable folder.
make the shortcut target

"D:\Games\Mageslayer\DOSBoxPortable\DOSBoxPortable.exe " "D:\Games\Mageslayer\mageslay.exe"

 

Edit the first path in the batch file to 

D:\Games\Mageslayer\DOSBoxPortable\MageSlayer.lnk
 

(maybe remove start)

 

Edited by syntax_X

Share this post


Link to post
Share on other sites

I get a dosbox window with the game mounted if that's what your asking.

sorry I had a dumb moment, I'm testing the batch through launchbox.

Edited by heartofdestany

Share this post


Link to post
Share on other sites

I think I sorted it out, I remembered I had a similar problem with diablo 2, so I did what I did with that and I think it worked.

In case anyone wanted to know how I got it to work, I made a shortcut to the game with -w -nofixaspect added to target in properties and then launched it direct from the shortcut.

I have no idea now why dosbox helped at all ever. Sorry for wasting your time everybody.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...