Jump to content
LaunchBox Community Forums
Buttonmasher

CPS2 games keep crashing

Recommended Posts

I am trying to run my CPS2 games from my .183 mame romset but when I try and fire it up through Launchbox or Retroarch it begins to load but then initially crashes.  Ive tried to test this on several different cores including various versions of mame as well as fbalpha.  I cannot seem to find a solution online through searching so I thought maybe the community would have an answer.

Share this post


Link to post
Share on other sites

Going by what you are telling us here I am unsure of what the exact problem would be.

The 178 update of Mame and romset has and requires a .key file in the rom files, 186 has and requires an up to date qsound.zip.

Try your 183 rom set with the Mame (no year) core in Retroarch. Or set up a 183 build of stand a lone Mame. You can either use a UI version to audit your CPS2 roms to see what is missing or loading a game using the command line you can find out what the error is.

Share this post


Link to post
Share on other sites
10 hours ago, lordmonkus said:

Going by what you are telling us here I am unsure of what the exact problem would be.

The 178 update of Mame and romset has and requires a .key file in the rom files, 186 has and requires an up to date qsound.zip.

Try your 183 rom set with the Mame (no year) core in Retroarch. Or set up a 183 build of stand a lone Mame. You can either use a UI version to audit your CPS2 roms to see what is missing or loading a game using the command line you can find out what the error is.

It sounds that I am I gonna have to move away from the libretro cores and over to standalone MAME if I want any success.  I went with the libretro cores because I have found MAME pretty intimidating. I'm worried the customization I'm looking to achieve for my arcade cabinet won't be as good with MAME as what the libretro cores have been able to provide. It's incredible how many hours one can spend trying to get things setup exactly how they want. I just want to get it customized to how I want so that everything runs fluidly and disable it from the internet forever. 

Share this post


Link to post
Share on other sites

MAME can be intimidating at 1st its a extremely ambitious project that covers so much data. Luckily the Arcade functions are the easiest thing to get working in MAME without knowledge of the program. I suggest looking through this document to learn how a lot of things work. Some of the sections can be a little technical but some are more for the average user.
http://docs.mamedev.org/

Share this post


Link to post
Share on other sites

Is the issue that I am experiencing due to having a merged rom pack?  More specifically is retroarch/mame only opening the zip folder of the game and then just simply stopping rather than knowing which of the several versions to select?

Share this post


Link to post
Share on other sites

Yeah merged sets are the worst kind to use in LB and you have to have intimate knowledge of the ROMs naming to know how to utilize any versions outside of the parents. No RA MAME should work with a merged set so that shouldn't be an issue as far as I know.

Share this post


Link to post
Share on other sites

@DOS76  Even after downloading standalone MAME I am having a similar issue.  It works for a number of games just like when Retroarch was my default emulator in Launchbox, but it still seems to have an issue with several others.  When I try to load up a number of games, all of which I have the rom files for, MAME it gives me the error of, "The selected machine is missing one or more required ROM or CHD images.  Please select a different machine."  This occurs even for games that do not require a CHD file.  

Would you think that a split rom pack would keep this issue from occurring? 

Edited by Buttonmasher

Share this post


Link to post
Share on other sites

What version of MAME did you get if its the latest your cps-2 files won't work unless they use the 0.186 ROMs as they all changed.

Share this post


Link to post
Share on other sites

I am using MAME version .186 with the .183 merged rom pack.  However, every libretro MAME and FBA core that I tested against these particular roms also did not work either.  I am currently downloading the latest .186 split rom pack now.  Perhaps that will work.  

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...