Jump to content
LaunchBox Community Forums
a_netanel

Sega Model 2 not saving nvram

Recommended Posts

I noticed that each time I start a Sega Model 2 game I need to change the machine settings again. For example changing the machine type from "master" to "single" etc.

Did some digging and apparently the AutoHotKey script for this emulator maps the Esc key to a Process Close command, which causes the emulator to be killed and not save the file.

I changed the script to close the emulator gracefully, like so:

WinClose, ahk_exe {{{StartupEXE}}}

So, far it seems to work just as well, and the file is being saved.

I opened an issue for that (https://bitbucket.org/jasondavidcarr/launchbox/issues/3123/sega-model-2-emulator-ahk-script-fix) but thought I'll write it here too for any one having the same problem.

  • Like 3

Share this post


Link to post
Share on other sites

This has also worked for me.    Does it effect any of the other games?  Or is it per game settings that are being saved I wonder.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...