Jump to content
LaunchBox Community Forums
4pp_r0n3

Commodore VIC-20

Recommended Posts

I neep help emulating the Commodore VIC-20 with LauncBox / MESS. The problem is that I have no idea wether or not the BIOS I have is the right one, and that of how to emulate the Commodore VIC-20 with LaunchBox. 

Any help?

Share this post


Link to post
Share on other sites

Hi @4pp_r0n3

I would try a dedicated emulator too, but if you're set on using MAME, then here goes.

The parent machine is VIC-1001 (Japan). To run this you need the machine's romset and a device romset
vic1001.zip
c1541.zip

There are 3 clone machines

VIC-20 (NTSC). To run this you also need
vic20.zip

VIC-20 (Sweden/Finland). To run this you also need
vic20_se.zip

VIC-20 / VIC-20 (PAL). To run this you also need
vic20p.zip

The cartridge games with the a0 (A0) extension I found the easiest to work with as they open when clicked in LaunchBox.

If using cartridge games, your Default Command-Line Params in your MAME (Arcade) Associated Platforms tab will be one of (take your pick)

vic1001 -cart1
vic20 -cart1
vic20p -cart1

You may find the game screen size and position a bit different when using the PAL clone.
It's been a while since I played around with the VIC-20 under MAME and I didn't try too many games so you may find issues that I didn't. Best of luck and I hope that this has helped you a little.

  • Like 1

Share this post


Link to post
Share on other sites

Hello guys! Im trying to run it with the Retroarch Core, I get to the Vic-20 screen but the game doesn't start/load.  Am I missing a command? Thanks!

Share this post


Link to post
Share on other sites

If you are using WinVice to emulator the Commodore VIC-20.

Default Command-Line Parameters

.d64 .tap .prg Files : -autostart

.d64 .tap .prg Files (full Screen) : -fullscreen -autostart

.crt Files : -cartgeneric

.crt Files (full Screen) : -fullscreen -cartgeneric

Edited by GuroDragon

Share this post


Link to post
Share on other sites
On 9/22/2017 at 5:31 PM, Elber said:

Hello guys! Im trying to run it with the Retroarch Core, I get to the Vic-20 screen but the game doesn't start/load.  Am I missing a command? Thanks!

I'm having the same problem, I get the main boot screen and no further,  I tried, on a whim, to type run or load only to find the keyboard mapping is way off so that's another thing I have to address.  Frankly, it would be easier to unbox my original Vic-20 and just plug in the cartridges...

Share this post


Link to post
Share on other sites
16 hours ago, Vampireslug said:

I'm having the same problem, I get the main boot screen and no further,  I tried, on a whim, to type run or load only to find the keyboard mapping is way off so that's another thing I have to address.  Frankly, it would be easier to unbox my original Vic-20 and just plug in the cartridges...

Ditch Retroarch and just use Winvic, retoarch is great but not the best option for everything.  I listed the Default Command-Line Parameters above and here is a screen shot of my setup.

Winvic only takes about 5 minutes to download and setup in launchbox, but you can tweak it for quite some time.

 

 

2.thumb.JPG.d68f5863dfee8ac420391710a779d4d5.JPG

Edited by GuroDragon

Share this post


Link to post
Share on other sites

Using -autostart tries loading and running a disk but all of my files are cartridge .prg... opening a cartridge file in XVic works but how do you set autostart for cartridges?

Share this post


Link to post
Share on other sites
8 hours ago, Vampireslug said:

Using -autostart tries loading and running a disk but all of my files are cartridge .prg... opening a cartridge file in XVic works but how do you set autostart for cartridges?

For Carts  .crt Files : -cartgeneric

I setup up two emulators using the same .exe just with different Default Command-Line Parameters .

I can check when I get home, apologies I have about a 160 systems on my launchbox and  don't remember the exact solution I used for the vic20 off the the top of my head.

The old computers are kind of a pain in the ass when coming to launchbox as most had several formats for data storage and just like the real things are buggy and not always good right out of the gate, some even require custom config files. I am an old Hyperspin user, trust me launchbox is way easier to deal with and once you have played with it for while it becomes second nature.

Edited by GuroDragon

Share this post


Link to post
Share on other sites

I'm using Win-Vic and can't get any rom to load. I've tried all the different rom types, tried running them directly through the emulator, tried all the command lines, nothing! I get this screen everytime. Any help would be nice.

 

Screenshot (41).png

Share this post


Link to post
Share on other sites

Here`s the trick - Right click the Vic cartridge game in Launchbox, and choose "Edit".  Click on the Emulation tab.  Check the box marked "Use Command-line parameters".   Type in "-cartgeneric" into that field.

Vic20 cartridges will suddenly work fine in VICE Vic20!  I am using Version 3.2.

Another tip, if you're looking for an easy way to exit Vice with the escape key, try the following, which I discovered at https://www.lemon64.com/forum/viewtopic.php?t=33372&sid=af3ea6ae0b8c6a35f2278b5d18f69d33

Find the file win_shortcuts.vsc, located in the Vic20 folder and open it with a text editor (for example Notepad). 
Add this line to the table: 

Code:

KEY             27          IDM_EXIT                          X 

Vice can now be terminated with the Esc key.

Edited by MacGuyver
  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites

At last! they work, well the cartridge .a0 roms do. The other rom types still don't though. I've deleted all non cart roms, currently on the hunt for more cartridge roms. Many thanks MacGuyver!

  • Like 1

Share this post


Link to post
Share on other sites

I'm also having no luck yet getting the PRG and TAP files to run using VICE 3.2.   I tried GuroDragon's suggestion of using -autostart but have not had any success.  I just get a black screen.  

Share this post


Link to post
Share on other sites

I have the -autostart but am only able to successfully open .TAP files.  For some reason, I can't edit individual game entries, the Application and Configuration Command-Line parameters boxes are grayed out.  I tried the -cartgeneric with .CRT files but it still went to the loading/ready/run screen then nothing.

Share this post


Link to post
Share on other sites

Regarding the greyed-out parameters, to address this you need to click on the emulation tab on the edit game screen.  Click "Use Custom Command Line Parameters" and enter -cartgeneric.  I think it's really important to have specific command line parameters for specific games, depending on whether they are cartridges or not (i.e. a single command line parameter will not be useful for everything).

You were mentioning problems with CRT files.  What ROMset are you using?  I ran a test on the following CRT file from the Gamebase20 V03 which I believe is the most up to date collection of ROMs available.

The file I tested is called

Omega Race (1982)(Commodore)-a000.crt

The version of Vice that I'm using is WinVICE-3.2-x86-r34842

I tried the -autostart again and this time I realized that if I wait long enough on the black flashing screen, the TAP files do in fact work.  I wish I knew how I could address the black flashing.  I am running VICE full Screen.

Edit Game.jpg

Share this post


Link to post
Share on other sites

That looks like exactly what I need.  I've found that -cartgeneric does work with *most* of my CRT files, I think there may be a bad dump here and there and I'm pretty sure I'll need to do something with the Scott Adams carts that need the sys command "SYS 32592" to run them.  The problem, I realize now, was that I was changing the global setting for XVic which would allow -cart generic or -autostart, but not both.  Now I have the default -autostart as most files are TAP, and I'll edit the emulation setting for the CRT files to -cartgeneric and I think that will do it.  There are also PRG and A0 files to deal with but I deleted those for the time being, I may add them back and work on them later.  Thanks!

Share this post


Link to post
Share on other sites

One more tip that I just discovered.  It helped me to get more games working!  I'll explain carefully.

 

The example is "Load Runner".  I loved playing this game on my Vic as a kid, but for the life of me, I couldn't get it working using VICE in Launchbox.   I noticed in the TOSEC set available on archive.org there were the following ROM dumps of this game:

 

Lode Runner (1983)(Broderbund)(NTSC-PAL)[h][A000][multipart].crt

Lode Runner (1983)(Broderbund)(NTSC-PAL)[h][a][A000][multipart].crt

Lode Runner (1983)(Broderbund)(NTSC-PAL)[h][a][6000][multipart].crt

Lode Runner (1983)(Broderbund)(NTSC-PAL)[h][6000][multipart].crt

Lode Runner (1983)(Broderbund)(NTSC-PAL)[A000][multipart].crt

Lode Runner (1983)(Broderbund)(NTSC-PAL)[6000][multipart].crt

Lode Runner (1983)(Broderbund)(NTSC-PAL)[6000].crt

Lode Runner (1983)(Broderbund)(NTSC-PAL)(b)[A000].crt

 

Whereas in the Gamebase20_v3 set, there was only one Lode Runner dump:  Lode Runner.zip which contained two files:

Lode Runner-6000.prg

Lode-Runner-a000.prg

 

I tried everything to get these to work.  The great tips listed above which worked on TAPs and other cartridges (using -autostart or -cartgeneric) did NOT work on any of these Lode Runner dumps.

Then on the Vic20 Denial site, a user named Mayhem gave me the following tip of what needs to happen to run the Lode Runner.zip file on VICE via the command line:

-cart6 Lode Runner-6000.prg -cartA Lode Runner-A000.prg
You need the argument cartX, where X = 2, 4, 6, A, specifies the memory block to attach it to.
Not sure you can execute loading the game with the files in a zip.

 

This was the info I needed to sort this out!  While I was NOT able to get Launchbox to run TWO separate files in the command line like suggested above, the information about the -cart command is very important.

So next I focused on the ROM dumps that were not multipart.  So in the list above, there were two rom files that were already joined together.

 

Lode Runner (1983)(Broderbund)(NTSC-PAL)(b)[A000].crt

Lode Runner (1983)(Broderbund)(NTSC-PAL)[6000].crt

 

I could not get the (b) [A000] dump to work, but the 2nd [6000] dump does in fact work fine in Launchbox, by adding the -cart6 on the command line parameters line!  Success!

However, I for some reason this command does not work if the crt file is contained in a zip.  So make sure to unzip it first!

So in summary, if you are trying to run dumps from TOSEC, stay away from the multiparts, make sure files are unzipped, and use the following command line parameters:

For .crt or .prg files ending in A000, use -cartA      (must be capital A, small a does not work)

For .crt or .prg files ending in 2000, use -cart2

For .crt or .prg files ending in 4000, use -cart4

For .crt or .prg files ending in 6000, use -cart6

 

Let me know if this helps you run any more carts!!! 😊

 

Edited by MacGuyver

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...