Jump to content
LaunchBox Community Forums
LuismaSP89

Rpcs3 in launchbox

Recommended Posts

Does anyone know why Launchbox is incapable of indetifying games that are part of a compilation (the several god of war, ico, etc) but only the compilation itself?

It's a bit annoying because the compilation is useless to launch the games with rpcs3, you need to launch the independant game itself. Also those games exist independently on the PSN.

Is there any way we could fix this? Thanks!

Edited by Nocta

Share this post


Link to post
Share on other sites
16 minutes ago, Nocta said:

Does anyone know why Launchbox is incapable of indetifying games that are part of a compilation (the several god of war, ico, etc) but only the compilation itself?

It's a bit annoying because the compilation is useless to launch the games with rpcs3, you need to launch the independant game itself. Also those games exist independently on the PSN.

Is there any way we could fix this? Thanks!

Its not a launchbox issue. If the game has 2 eboots to launch the games separately the you need to import them separately. Also PS3 games come in two types, disc and store, they have different serials and go into different folders in the emulator, so if you have the disc version of the game then that is what the emulator will see. Again not a Launchbox problem but a feature of the emulator itself.

Share this post


Link to post
Share on other sites

Thanks neil9000!

My bad, I was actually wrong, a lot of those games are in the database, I was just making mistakes in the process.

Ico HD is missing from Launchbox's DB though it seems.

Edited by Nocta

Share this post


Link to post
Share on other sites
On 9/8/2020 at 10:56 PM, Drybonz said:

Ah, good call, Sundogak... I had made a custom config for Demon Souls at some point and that is the game I have been testing with.  So, if I check all the boxes in the custom config it does close the RCPS3 launcher after the game closes.  I guess my main wish would be if I could, like a lot of other emulators, launch through LB and completely hide the RCPS3 launcher as well... but thanks for helping me get the launcher to close.

*edit*  The LB options you mention might do the trick, but they are LB Pro features and I let my LB paid subscription run out a long time ago, so I can't use those.

Rpcs3 actually has a --no-gui command-line parameter. I used it in the past but I ran into some problems, although I can't remember what it was.

Share this post


Link to post
Share on other sites
9 hours ago, Koroth said:

Rpcs3 actually has a --no-gui command-line parameter. I used it in the past but I ran into some problems, although I can't remember what it was.

I have never had issues in that the GUI always stays behind all LB windows so really haven't run into the need for option yet. But for those that are see this thread

https://github.com/RPCS3/rpcs3/pull/6407

TL:DR is no real option to hide the GUI that works in front end environment currently even though there is a no-gui flag. 

Apparently the no-gui flag prior to a fix in Aug 2019 was really a "headless" function used for debugging. It wouldn't work at all from a frontend perspective. There was a fix made that added a headless flag and he coded in another no-gui option using the same flag as prior:

--no-gui

However, it still has issues per the author as noted below. Towards the end of the thread some fellow LB'ers were noting some issues still with some AHK hacks as workarounds.  The issue was closed, so not sure high on priority list of author. 

Quote

The problem is that we haven't properly implemented the no-gui option yet. So if you run a game with llvm recompilers then it will open a window with a progress bar. As soon as that window is completed the game will close itself. You can work around this issue if you use interpreters and asmjit. This is a known issue. So it it basically working "as intended" for now.

 

Share this post


Link to post
Share on other sites

I tried to insert the RPCS3 in launchbox and I noticed that with the most recent versions of the emulator the games under launchbox start but all give me errors (eg "fatal error. Trophy initialization failed ..."). Using an old version (0.0.6-8439) everything was perfect.
However, my question is another. In the various tutorials I have seen that the importation of games (eboot.bin file if I'm not mistaken) takes place from folders other than the classic one of the emulator (... DEV_HDD0 \ GAME \ ..). I tried too but nothing, unless in the folder there is the same game already installed. Did I miss anything when it comes to importing games? To use the most popular versions of the RPCS3 can you tell me something?
Thanks!

Edited by Colorman3605

Share this post


Link to post
Share on other sites

@Colorman3605 Current RPCS3 version works okay on my setup with LB and no launch errors. I assume you have verified they work in RPCS3 directly, outside of LB since sounds like somethings not right with the RPCS3 install if getting that error.  As far as what LB points to, it is in the normal directory structure and the eboot.bin file.  So for example, Demon Souls for US, LB points to this file:

Capture.thumb.JPG.ad7cf891d25b03653e1826003cecde96.JPG

 

Share this post


Link to post
Share on other sites
7 hours ago, sundogak said:

@Colorman3605 Current RPCS3 version works okay on my setup with LB and no launch errors. I assume you have verified they work in RPCS3 directly, outside of LB since sounds like somethings not right with the RPCS3 install if getting that error.  As far as what LB points to, it is in the normal directory structure and the eboot.bin file.  So for example, Demon Souls for US, LB points to this file:

Capture.thumb.JPG.ad7cf891d25b03653e1826003cecde96.JPG

 

All games outside of Launchbox work fine. Of course there are any various settings to be made (video, audio ...) but they start and work. Maybe I asked the question wrong. The eboot file and therefore the game folder must necessarily be in the DEV_HDD0 \ GAME \ "gane folder code" \ of the RPCS3. From various tutorials it seems not (at least from what it seems) but in practice not unless the game is also in "DEV_HDD0 \ GAME \" gane folder ". As for the launchbox version I will do other tests. It seems to me however that all problems launching games via launchbox stem from loading while loading trophies, can this be a clue? Are there any settings to be made in this regard? Thanks!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...