Jump to content
LaunchBox Community Forums
cowboypat905

Sound problem

Recommended Posts

Using LB 7.10 in Windows 10

Used to work perfect. No idea what happen but some emulators still work fine in LB but no sound. When playing games directly in the emulator (outside LB), the audio works. 8 emulators out of 16 are working great, audio and video. The other 8 lack of audio (music when available still works when hover games but no audio at all when playing game). Also,  the 8 emulators lacking of audio run through Retroarch, and from the 8 emulators that have no audio problem, 3 run through Retroarch.

Not sure what settings I should look for and where (Retroarch? LB?). ANd why are they working ok when outside LaunchBox. Any help please. Waiting to fix this problem before upgrading to BigBox.

Thanks

Share this post


Link to post
Share on other sites

That is extremely strange and Launchbox should not have any effect on audio in an emulator. If it was to be causing problems one would think it be in all the emulators or in the case of Retroarch all the cores. Since 8 of systems having sound issues I would check in Retroarch with those cores running at the audio settings and see if the volume got turned down or if mute got turned on somehow.

I remember one time having sound problems with the Turbografx / PC Engine core and it turned out to be the audio settings for the core itself for CD games.

Share this post


Link to post
Share on other sites

Thx again for quick reply. Found problem. I opened retroarch.cfg, scrolled down and for some reason, I saw audio_mute_enable="true" (I replaced it with false). 

Big thank you 😀

Share this post


Link to post
Share on other sites

Hello guys :)

 

I am new to LauchBox and i am really impressed !! It looks so cool. If it works for me, i think about the pro version ;-)

But i have the same problem as the Threat Starter :-( I can launch my games directly in RetroArch with all sounds.
When i start them via LauchBox, my games are muted. I just have tryed SNES and N64 Roms.

I use LauchBox v 7.14 and RetroArch 1.6.7 with the mupen64_plus Core for the N64 Roms and a snes9x core for the SNES Roms.

Can anyone confirm this problem or help me to fix the missing audio :-)

 

THANK YOU VERY MUCH !!

Share this post


Link to post
Share on other sites

Did you try what fixed it for the previous member in this post? 

Open your retroarch.cfg and scroll down to audio_mute_enable in that line item if it says "true" replace it with "false".

Share this post


Link to post
Share on other sites

Hey Retro808 !
Thank u for the quick reply!!

Yeah - sure i have checked my retroarch.cfg.
my audio_mute_enable is set to "false"
I use my TV as a Monitor and my PC is connected via an HDMI Cable. But i dont think, that this can be an problem.
Everything else outside LB is working fine with audio :( Do i have to put in some start parameters for my emulator?

I just tried the other N64 Core from RetroArch (parallel_n64), but with the same issue.... absolutely no sound.
When i am in the muted N64 game via LB and i switch my controller off and on, i can hear the windows sound for plugging an USB Device, so i think its not an driver problem.

But i have ablolutely no clue what causes this problem O.o
In the end i will try to reinstall LB. In my retroarch i have a lot of configs, so i will avoid to reinstall it...

Anyway Retro88 - thank u for your answer ^_^

Share this post


Link to post
Share on other sites

Sorry that did not help. I am not sure what it could be. I am not too knowledgable in this area. I also do not remember seeing many audio issues like this with LB and Retroarch. Hopefully one of our resident experts will chime in. 

Share this post


Link to post
Share on other sites

There is no reason to re-install Launchbox, Launchbox has no effect on the emulator other than loading it so in-installing would be a waste of time. Are you loading a specific config for Retroarch through Launchbox?

Share this post


Link to post
Share on other sites

Hey :)

No Problem Retro808 - thx anyway!!

@neil9000: Okay - i was thinking the same, that LB just "lauch" the emulators and executes the executable files :$
Is there a way to start my Retroarch with a specific cfg through LB?
I am not sure...

I just import the N64 ROMS, choose Retroarch as my default emulator, download the covers and metadata, and that's all.
After starting the game via LB, it starts with Retroarch and everything is good... except no audio.

*********************

Just find out, when i go to Retroarch Audio options and short change of the Audio Output Rate (Hz), i have my sound when back in game !!!! yippi yippi yeah...
I can change it from 48000 to 48100 and immediately back again to 48000... than go back in game with sound !!
WTF?!? O.o
After quit my game and start it again via LB, it is muted again.... till i change the Output Rate in any kind (up and down again - or down and up again)...

Now my question is: how can i bypass this workarouond? o.O

Anyway I HAVE SOUND VIA LB... so i can put all my roms here and sort my collections with covers and metadata :):)

Share this post


Link to post
Share on other sites

Good to see you found the issue. To save it at that frequency load retroarch by itself with no game or core loaded, change the sound to what you want then go back to the main menu and down to configurations and choose save current configuration. 

Share this post


Link to post
Share on other sites

hmm... to change the standard frequency does not help. Everytime i lauch via LB, my games are muted till i change the frequency settings.
I juse 48000 as the default - and when i start directly via Retroarch that works.
But when start via LB, i have to go in the settings and change it to eg. 48100 and back again to 48000. Than i can play with sound at 48000 and everythink work finde.

When i use 48100 as default and start the game via LB and my default 48100, i have no sound anyway.
I have to do my workaround again...

I just have to CHANGE the settings. Only then i got my sond... it is not the settings at all.
It seems that change of the audio settings trigger something so i have my audio back :|O.o

I will play with the settings and look if i can find a solution for that workaround. But in the end i have to save all my configs from Retroarch and will do a fresh install here.
Maybe this will help...

Anyway i am happy to use LB in a way that works for now.... :P

Share this post


Link to post
Share on other sites

Hello again...

Still fightin with my sound problem :(

So now i have completly reinstalled my retroarch... but still the same problem.
Even with the fresh instal of Retroarch!
And with the backuped cfg files the same... both with no sound if i start via LB.

Right now there was an update for Launchbox to 7.15.
But nothing changed (for my problem)

Only when i do a change in the Audio_frequence (Hz) settings, it will get some sounds :(
Okay - this costs 5 extra Seconds for this workaround... but everytime i start a game, i have to stop it and do my audiosettings change.

Maybe someone can post his or her Retroarch.cfg audio settings, so i can copy them and see if i have something wrong?

I have attached my cfg if someone is interessted in it...

 

If i found a solution i will post it ... :|
thx anyway guys... LB4EVER ^_^

retroarch.cfg

Share this post


Link to post
Share on other sites

This is a weird issue with Retroarch and your system, the default settings of Retroarch should be fine, you could try and change the audio driver in the drivers menu of Retroarch.

  • Like 1

Share this post


Link to post
Share on other sites

Your config looks fine, xaudio is almost 99% of the time the default setting you want to use. I would try dsound and see what results you get. Is your PC using a soundcard or does your motherboard have onboard audio? Make sure you have the latest drivers for your graphics and sound cards.

  • Like 1

Share this post


Link to post
Share on other sites

THANK U SO MUCH GUYS FOR YOUR ANSWERS AND TAKING PART OF MY PROBLEM !!!

I use an Intel NUC with Intel Iris Pro Graphics 580 and the digital audio via HDMI to my TV.

So i think i have my Audio on board... 


Anyway
I spend hours of fightin with this issue...
But keltoigael and Lordmonkus (
my heros !!!) were right - i changed my audio driver in Retroarch to dsound and TA-TAAA... i have Sound all over !!!! :D
Directly in Retroarch or if i start via LaunchBox.

So my Problem is solved by changing the audiodriver settings in Retroarch to dsound !!!

LaunchBox is not only great because of its comfort and design... it is also great with THIS FAST AND SUPER SUPPORT !!

Thank you Thank you Thank you !!! 
 

Edited by Kamikaze01
  • Like 3

Share this post


Link to post
Share on other sites

dsound would be correct since you are using intel's integrated hardware. If you ever plan to throw in a nvida card and run it through hdmi switch back over to xaudio. 

Share this post


Link to post
Share on other sites

have a few laptops using Intel Integrated graphics and I never have to switch my audio driver from default settings this is really weird but at least you sorted the issue out.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×