Jump to content
LaunchBox Community Forums

CD-i emulation


Recommended Posts

So I have been trying to learn more about CD-i Emulation, and it all seems to boil down to the paid CD-i Emu and MESS. But this info is years old from what I can see Googling it.

Anyone know of anything new? Also, I looked up MESS and they say it is incorporated into MAME, but MAME mentions nothing of it.
Any help guiding me into the right direction would be great!!

Thanks!

Link to post
Share on other sites
  • Replies 85
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

That's a good question, you are now the designated guinea pig to find out

I just recently set this up and here are a couple items I found as well as will summarize previous comments: cdimono1 is the only MAME machine that works currently and is listed as "imperfect"

Ok so ran the CHDMAN on my .chd files and it made my bin and cues for me.  Still when trying to open them with MAMEUI64 was getting the servo and slave errors.  At least it would open the mame window.

Posted Images

Brad did a tutorial on CD-i using Mess:

But the current Mame should be the same or very similar. I know the command line parameters are the same and I have toyed around with Mame for some of the non arcade stuff and it's fairly straight forward once you have the bios and command line.

  • Thanks 1
Link to post
Share on other sites

I honestly couldn't tell you which is the better choice. I only briefly messed with Mess for it to play Dragons Lair but it was missing the MPEG encoder addon module for the system so it never worked beyond telling me it was missing that.

Beyond that though I had no interest in the CD-i.

  • Like 1
Link to post
Share on other sites

I am a little stuck.... So I followed the video tutorial and I got only the files they mentioned;
cdimono1&2 and the CHDs for the games I am testing. Put them all into roms folder.
I am using the current MAME 0.189 x64 release. Did the command line perimeters as show as will. When I launch the game nothing happens. I do not see the mame INI, however they mentioned if you use the default roms path then it shouldn't need tweaking.

Any suggestions? Maybe I need more files for the roms folder? :P

Edited by wolf
Link to post
Share on other sites

I figured it out.... they did not mention you have to uncheck in the emulator settings for mame/mess the boxes for "Don't use quotes" & "Use file name only" & "No spaces before rom"

After unchecking them at all worked perfectly!

Edited by wolf
Link to post
Share on other sites
28 minutes ago, wolf said:

I figured it out.... they did not mention you have to uncheck in the emulator settings for mame/mess the boxes for "Don't use quotes" & "Use file name only" & "No spaces before rom"

After unchecking them at all worked perfectly!

Just wondering, now that you've got it working, how is the compatibility (lately) with CD-i emulation in the latest version of Mame?

Link to post
Share on other sites

Thus far I tested the Following using MAME's CHD for:

Link - Faces of Evil (seems 100%)
Zelda - Wand of Gamelon (seems 100%)
Zelda's Adventure (Seems 100%)
Hotel Mario (Seems 100%)
The Apprentice (Plays well, has few discolorations during title, just little tearing in gameplay)

I don't really care for any other games unless they are exclusive. I play all the other big CD-i games in better systems like DOS or other console emulators.

Also, instead of using just MAME... I am using MAMEUI 64. It is set up exactly the same however you will have a GUI for working on the video settings in the menus. Highly recommend this over the command/basic MAME!!!

  • Thanks 1
Link to post
Share on other sites

Use CHD files!! They work perfectly! you can find them by searching cd-i chd.

Read a little in and you can see where you can choose the CHD individually then the entire database which is massive!
 

 

 

Edited by neil9000
This is the second time i have edited this post, mentioning the whole site address is just as bad as a direct link. Please refrain from directly referencing sites that host copyrighted materials.
Link to post
Share on other sites

Does anyone using MAME for CD-i, know how to force bi-linear filtering off?

I am using mameui 64, and doing all the video changes in menu only seems to affect arcade games. Not CD-i emulation. Hoping to edit a config file or something.

Edited by wolf
Link to post
Share on other sites
1 hour ago, wolf said:

Use CHD files!! They work perfectly! you can find them by searching cd-i chd.

Read a little in and you can see where you can choose the CHD individually then the entire database which is massive!
 

 

 

Hmm, I don't quite follow your advice. I'm already using the CHD files with both Mame and Mess, and when a game like "Dragon's Lair" loads up, I get the same message "Digital Video Cartridge Required" and the emulation stops from there. Is there some type of secret method to get around this, or is it simply impossible at this point in time?

Edited by bundangdon
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...