Jump to content
LaunchBox Community Forums

CD-i emulation


Recommended Posts

7 hours ago, JoeViking245 said:

Is it unplayable in-game, or does it not load at all for you?  If the latter, did you try directly in stand alone MAME?

If it's not loading, which method in LaunchBox are you using to point to the rom?  If you have MAME setup for soft lists, you can simply launch "cdimono1 -cdrm zeldgam".  Unless you have the US version, then use "zeldgamu".  Or do you just have LB pointing to the "FULL\PATH\TO\ROM\FILE.chd"?

Either way, just tested and both do work.  Again, if using the 1st method, make sure you're telling the correct version of the rom you have.

Zelda is currently unplayable. It launches, but as soon as you select a level, it slows down extremely and eventually crashes. This happens with recent mame core versions, I think .222. If you use an older version of mame (I tried .215) it works.

See also here: https://mametesters.org/view.php?id=7716

  • Like 2
Link to post
Share on other sites
  • Replies 86
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

That's a good question, you are now the designated guinea pig to find out

I just recently set this up and here are a couple items I found as well as will summarize previous comments: cdimono1 is the only MAME machine that works currently and is listed as "imperfect"

Ok so ran the CHDMAN on my .chd files and it made my bin and cues for me.  Still when trying to open them with MAMEUI64 was getting the servo and slave errors.  At least it would open the mame window.

Posted Images

10 hours ago, JoeViking245 said:

That's obviously where my testing stopped. lol 

Haha, yes I found out about that by pure accident. Wanted to show these games to a friend and that's when I found out it didn't work anymore.

  • Like 1
  • Haha 1
Link to post
Share on other sites
9 hours ago, SiriusVI said:

Haha, yes I found out about that by pure accident. Wanted to show these games to a friend and that's when I found out it didn't work anymore.

Due to the lack of FMV i cnat use cdi in any meaningful way so i just wanted to show zelda and mario along side snes and nes and gba etc as an oddity.  I also cant get Mutant Rampage - Bodyslam working.  If i could just get zelda and this working I would leave the rest alone haha

Link to post
Share on other sites
1 hour ago, WInzen said:

Due to the lack of FMV i cnat use cdi in any meaningful way so i just wanted to show zelda and mario along side snes and nes and gba etc as an oddity.  I also cant get Mutant Rampage - Bodyslam working.  If i could just get zelda and this working I would leave the rest alone haha

Well, just use any mame version below .221 and it should work.

  • Like 1
Link to post
Share on other sites
19 hours ago, SiriusVI said:

Well, just use any mame version below .221 and it should work.

 

not sure how to set this up.  I found via the cdi bios a cdi list in mame but when i click on a working game like mario it says "missing files software" :?

EDIT: I set it up in LB and the old working games work and now ZELDA works!

But mutant rampage still wont work :(

I can get to the player screen and then the philips logo but then black screen of death.

maybe my roms are bad thought the game is listed as working perfectly on a compat list.

Or do we know if this game works ? Anyone have this working on mame?

thanks

 

 

Edited by WInzen
Link to post
Share on other sites
  • 1 month later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...