Jump to content
LaunchBox Community Forums

Recommended Posts

2 minutes ago, eatkinola said:

The "inception" look will always happen if you use viking's videos,

Yeah you will just want to use the standard emumovies platform montage videos with this theme, then it will look like Vikings platform videos.

Share this post


Link to post
Share on other sites
7 minutes ago, eatkinola said:

Glad you like the theme, @Guidope. It's designed for 16:9 screens and won't look as intended at 4:3. However, you could allow it to stretch and fill a 4:3 screen. Look in the ThemeSettings.xml in the root of the theme's folder. There should be a tag called Force16x9... set to true -- set this instead to false, and it should then allow stretching to 4:3.


    <Force16X9AspectRatio>true</Force16X9AspectRatio>
    ...change to false

The "inception" look will always happen if you use viking's videos, as I used his videos to make the backgrounds with screen cutouts. While Nostalgia is one of my favorite themes, not that I'm biased :), you might want to look into a 4x3 theme for your cabinet. There are a few out there. Another theme I created called Refaktor should work well for either 4x3 or 16x9.

https://forums.launchbox-app.com/files/file/1259-rξfδktφr/

This already helps out a bunch! To me this is the perfect theme, so I guess I'll have to live with the squeezed background image for now.

  • Game On 1

Share this post


Link to post
Share on other sites

@eatkinola If I were to convert all platform png's to the correct ratio, with the cutouts for the video's at exactly the right position, would it still be a lot of hassle to modify the theme code-wise? 🤐

 

 

Share this post


Link to post
Share on other sites
1 hour ago, Guidope said:

If I were to convert all platform png's to the correct ratio, with the cutouts for the video's at exactly the right position, would it still be a lot of hassle to modify the theme code-wise? 🤐

After cropping those pngs, you'd need to adjust the @INDEX files in the AVLF subfolder to correctly position the videos. Then (and this is probably the hardest part), you'd need to edit each view's xaml file to adjust the layout. You'd probably also need to scrap some design elements in the process to make things fit. It could be done but will take a good bit of work.

  • Thanks 1

Share this post


Link to post
Share on other sites
Posted (edited)

I love this theme but some videos don't play yet they do when using the default theme. One specific system that doesn't play is MAME using WMP or VLC, though VLC standalone plays them fine. Relevant pastebin of video properties from MPC-BE player.

Edit: Also using LB 9.10 and the latest Nostalgia which I downloaded today.

Edited by Tony
Specify versions

Share this post


Link to post
Share on other sites
3 hours ago, Tony said:

I love this theme but some videos don't play yet they do when using the default theme. One specific system that doesn't play is MAME using WMP or VLC, though VLC standalone plays them fine. Relevant pastebin of video properties from MPC-BE player.  Edit: Also using LB 9.10 and the latest Nostalgia which I downloaded today.

Thanks for the info. Pardon all these questions -- just trying to narrow it down a bit more. Was it working before you upgraded LB or the theme? Does it only occur for games where you use theme videos? Anything else the games for which videos do not play have in common? Does it show something besides the video, e.g., screenshots, or just the tv-static video? Also, if you want to pm me a few of the videos that aren't playing that might help, though I assume you're using the same videos as me from emumovies (?).

Share this post


Link to post
Share on other sites
Posted (edited)
8 hours ago, eatkinola said:

Thanks for the info. Pardon all these questions -- just trying to narrow it down a bit more. Was it working before you upgraded LB or the theme? Does it only occur for games where you use theme videos? Anything else the games for which videos do not play have in common? Does it show something besides the video, e.g., screenshots, or just the tv-static video? Also, if you want to pm me a few of the videos that aren't playing that might help, though I assume you're using the same videos as me from emumovies (?).

1) At one point, yes, it was working but I haven't launched Bigbox in a good 6 months, I mainly use the LB interface.

2) Theme videos? I don't really use those, if I'm understanding the term correctly, I just use video snaps for games and usually search youtube for console commercials as my main console videos. I'm not sure it's allowed but for instance, my source for MAME videos was the Arcade Punks HQ pack, most other places it was Emumovies. The other Bigbox theme I use, Unified Refried and default, plays those videos fine. One exception I've experienced lately is BB crashes when loading my Colecovision games, no problem with LB, but that's another issue I'll have to resolve later. I'll PM you a few examples.

Edit: SOLVED! Thanks to eatkinola's quick response. Just had to specify in LaunchBox\Themes\Nostalgia\Views\Styles\Nostalgia.xaml to use VLC instead of WMP via editing <sys:String x:Key="NostConfig_MediaPlayerImpl">VLC</sys:String>. I suspect maybe a codec issue with built-in WMP and since I'm using odd snap packs from the internet that may use various other encoding means for x264 videos.

Edited by Tony
Solved
  • Thanks 1

Share this post


Link to post
Share on other sites
2 hours ago, Tony said:

Edit: SOLVED! Thanks to eatkinola's quick response. Just had to specify in LaunchBox\Themes\Nostalgia\Views\Styles\Nostalgia.xaml to use VLC instead of WMP via editing <sys:String x:Key="NostConfig_MediaPlayerImpl">VLC</sys:String>. I suspect maybe a codec issue with built-in WMP and since I'm using odd snap packs from the internet that may use various other encoding means for x264 videos.

Thanks @Tony for the troubleshooting efforts. To others reading this, bear in mind switching to VLC in my themes (i.e., using the Ao.Bigbox.Themer plugin) might lead to instability; it may work, it may not depending on the videos. That's why my themes force WMP by default. In my experience, WMP runs smoothly and efficiently. WMP does not support as many codecs out the box as VLC, which can be an issue for some users; depending on how you source your videos. I've had great experience with emumovie vids.

Share this post


Link to post
Share on other sites

Just wanted to let you Guys know my theme got completely messed up when installing the newest version of LB. Screen starts up on ‘general’ With no games or platforms shown. Can’t change views either. Other themes seem to still work fine

Share this post


Link to post
Share on other sites
5 minutes ago, Guidope said:

Just wanted to let you Guys know my theme got completely messed up when installing the newest version of LB. Screen starts up on ‘general’ With no games or platforms shown. Can’t change views either. Other themes seem to still work fine

Thanks, Guidope. I had to update it to support LB 10+. I'm almost done and hope to post an updated Nostalgia this weekend.

  • Unusual Gem 1

Share this post


Link to post
Share on other sites

UPDATED to v2.0 -- support for LB10+ (now requires 10+) ... Turned off by default is when then selection wheel fades to platform/game details. You can turn this back on if you want by quickly editing Views\Styles\Nostalgia.xaml ... near the top of the file, and the bundled PDF describes what to change.

@Guidope

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...