Jump to content
LaunchBox Community Forums
Alby22

DosBox -freesize not working

Recommended Posts

Hi everyone i need help for DOSBox settings. I want to install The Elder Scrolls Daggerfall but seems I need more space to install it. I Have already done the -freesize method but it doesn't work i'm so sad about this.

I'm running it on Win 10 and I have downloaded the Bethesda version on their site.

Thank to everyone that can do anything about this.59ef5f6f5f997_DesktopScreenshot2017_10.24-17_39_43_50.thumb.png.c530772efb2feee600c0d6001f26c645.png59ef5f03b04a2_DesktopScreenshot2017_10.24-17_38_43_21.thumb.png.f909fd4cf347e5cd8ef1bbdc309e134f.png59ef5f19078dd_DesktopScreenshot2017_10.24-17_39_05_41.thumb.png.5ef4c41e0a33079d283c58911bb066c6.png

Share this post


Link to post
Share on other sites

As it says in your screenshot, the Autoexec portion of a conf is only used if the application path is not set. Also, for the love of god, never mount C as your actual C drive. That is a very bad idea that can lead to deleting/changing files that you do not want to be deleted/changed.

Open up DOSBox by itself. You can do this by right-clicking on a DOS game in your library and selecting "Open DOSBox" or by navigating into your LB folder, going to the DOSBox folder, and starting DOSBox.exe.

mount c "L:\MS-DOS\" -freesize 1024

mount d "L:\MS-DOS\Dagger\DFCD\" -t cdrom -label Daggerfall

D:

Install

Select "Continue, I agree to the terms"

"Install the game to your hard drive"

"Change the install size"

"Huge installation"

"Yes, this installation size is fine"

"Yes, I want to install the game here"

"Go ahead and install the game"

Let it complete, setup your sound card options, and then import it into LB. Dagger.exe should be the startup exe and setup.exe in the setup field. Make sure the DFCD folder is setup as the mounted CD (D:\) in the mounts tab. The -label Daggerfall bit is important otherwise it'll think it's the wrong CD.

EDIT: I can't remember if you can indicate the label in the mountings tab in LB or not (not at home to check currently). If not, worst case scenario we can just create a .conf that has the proper autoexec text once you've installed the game. You would do that by removing anything in the paths fields of the Launcher tab, removing any mounts in the mounts tab, then going to the DOSBox tab, clicking the "create..." button, scroll down to the bottom of the .conf to the autoexec portion, and adding te following:

mount c "L:\MS-DOS\Dagger"

mount d "L:\MS-DOS\Dagger\DFCD\" -t cdrom -label Daggerfall

C:

Dagger

Share this post


Link to post
Share on other sites

 

Thank you I managed to install the game but did not understand the last step of the explanation in which to explain how to add the game to LB and how to set the cd.
34 minutes ago, Zombeaver said:

 

34 minutes ago, Zombeaver said:

 

Share this post


Link to post
Share on other sites

Drag the entire Daggerfall folder into LB, indicate that it's a DOS game, select "Use the files in their current location", scrape for metadata, etc. and once it's done edit the game entry and go to the mounting tab - there's a section to add either a disc image (like an iso or bin+cue) or a folder and you can indicate that it's the CD and the drive letter for it (we want D:\ in this case).

I can't recall from memory if you can actually specify the label for the disc though - 99% of the time the label doesn't actually matter, but it does for Daggerfall. Unless the disc (the DFCD folder in this case) is labeled via -label Daggerfall in DOSBox, it will think you're using the wrong disc.

I'll actually be home in about 10 minutes so I can double check Daggerfall in my library. Worst case scenario, if you can't specify the label in the mount tab, it can be specified by making a custom .conf for the game and then specifying the necessary start commands. You can do this by removing anything that's in the path fields of the launcher tab when you edit your Daggerfall entry, removing anything that's in the mounts tab, then going to the DOSBox tab, clicking the "create..." button, scrolling to the bottom and below the Autoexec line entering (in your case) the following:

mount c "L:\MS-DOS\Dagger"

mount d "L:\MS-DOS\Dagger\DFCD\" -t cdrom -label Daggerfall

C:

Dagger

Share this post


Link to post
Share on other sites

Ok i added Daggerfall to LB and i've done the thing in the mounting tab. Now when i open it in DOSBox says that cannot recognise the cd in the D: directory. For now i will wait until you come home and see.

Share this post


Link to post
Share on other sites

It looks like in my case I'm actually using a disc image (.iso) so it's not quite the same scenario. There doesn't appear to be a way to specify the label in the mounts tab.

So, go ahead and remove anything the mounts tab:

image.thumb.png.eb82f69e0dc861491c1ee8988ab8d5d7.pngGo the launcher tab and clear out the paths:

image.thumb.png.53d2b91233fbaa36998080600fecc05a.pngGo to the DOSBox tab, and click the "create..." button and save dosbox.conf into your Daggerfall folder. Then click the "Open in notepad" button.

image.thumb.png.02c9345ad678ead7c6303801c622dc11.pngScroll down to the very bottom, and you'll see the line:

[autoexec]
# This is run at startup, but ONLY IF the Application Path is not set.

Underneath that line, add in the following:

mount c "L:\MS-DOS\Dagger"

mount d "L:\MS-DOS\Dagger\DFCD\" -t cdrom -label Daggerfall

C:

Dagger

Save and close it. Start the game.

Share this post


Link to post
Share on other sites

I've done all of this and i'm getting this screen (The "DAGGER" is in lowercase):

59ef77c50bead_DesktopScreenshot2017_10_24-19_25_24_20.thumb.png.192174693a4989582ab951d5e3c7dbca.png

Edited by Alby22

Share this post


Link to post
Share on other sites

You moved it into your LB directory on import. I told you not to do that. The C mount line would now need to be:

mount c "E:\Emulatoti\Launchbox\Games\MS-DOS\Daggerfall\Dagger\"

When you import DOS games into LB you should always use the "use in current location" option in the importer.

Share this post


Link to post
Share on other sites

You should be able to just change the conf. The line for mounting C needs to be replaced with the one I have above. Based on your DOSBox screenshot, the DFCD folder hasn't moved so the D mount line would be the same.

Share this post


Link to post
Share on other sites

Ok thank you and sorry for the inconvenience I will try to do everything and i will post something in case has gone wrong :D

Edited by Alby22

Share this post


Link to post
Share on other sites

I have the freespace issue for DOSBox on Windows 8. I have it set at freespace 800 in the mount command on autoexec but no matter what value I set it at I get only 250 MB. I've looked for answers to this and am just unable to find a solution. I've tried setting freesize to 500 and all the way to 614400 because that was the number specified on the instructions page for Daggerfall on another site. But it just will not exceed 250 mb. Any advice would be appreciated.

dosboxscreen.jpg

Edited by Rex3794

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...