Jump to content
LaunchBox Community Forums

BigBox Freezes after Exiting Emulator (not every time)


mgunther32
 Share

Recommended Posts

I know this has been discussed before, but I still haven't found a solution... I have no problems AT ALL with version 7.0, but when I update to anything newer than that, I run into the following issue: (Doesn't happen every time) But often, when I exit an emulator (using the built in automation... (select + start)) BigBox will completely hang.. It happens often enough that I created an AHK that closes and restarts BB.   As I said, everything works fine on version 7.0, but I really like the playlist functionality (amongst other upgrades)

Things I've tried:

I have used both VLC and Media player for videos.

I forced populated all game wheel images.

I'm using the max RAM cache. 

Hide Taskbar (Checked & Unchecked)

Show "Loading Game" (checked & unchecked)

Some observations:

I am running Windows 7, but I shelled with BigBox (replaced explorer.exe with BigBox.exe)... If I have explorer.exe loaded when the freeze occurs, I can see the taskbar (meaning BigBox lost focus).  But clicking on BigBox to return focus doesn't solve the issue, I have to kill and restart regardless

The videos and scrolling game info freeze as well

It generally doesn't freeze after exiting the first game... only after the second or third exit

Sometimes BB will lose focus after exiting an emulator, but the gamelist video will still be playing... if this is the case, then I can just "click" to give BB focus back, and all is well (if the video is frozen... then I have to close/restart BB)

Specs:

Windows 7 64bit

Core2Duo E8400 @ 3.00GHz

8GB RAM

 

I will update this as I try new things... Please ask me if you need any other details

Thank you all in advance for the help

Cheers!

Link to comment
Share on other sites

is this with all emulators or just a select few? because i had run into this only in the versions you mention as well, but only with Demul. also i hit this with retroarch, but a newer version of retroarch cleared that one. so basically i had found with Demul, i had to add a specific ahk script in the demul ahk tab with a specific way to close Demul. then my problems went away. but for many people, the usual ahk script worked for Demul. but i assume you already found that on the forum posts and tried it. i use the same buttons with controller automation as you. i use a xbox 360 as well as a xbox one controller. 

Link to comment
Share on other sites

I'm so glad that you asked this because I assumed it was happening with every emulator... but when I went back and tried to recreate the issue with each system, I realized that a few of them didn't have an issue! (although most did...)... 

I had NO issues when exiting the following:        

  1. N64 (Project64 2.3),
  2. Playstation (ePSXe 205),
  3. PS2 (PCSX2 1.4),
  4. Dreamcast (Demul 582),
  5. GameCube (Dolphin 5.0)

I constantly had the freezing issue when exiting the following:

  1. MAME (MAME139),
  2. Genesis/MasterSystem/CD/32x (Fusion 364-738), 
  3. SNES (snes9x 1.53),
  4. NES (Nestopia136)

I'm going to see if I can find a common link between these two groups

Any ideas?!

Thank you for the help/response

-mg

Link to comment
Share on other sites

I had this issue on exiting PPSSPP on version 7.10 i think? I found no reason or fix for it. Pressing Alt+Tab would unfreeze it. I just rolled back one version until 7.11 was released and that fixed the problem.

Anyway, cool story, not much help to you though sorry!

Link to comment
Share on other sites

I had a long running issue with this when exiting from MAME to Big Box, everything would freeze and the only way out of it was to open Task Manager and kill Big Box. I use controller automation in Big Box and had set Select + Start to exit emulators. I had also made this same command my UI Cancel in MAME itself. I thought this weekend that maybe this was causing a conflict and changed the key combo in MAME to Select + X and, lo and behold, I have had no issues exiting MAME since. @Jason Carr, I remember troubleshooting this issue with you on a live stream and you could not replicate it. Maybe this could have been it all along, anyway, I thought I would post here in case any other users are experiencing the same issue and it may work for them.

  • Like 1
Link to comment
Share on other sites

I'd love to get this fixed but as @Charco stated I've never been able to replicate it and it doesn't seem to be a common issue. I remember in the past, the closest we got to fixing it was discovering issues with Microsoft's 360/Xbox One controller drivers; they really screwed them up for a while. I'm not certain if this is it, but do try and see if you can update your 360/Xbox One controller drivers. :)

Link to comment
Share on other sites

  • 1 month later...

@Jason Carr - (You're The MAN, btw..).  I am able to reproduce this issue at will.. If it would be helpful at all, I can install LB on a machine (that I don't care about) and give you permanent remote access to it so you can look into it... think of it as a "sandbox"... wouldn't matter to me if you nuked the thing to pieces haha! Let me know if that is something that you would find useful (and/or have time to do) and I'll set it up etc.

Thank you for all of your hard work... I am "Team LaunchBox" through and through!!

Cheers

-Gunzaldinho

Edited by mgunther32
Link to comment
Share on other sites

  • 2 years later...

Dont know if this was ever resolved, but I just came across same issue, heres my scenario:

 

-When computer thats running BB is connected to (2) computer monitors, the freezing NEVER happens

- When computer thats running BB is connected to (1) computer monitor, the freezes HASNT HAPPENED YET.  (Im usually connected to 2, I just unplugged one to see if I could make it happen)

- When computer thats running BB is connected to a 65" TV, I've had it happen 3 times within 30 minutes.  Once when exiting MAME, twice when exiting NESTOPIA.

Link to comment
Share on other sites

On 2/1/2020 at 7:48 PM, nappyjim said:

Dont know if this was ever resolved, but I just came across same issue, heres my scenario:

 

-When computer thats running BB is connected to (2) computer monitors, the freezing NEVER happens

- When computer thats running BB is connected to (1) computer monitor, the freezes HASNT HAPPENED YET.  (Im usually connected to 2, I just unplugged one to see if I could make it happen)

- When computer thats running BB is connected to a 65" TV, I've had it happen 3 times within 30 minutes.  Once when exiting MAME, twice when exiting NESTOPIA.

Well that's certainly interesting. Unfortunately it sounds like a bad video driver, so the first step would be trying to update your video drivers. I would also make sure that you're all up to date on Windows updates.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...