Jump to content
LaunchBox Community Forums

Can't Install LaunchBox


greengeek
 Share

Recommended Posts

Can LaunchBox be installed without having all the latest Windows 10 feature upgrades?  I am running Windows 10 and it is fully up to date on security updates.  It does not have any of the feature updates though.  So none of the creators upgrades.  Without adding the feature upgrades to get an updated windows version number, I can only install up to .net 4.6.1.   When I try to install the latest version of launchbox, it tries to install .net 4.7.   Since that version is not compatible with my system, it fails and the only option it gives me is to cancel the installation of launchbox.  

Can LaunchBox run with .net 4.6.1 or can LaunchBox run using the Windows 10 2015 LTSB version of the OS?  Is there a way to by pass the of the 4.7 .net or to at least allow one to continue installation if it fails?   I really dont want to have to install this on a version of the OS that installs all the extra 3rd party apps from MS if I don't have to as this is a dedicated machine only for LaunchBox.

Thanks.

Edited by greengeek
Link to comment
Share on other sites

So you can't just install .NET Framework 4.7 by itself? You have to do feature updates to do that?

https://www.microsoft.com/en-us/download/details.aspx?id=55170

Newer LB/BB versions do use newer versions of .NET, so your options are going to be updating Windows sufficiently so that you can install .NET 4.7 or use an older version of LB/BB which use 4.6.1. I'm not sure what version that would be, specifically.

Link to comment
Share on other sites

Yep only way to upgrade a Windows 10 LTSB is to do a full Windows install from media, ie LTSB 2015 to LTSB 2016.  They dont allow for traditional upgrades.  I am curious though if LB itself has any hard coded requirements for the very latest version of .net, or if that is only hard coded into the installer.  Are there libraries it calls in 4.7 that are not in 4.6?  Is there a command line argument that lets me bypass the additional requirements check?  Would installing it on my main box, and then just copy over the installed folder to the arcade box work?

Link to comment
Share on other sites

This is all correct. The .NET 4.7 framework is required, or LaunchBox won't work at all. We upgraded primarily for performance reasons, as version 4.7 of the framework has some significant performance improvements. The latest Windows 10 feature updates are required in order to install the 4.7 framework if you're running Windows 10. Unfortunately that's just how Microsoft has done it.

  • Like 1
  • Thanks 1
Link to comment
Share on other sites

Dang, that means one cant use any current LTSB versions of Win10, or even Win 10 enterprise with differed upgrades turned on.  Which means increase performance of LB but unfortunately decreased performance of Windows with all the extra junk that gets installed with the feature upgrades. 

I guess on a related note,  how does LB/BB perform on Windows 7 or 8.1 compared to the latest version of 10?  Are there any downsides on using 7 or 8.1?  I am really wanting to give LB its own hardware and OS and try to minimize anything that is not related to it or entertainment in general. 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...