Jump to content
LaunchBox Community Forums
Aabra

Big Box isn't regaining Window Focus after game exit

Recommended Posts

I am trying to configure Minecraft to work with my Big Box setup.  This is the windows app version of it and so I am forced to link Launchbox to a shortcut I created for it since if there's an actual .exe file Windows hides it very well.  Doing this works without issue and when I select it - it launches straight in.  The only problem I am experiencing is after exiting out of Minecraft I can then see the Big Box screen but it doesn't have window focus.  I have to press a mouse button for the window to regain focus and be able to navigate again.  Any idea how I can resolve this issue? 

Share this post


Link to post
Share on other sites

There's another thread about focus, but taskbar related.  I don't know what to do about this, but I've had focus problems since day one.  Except mine is always the taskbar showing up and staying visible even when I do click back into big box. 

Share this post


Link to post
Share on other sites

I have experienced this problem on my HTPC but never my main PC. Somehow though the problem did fix itself and I really don't know what changed to fix it, one workaround I did use to deal with the issue was to set up an Alt + Tab function on the controller useing Xpadder (or AntiMicro) so that when the issue did arise I simply used that to get LB to regain focus.

Like I said though that is no longer an issue on my HTPC and I wish I knew what changed to fix it.

Share this post


Link to post
Share on other sites

That's a good workaround, but I feel like at this stage in the game, a front end as good as launchbox should just get its focus back without having to use a workaround.  I'm using RL as well so maybe they are having a hard time communicating to each other and that might need some more attention

Share this post


Link to post
Share on other sites
1 hour ago, damageinc86 said:

 a front end as good as launchbox should just get its focus back without having to use a workaround

I agree fully but like I said, it was an issue that happened for a short period and now it doesn't happen and I have no idea what made it not happen. So i don't know if it was just a bug in a previous build of LB or maybe something else changed outside of LB to make it stop behaving that way.

Share this post


Link to post
Share on other sites

To be clear I don't have this problem with pretty much everything else that I run through Big Box.  All other games and emulators work just fine without issue.  Perhaps it's because Minecraft is a Windows App that is causing the extra grief?  This is the Windows Store version of Minecraft which has full controller support... perfect for a Big Box setup.  Mapping alt-tab to the controller through xpadder would probably work I'm sure although I really would like to avoid xpadder if at all possible.  Nothing else needs it and it really shouldn't be necessary.

Share this post


Link to post
Share on other sites
1 hour ago, Aabra said:

To be clear I don't have this problem with pretty much everything else that I run through Big Box.  All other games and emulators work just fine without issue.  Perhaps it's because Minecraft is a Windows App that is causing the extra grief?

Ok well this helps narrow it down and since it only happens for you with one specific app then it is most likely that app is the cause of the issue.

 

Share this post


Link to post
Share on other sites

I am also seeing this issue when playing a windows store game (gears of war 4), after exiting the game, my screen displays bigbox but I have to alt + tab for it to respond to the keyboard etc.

Logged a bug here

Edited by satnav

Share this post


Link to post
Share on other sites

No updates because it was never something that could be narrowed down, if you are experiencing the issue and unable to fix and want a refund you send an email asking for one and you will in all likelihood get one.

Share this post


Link to post
Share on other sites

No way, No refund needed.... It's a small issue... a headache, but not a game breaker... Is there a way to run a .vbs script everytime I close an emulator? I can just do a clunky sendkeys command script.  

Share this post


Link to post
Share on other sites

Hi,

I've just started to play with windows games (Steam, GOG, windows store) and find that the regaining focus back to Big Box on exit of a given game is very hit and miss and in fact is inconsistent.

I find that some on exit return focus 100% of the time and some are quite random, and it's not based on the source - so I see erratic behavior from Celeste (Steam) and Cuphead (Windows Store) - but 100% reliable functioning from GRIP and Gris (Steam).

I have setup an xpadder ALT/TAB button to let me regain focus, but the inconsistency is a little annoying.

sTeVE

 

Share this post


Link to post
Share on other sites

I seem to be having this issue now. I’ve ne er had it before. I only noticed it since the update before last that introduced game loading splash screens. 

Im using controller automation to close the running window on my arcade cab. It closes the window and goes back to bigbox but it’s not in focus until I use a keyboard and alt tab. 

Ive noticed sometimes using controller automation to close the window just goes to a black screen too. 

It all used to work perfect so no idea what’s going on!

Share this post


Link to post
Share on other sites

Also experiencing the issue (black screen on exit) here quite frequently, but randomly. Seems to affect Dolphin more so than other emulators. I'm using controller automation to exit, but only Alt-Tab brings Big Box back.

Edited by dkr88

Share this post


Link to post
Share on other sites

Further playing around and I am finding that in my case I do not see a black screen at all, just loss of focus.

Whilst I have not used the windows game features much before I am now seeing games which in previous versions of BB were 100% reliable become flaky at returning control to BB.

But that is happening frequently and unlike previous versions - so I am experiencing issues I have not seen before.

sTeVE

Edited by jetbootjack

Share this post


Link to post
Share on other sites

I had focus issues with GOW. You can try this:

Focus.zip

Put the dll in plugins folder.

Put the ahk in Launchbox\AutoHotkey.

I couldn't get this to work properly with just c# so resorted to launching a script when a game exits. Seems to do the job for me but iv only tested a few games.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×