Jump to content
LaunchBox Community Forums

Choppy performance and stuttering issues in Retroarch and other emulators (SOLVED)


Recommended Posts

Just wanted to share a scenario I ran into and what fixed it, in case it helps anyone else. I bought a new Samsung TV over the weekend and hooked up my PC running Launchbox via HDMI, and everything was working fine. I launched into my Windows games folder and played some, everything was working great.

Then I launched a few games from other emulators that use Retroarch and everything was performing super slow and choppy, audio was stuttering at 1/2 speed. Since I had been playing other games without any issues, I initially thought there was something wrong with Retroarch so I installed a clean version, but this didn't fix anything. I then thought maybe I have some system issues and began uninstalling any recent software to check it again but no change. I also noticed this was happening with a few other emulators, but strangely not with Mame or Windows games and a few other emulators.

Anyways to make a long story short, I wasted a few hours pulling out my hair and going backwards in config on several portions of the system only to find that the refresh rate on my PC had changed when connecting to the new TV...... I'm on Windows 10, I just right clicked on the desktop and went to Display Settings > Display Adapter Properties > Monitor tab, and noticed the refresh rate was set to 29 Hertz (?). Setting this to 60 Hertz resolved the problem. It must have been that my previous TV had this refresh rate? I'm really not sure honestly.

Glad it's resolved, but feeling silly I didn't think of it *before* going down a rabbit hole that led me to screw up all my Retroarch settings. 

  • Thanks 2
Link to post
Share on other sites
  • 6 months later...

@zorkiii Thank you so much for sharing this! I had my entire gaming PC setup exactly how I wanted. I hooked it up to my Samsung TV, and experienced the same issue. After completely installing Windows, the issue still persists. I was about to lose it when I saw your post. 29hz. Same issue. Thank you for saving me from scrapping my system altogether!

Link to post
Share on other sites
  • 6 months later...
  • 5 months later...
  • 1 month later...

Thanks to this thread, I realized that my Lenovo m93p's integrated Intel 4600 can only output 30hz when running at 4K, which for me was causing the choppy audio as you mentioned above.

Switching the resolution down to 2K~ and a min of 60hz refresh rate solved the issue. Thank you!!

Link to post
Share on other sites
23 minutes ago, stevebor1 said:

Thanks to this thread, I realized that my Lenovo m93p's integrated Intel 4600 can only output 30hz when running at 4K, which for me was causing the choppy audio as you mentioned above.

Switching the resolution down to 2K~ and a min of 60hz refresh rate solved the issue. Thank you!!

Actually its possible its your motherboard or your connection/cable, that IGPU does do 4K60 but you need either a HDMI 2.0 port and cable, or display port. Standard HDMI ports and standard HDMI cables that are not 2.0 certified can often do 4K30, but they dont have the bandwidth for 4K60. If i was you i would look into it, it could be that your motherboard supports 4K60, but you simply have a non spec HDMI cable without the needed bandwidth to transmit 4K60.

https://ark.intel.com/content/www/us/en/ark/products/80806/intel-core-i7-4790-processor-8m-cache-up-to-4-00-ghz.html

image.thumb.png.e523eddf576cebbdaefc4ce6f3a47e8e.png

Link to post
Share on other sites
30 minutes ago, neil9000 said:

Actually its possible its your motherboard or your connection/cable, that IGPU does do 4K60 but you need either a HDMI 2.0 port and cable, or display port. Standard HDMI ports and standard HDMI cables that are not 2.0 certified can often do 4K30, but they dont have the bandwidth for 4K60. If i was you i would look into it, it could be that your motherboard supports 4K60, but you simply have a non spec HDMI cable without the needed bandwidth to transmit 4K60.

https://ark.intel.com/content/www/us/en/ark/products/80806/intel-core-i7-4790-processor-8m-cache-up-to-4-00-ghz.html

image.thumb.png.e523eddf576cebbdaefc4ce6f3a47e8e.png

You are right, I am doing 4K (3840 x 2160) at 60Hz!, before I had my resolution set  to the highest (4096x2304), which was causing the stuttering. I forget that 3840 x 2160 is actually 4K :)
btw, I have a Intel i5, 4570T with DisplayPort 1.2 to HDMI which can push the 3840 x 2160 @ 60hz to the TV just fine.
 

  • Like 1
Link to post
Share on other sites
  • 5 months later...
On 9/19/2019 at 11:18 AM, neil9000 said:

Actually its possible its your motherboard or your connection/cable, that IGPU does do 4K60 but you need either a HDMI 2.0 port and cable, or display port. Standard HDMI ports and standard HDMI cables that are not 2.0 certified can often do 4K30, but they dont have the bandwidth for 4K60. If i was you i would look into it, it could be that your motherboard supports 4K60, but you simply have a non spec HDMI cable without the needed bandwidth to transmit 4K60.

https://ark.intel.com/content/www/us/en/ark/products/80806/intel-core-i7-4790-processor-8m-cache-up-to-4-00-ghz.html

image.thumb.png.e523eddf576cebbdaefc4ce6f3a47e8e.png

OK

Dumb question.  How do I know if the HDMI cable can handle it?   know the GPU and MB can

 

Link to post
Share on other sites
  • 2 months later...

Greetings from the dystopian future year of 2020. I've been troubleshooting this problem for hours, and I can't believe the answer was this simple. Thank you. Now that this is solved, I'm going to go weld a cowcatcher to the front of my Honda so I can battle others for a roll of Charmin.

  • Haha 1
Link to post
Share on other sites
  • 5 months later...
  • 6 months later...
On 2/7/2018 at 8:44 AM, zorkiii said:

Just wanted to share a scenario I ran into and what fixed it, in case it helps anyone else. I bought a new Samsung TV over the weekend and hooked up my PC running Launchbox via HDMI, and everything was working fine. I launched into my Windows games folder and played some, everything was working great.

Then I launched a few games from other emulators that use Retroarch and everything was performing super slow and choppy, audio was stuttering at 1/2 speed. Since I had been playing other games without any issues, I initially thought there was something wrong with Retroarch so I installed a clean version, but this didn't fix anything. I then thought maybe I have some system issues and began uninstalling any recent software to check it again but no change. I also noticed this was happening with a few other emulators, but strangely not with Mame or Windows games and a few other emulators.

Anyways to make a long story short, I wasted a few hours pulling out my hair and going backwards in config on several portions of the system only to find that the refresh rate on my PC had changed when connecting to the new TV...... I'm on Windows 10, I just right clicked on the desktop and went to Display Settings > Display Adapter Properties > Monitor tab, and noticed the refresh rate was set to 29 Hertz (?). Setting this to 60 Hertz resolved the problem. It must have been that my previous TV had this refresh rate? I'm really not sure honestly.

Glad it's resolved, but feeling silly I didn't think of it *before* going down a rabbit hole that led me to screw up all my Retroarch settings. 

i was so happy until i discovered im already at 60hz I am very sad i spent so long setting retroarch up so depressed.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...