Jump to content
LaunchBox Community Forums

Recommended Posts

3 hours ago, C-Beats said:

This was done intentionally to allow the numeric sorting to work. We take the SortTitle that game has been given via the user and then format it to make the sort appear correctly.

I knew there had to be a good reason for doing so :) I assume this is to prevent situations such as in Windows File Explorer where a file such as "pic11.jpg" will sorted/shown prior to "pic2.jpg"? Regardless, thanks for the input!

Link to comment
Share on other sites

2 hours ago, Lahma said:

I knew there had to be a good reason for doing so :) I assume this is to prevent situations such as in Windows File Explorer where a file such as "pic11.jpg" will sorted/shown prior to "pic2.jpg"? Regardless, thanks for the input!

Correct.

Link to comment
Share on other sites

  • 3 weeks later...

Just an FYI, if anyone wants a debug build of the plugin (title problem fixed among other things) prior to the public release, hit me up on Steam, and I would be happy to send it to you. I'm getting close to finishing up with the changes I want to complete before pushing out a public build though, so it shouldn't be much longer.

  • Like 1
Link to comment
Share on other sites

16 hours ago, Lahma said:

Just an FYI, if anyone wants a debug build of the plugin (title problem fixed among other things) prior to the public release, hit me up on Steam, and I would be happy to send it to you. I'm getting close to finishing up with the changes I want to complete before pushing out a public build though, so it shouldn't be much longer.

Thanks for your continued work on this man! I'd be happy to do any testing if needed. I'm always around.

  • Like 1
Link to comment
Share on other sites

  • 5 weeks later...

Is anyone here good at graphics/art design or know anyone who is who might want to help contribute to the plugin? I think I've decided that I'm going to go ahead and release the 1.0 version of the plugin, as I've put a whole lot of work into cleaning things up, optimizing code, fixing bugs, adding new features, etc, so I think the plugin is finally in a state worthy of calling it a non-beta release. Thing is, I'd really like to create a set of logo/icons for the plugin that give it that last bit of polish/shine, but unfortunately, I am miserably bad at art/creative-design. While I know my way around Photoshop to a fair degree, I just don't think I have the creativity needed to accomplish what I'm trying to do. What I've been trying so far is to create an amalgamation of both the Steam logo and the LaunchBox logo, but its not going so well... Thought it was at least worth asking around if someone in the community might be willing to contribute some of their talent to the project. Thanks!

  • Like 1
Link to comment
Share on other sites

34 minutes ago, Lahma said:

Is anyone here good at graphics/art design or know anyone who is who might want to help contribute to the plugin? I think I've decided that I'm going to go ahead and release the 1.0 version of the plugin, as I've put a whole lot of work into cleaning things up, optimizing code, fixing bugs, adding new features, etc, so I think the plugin is finally in a state worthy of calling it a non-beta release. Thing is, I'd really like to create a set of logo/icons for the plugin that give it that last bit of polish/shine, but unfortunately, I am miserably bad at art/creative-design. While I know my way around Photoshop to a fair degree, I just don't think I have the creativity needed to accomplish what I'm trying to do. What I've been trying so far is to create an amalgamation of both the Steam logo and the LaunchBox logo, but its not going so well... Thought it was at least worth asking around if someone in the community might be willing to contribute some of their talent to the project. Thanks!

My humble suggestion: just release it as it is. I don't think many people would care that much about a logo. But it's not hard to find someone that could do the art for you though. Thanks anyway for the hard work.

Link to comment
Share on other sites

1 minute ago, coleroddy said:

My humble suggestion: just release it as it is. I don't think many people would care that much about a logo. But it's not hard to find someone that could do the art for you though. Thanks anyway for the hard work.

I can send you a current debug build if you'd like. Just shoot me a PM and I'll send you a link.

Link to comment
Share on other sites

  • 4 weeks later...

Description says "Use per-rom or per-emulator controller configurations that are automatically remembered between gaming sessions (without having to create convoluted Steam shortcuts for every rom)"

How can I change a controller configuration per-emulator? It always seems to default to "Gamepad" the first time I launch a specific game. Trying to have a separate PCSX2 config auto-loading for its weird hotkeys.

 

 

Edited by andreycout
Link to comment
Share on other sites

I should probably revise that line in the documentation as there really isn't a way to set a specific controller profile to automatically load when a given emulator is used. Any time you change any controller configuration settings in Steam, it saves those settings by associating them with the name of the currently running game. An example of a game name when launched using the plugin might be: Super Mario World (SNES). (Note: You can see the name of the currently running game in Steam by looking at your own name in your friends list.) If you've never played a particular game before using the plugin/Steam, it is not going to have any controller configuration tied to that game name, so it is simply going to pick the default "Gamepad" controller configuration.

If you want to use the same controller configuration for all games running under PCSX2 (or at least want to use a particular controller configuration as a "starting point" for all games running under PCSX2), the simplest way to accomplish this is as follows:

  • Run any game under PCSX2 using the plugin
  • Setup your controller configuration as you like
  • While inside of the controller configuration overlay screen, hit the 'Export' button (or press the 'Y' button if using an Xbox or Xbox-style controller)
  • Scroll down to 'Templates'
  • Select the 'Save new template binding' option

image.thumb.png.4bbd0272360fc2805431cfc0423f532c.png

  • Enter an appropriate name (i.e. PCSX2 Template) and description
  • Click 'Save'

Now, any time you load up a new game under PCSX2, just pull up the overlay, select 'Controller Configuration', hit the 'Browse Configs' button (or press the 'X' button if using an Xbox or Xbox-style controller), and select your newly saved PCSX2 Template config. Takes all of about 3 seconds and you'll only have to do it one time whenever playing a new game. The nice thing is that you can now change any controller bindings (on top of your PCSX2 Template config) and they will automatically be reloaded the next time you run the game (and these changes won't affect/modify your PCSX2 Template config).

Hopefully this was helpful but if you have any additional questions or need any additional help, I'd be happy to assist in whatever way I can. If you need a quicker response, you're always welcome to hit me up on Steam as well.

  • Thanks 1
Link to comment
Share on other sites

  • 3 weeks later...
  • 2 weeks later...
On 8/1/2020 at 2:22 AM, Shermer321 said:

I can't get the alpha to work. Crashes launchbox on startup.

Did you have the previous version already installed? or just trying it out for the first time?.. The link above is for the Alpha .DLL file only; you still need the other 5 files that come with the plugin when downloaded from the forums, and they all need to be in the folder: Launchbox/Plugins/SteamLauncher/

Link to comment
Share on other sites

On 8/11/2020 at 9:32 AM, Shermer321 said:

Yeah that's what I used. Either way it was easier to use an ahk script to look for the window. Thanks though.

Hey @Shermer321, sorry I didn't respond immediately. I've been out of town for a funeral. I'd be happy to help you get the plugin working. The 1.0 final build is just about done, but I can send you the latest debug build I have and we can walk through whatever issue you're having. It would be much easier to do via Steam messaging, so if you could hit me up on there that would be great. My Steam contact info is on the plugin download page. I suspect whatever problem you're having can be resolved very quickly and easily as I'm very confident that the latest alpha I linked to in this thread is working just fine. Anyways, shoot me a msg and we'll get it figured out.

  • Game On 1
Link to comment
Share on other sites

  • 2 weeks later...

Not sure if the LaunchBox 11.3 update broke something or if I'm just unlucky but decided to try this plugin today for the first time but with it active keep getting the error " The file you've specified for the emulator application path was not found". When i turn SteamLoader to off in the menu all my games launch just fine. Would be awesome if I could get this working it would streamline my control configuration between the emulators and the PC games in my collection. I've tried everything i can think of made sure to install correctly, turned of anti-virus, tried with a new install of LB.

Edited by hadrex83
Link to comment
Share on other sites

6 minutes ago, hadrex83 said:

Not sure if the LaunchBox 11.3 update broke something or if I'm just unlucky but decided to try this plugin today for the first time but with it active keep getting the error " The file you've specified for the emulator application path was not found". When i turn SteamLoader to off in the menu all my games launch just fine. Would be awesome if I could get this working it would streamline my control configuration between the emulators and the PC games in my collection. I've tried everything i can think of made sure to install correctly, turned of anti-virus, tried with a new install of LB.

You need to use this new alpha build that isn't publicly posted yet:
https://drive.google.com/file/d/1nsUnrk67ChsnvXxfoOUr-sM6GR12WgSm/view?usp=sharing

Let me know if you have any problems.

Link to comment
Share on other sites

Fresh install of LB 11.3 crashes at launch with that version of the dll  just generates a blank debug log in the SteamLauncher folder. LaunchBox only launches if there is a config xml in the SteamLauncher folder already without one it pops an error and falls flat on its face with the new alpha build. But with a config xml generated from the beta that is posted for download here version you get the "The file you've specified for the emulator application path was not found" error. If you would like i can post the LaunchBox error that pops up somewhere but it won't be till tomorrow i need to wake up early.

Edited by hadrex83
  • Like 1
  • Thanks 1
Link to comment
Share on other sites

After further testing it seems to be only LB 11.3 rolled back to 11.2 and SteamLauncher works. In LB version 11.3 the emulator application path is changed to "..\Plugins\SteamLauncher\SteamLauncherProxy.exe" sadly something with the update broke the functionality of the plugin.

  • Thanks 1
Link to comment
Share on other sites

19 minutes ago, hadrex83 said:

After further testing it seems to be only LB 11.3 rolled back to 11.2 and SteamLauncher works. In LB version 11.3 the emulator application path is changed to "..\Plugins\SteamLauncher\SteamLauncherProxy.exe" sadly something with the update broke the functionality of the plugin.

I wasn't aware that a new LB update was out but even so, there should be little chance that a LB update would break the plugin. From what you've said though, it sounds like that may be the case. I will look into the problem right now, and I will try to post a new beta build of the plugin in this thread shortly. Also, thank you @hadrex83 for the report about the crash occurring when there is no 'config.xml' file in the SteamLauncher directory. Normally this wouldn't be a problem as the plugin would just generate a new default 'config.xml' file but there was a small bug that was causing the debug logging to try to access a config value before the new default config had been generated. I got that bug fixed already and I'm looking into the new LB update right now.

Edited by Lahma
  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...