Jump to content
LaunchBox Community Forums

Recommended Posts

47 minutes ago, mp3deej said:

I checked and that's not it,  it is starting in Big Box and Launch Box.  I mean all of my games on all emulators.   

What is going on?   Can this be fixed without  having to reset everything? 

Not sure if your emulator paths are correct and pointing to the right programs. Do you have another copy of Steam Launcher ANYWHERE in the Launchbox directory? Lahma strongly advises against this. I believe he described the effect of having two of them as "mayhem" 

 

Whatever it is its a simple fix I'm sure. 

Share this post


Link to post
Share on other sites
1 hour ago, mp3deej said:

I checked and that's not it,  it is starting in Big Box and Launch Box.  I mean all of my games on all emulators.   

What is going on?   Can this be fixed without  having to reset everything? 

 

Hey @mp3deej, you have to disable SteamLauncher for it to not intercept game launches. In BigBox, you can do this by clicking this menu item (when it is turned off, the menu item will read 'Use SteamLauncher (OFF)'):

image.thumb.png.7148980a1957741228d8eb18ab5f9cf8.pngDo note that this is a global switch which will enable/disable SteamLauncher for both LaunchBox and BigBox, so if you disable it in BigBox, it will still be disabled the next time you open LaunchBox (can be easily reenabled in LB by clicking the 'Tools' menu item and looking for the same 'Use SteamLauncher' menu item). With that being said, I am working on the BigBox fix as I type this.

Edited by Lahma
  • Thanks 1

Share this post


Link to post
Share on other sites

@The_Keeper86, @Corgana, @mp3deej
Just wanted to let y'all know I finally figured out the problem with BigBox. The issue was of course related to LB/BB moving over to .NET Core. More specifically, it was related to a dependency that my plugin relies on not being able to be loaded correctly. The reason it works fine in LB is because LB also relies on that same dependency. BigBox however does not list that dependency in its 'BigBox.deps.json' file, so whenever my plugin is loaded under BigBox, even though I have that dependency listed in my 'SteamLauncher.deps.json' file, it will throw an exception whenever it tries to load it. While I'm sure there is some way I could use the copy of the dependency that is packaged with LaunchBox, I'm concerned that it would just be moved to a different location or something in a subsequent LB update, so I will probably just include the dependency with the plugin going forward. Give me a little time to do a little more digging on the problem to see if I can't find a more elegant solution (I really hate including external dependencies with the plugin, if I don't have to, as I've worked very hard thus far to not do so). Either way, I will post an update here sometime tomorrow as it is already midnight.

  • Thanks 1

Share this post


Link to post
Share on other sites
4 hours ago, Lahma said:

@mp3deej Please let me know if the info I posted previously helped you get your problem resolved.

I finally figured it out, I checked the emulator paths for the games that it was happening to, but not all of the paths in Launchbox.  I found a couple of emulator paths pointing to Steam and corrected them.  I'm not sure why it was launching those games, but the issues is resolved.

Thank you for all your assistance in this matter. 

Great community of users. 

Share this post


Link to post
Share on other sites
Just now, mp3deej said:

I finally figured it out, I checked the emulator paths for the games that it was happening to, but not all of the paths in Launchbox.  I found a couple of emulator paths pointing to Steam and corrected them.  I'm not sure why it was launching those games, but the issues is resolved.

Thank you for all your assistance in this matter. 

Great community of users. 

Glad you got it resolved man! I gotta agree.. while the plugin might not have an enormous user base, I think the ones we do have (especially those in this thread who go out of their way to help others when I can't answer immediately) are pretty awesome 🏆 And if you were referring to the LaunchBox community in general, ya.. they're pretty alright too ;)

Oh, and just an FYI to everyone waiting for the BigBox fix, I should have it posted shortly. I think I figured out how to resolve the problem without including an external dependency with the plugin.

  • Game On 1

Share this post


Link to post
Share on other sites
3 hours ago, Lahma said:

Glad you got it resolved man! I gotta agree.. while the plugin might not have an enormous user base, I think the ones we do have (especially those in this thread who go out of their way to help others when I can't answer immediately) are pretty awesome 🏆 And if you were referring to the LaunchBox community in general, ya.. they're pretty alright too ;)

Oh, and just an FYI to everyone waiting for the BigBox fix, I should have it posted shortly. I think I figured out how to resolve the problem without including an external dependency with the plugin.

Amazing, cheers dude! 🤘

Share this post


Link to post
Share on other sites

Sorry guys, I had an extremely busy day today but I promise I will have the new build posted asap.

  • Like 2

Share this post


Link to post
Share on other sites
On 9/21/2020 at 12:28 AM, Lahma said:

You definitely cannot run BigBox through Steam and then run a game in BigBox using SteamLauncher. Besides the fact that that would mean Steam is trying to run multiple games simultaneously (bc Steam will consider BigBox a "game" just like any other non-Steam shortcut run via Steam), Steam would be trying to inject the overlay into a process multiple times (I'll spare you the technical jargon). Essentially you're creating a circular dependency and if you're not careful you might just cause your PC to implode into a black hole while trying this ;)

Kind of what I was expecting. I made a hadron collider out of some PVC pipe I found behind a dumpster to test this theory, but I guess I won't need it now 😭

 

So I have a new problem. I'm trying to launch some free indie roguelike, but Steam sees the game as a launcher window and not the actual application. As far as I can tell, there's an option to fix this, but it's only accessible in big picture mode for some inexplicable reason. (Big Picture>[App]>Manage Shortcut>Controller Options>UNCHECK Allow Desktop Configuration in Launcher).

The problem is, there's no way to get to that option with a shortcut created by this plugin for some reason. I also tried making a shortcut through Steam manually, setting the option, then changing the name of the shortcut to what the plugin calls the program, but once I launched the program through LaunchBox the settings would revert and the option would disappear again.

So... does anyone know a work around for this one? Just found out about application command line parameters (like adding -launch to the end of Diablo 3's path location to prevent the Blizzard launcher from popping up) and was thinking there'd be an answer with that, but haven't found a command that helps for this situation.

Share this post


Link to post
Share on other sites
6 hours ago, alienhuntinyeti said:

Kind of what I was expecting. I made a hadron collider out of some PVC pipe I found behind a dumpster to test this theory, but I guess I won't need it now 😭

 

So I have a new problem. I'm trying to launch some free indie roguelike, but Steam sees the game as a launcher window and not the actual application. As far as I can tell, there's an option to fix this, but it's only accessible in big picture mode for some inexplicable reason. (Big Picture>[App]>Manage Shortcut>Controller Options>UNCHECK Allow Desktop Configuration in Launcher).

The problem is, there's no way to get to that option with a shortcut created by this plugin for some reason. I also tried making a shortcut through Steam manually, setting the option, then changing the name of the shortcut to what the plugin calls the program, but once I launched the program through LaunchBox the settings would revert and the option would disappear again.

So... does anyone know a work around for this one? Just found out about application command line parameters (like adding -launch to the end of Diablo 3's path location to prevent the Blizzard launcher from popping up) and was thinking there'd be an answer with that, but haven't found a command that helps for this situation.

What game is that? Just in case I have it in my library.

Share this post


Link to post
Share on other sites
10 hours ago, Metrasher said:

What game is that? Just in case I have it in my library.

I think it was called Elona, some freeware game I haven't actually played yet. Doesn't really matter the program though, this problem can be recreated with ANY program Steam recognizes as a launcher when you don't want it to.

 

As an aside, is there any way to have a steam overlay for a launcher window without using GloSC? I'm guessing no, but tossing this safely ignorable question out there in case some passer-by knows a way.

Share this post


Link to post
Share on other sites
On 10/4/2020 at 6:25 PM, alienhuntinyeti said:

Kind of what I was expecting. I made a hadron collider out of some PVC pipe I found behind a dumpster to test this theory, but I guess I won't need it now 😭

 

So I have a new problem. I'm trying to launch some free indie roguelike, but Steam sees the game as a launcher window and not the actual application. As far as I can tell, there's an option to fix this, but it's only accessible in big picture mode for some inexplicable reason. (Big Picture>[App]>Manage Shortcut>Controller Options>UNCHECK Allow Desktop Configuration in Launcher).

The problem is, there's no way to get to that option with a shortcut created by this plugin for some reason. I also tried making a shortcut through Steam manually, setting the option, then changing the name of the shortcut to what the plugin calls the program, but once I launched the program through LaunchBox the settings would revert and the option would disappear again.

So... does anyone know a work around for this one? Just found out about application command line parameters (like adding -launch to the end of Diablo 3's path location to prevent the Blizzard launcher from popping up) and was thinking there'd be an answer with that, but haven't found a command that helps for this situation.

First, just wanted to say sorry for not having pushed out the BigBox fix yet. I'm trying to cleanup and consolidate a lot of code that needs to be finished in preparation for the 1.0 release. I've put about 40 hours of work into the plugin over this last weekend and the first part of this week already. To answer your question, the plugin has a custom feature implemented for this exact purpose. If you open the plugin's settings window and go to the 'Game Launchers' tab, you will see a data grid that you can add entries to. Let me explain the purpose of this and how it works:

For the plugin to work correctly, it has to be able to monitor when a game/emulator's EXE starts and exits. For most games, this isn't a problem, because the plugin just waits for the game's EXE to start and then whenever the game's EXE closes, SteamLauncher knows the game has exited. Some games however use a launcher EXE which launch the actual game exe, after which, the launcher EXE exits immediately, not waiting for the game EXE to exit. When this happens, SteamLauncher thinks the game has exited after the launcher EXE closes because that is the only EXE it is aware of. To fix this problem, there are a couple of potential solutions, but the first and easiest is using the feature implemented in the plugin for this specific purpose.

Once you're on the 'Game Launchers' tab in the settings window, we're going to create a new entry. Under 'Launcher Executable', you are going to place either the name of your game's launcher EXE (ex: 'GTAVLauncher.exe') or the full path to your game's launcher EXE (ex: 'C:\PC_Games\GTAV\GTAVLauncher.exe'). It is up to you whether to put the exe name or the full path, but as long as you don't use that same launcher exe for multiple games at multiple different paths, the exe name alone should be fine. Next, under 'Started by Launcher', you need to put either the name of the EXE that is started by the launcher (the actual game EXE that stays running the entire time you're playing the game) (ex: 'GTA5.exe') or the full path to that exe (ex: 'C:\PC_Games\GTAV\GTA5.exe'). Again, it is up to you on whether to put the exe name or the full path but as long as you are not launching that same game EXE name with multiple different launcher EXEs, the name of the exe alone should be fine. Finally, ensure that the 'Enable' checkbox is checked and hit the 'Save' button.

image.thumb.png.0e7b240ffdfb4de591d0015923f0c0f5.pngNow, the next time you launch that game launcher EXE from LaunchBox, the plugin won't think the game has exited as soon as the launcher EXE closes... Instead, it will wait for the game EXE to close. With that being said, there are still some instances in which Steam still won't be able to inject its overlay into the game and the plugin can't do anything to fix that. Essentially, if you add the game's launcher EXE to Steam as a non-Steam shortcut and it does not work when running that non-Steam shortcut directly from Steam, the plugin isn't going to be able to do anything to mitigate that problem. There are very few instances in which this is going to happen, but they do exist. The only "universal" workaround I'm aware of in these rare instances it to use something like GlosC or Non-Steam-Overlay-Manager (and you would need to setup the GlosC/NSO-Manager exe as the launcher EXE and the game's real EXE as the game EXE, as described above). If you have multiple games which use GlosC/NSO-Manger, you can create multiple copies of the GlosC/NSO-Manager launcher exe and use each renamed EXE to only launch a specific game (that way, when you setup the launcher-to-exe relationship in the plugin's settings, it will be able to differentiate each launcher exe and associate it with a specific game).

The only other suggestion I can offer in regards to this topic, and it is one I use VERY often, is the creation of a custom launcher exe using 'BAT to EXE Converter'. You can write a custom batch script (.bat file) to setup and launch a game and/or game launcher and make it so that the batch file does not exit until the actual game EXE closes. You then use 'Bat to Exe Converter' to convert this .bat file into a EXE, and you then use this exe as your game's EXE in LaunchBox. Using this method, you don't need to setup a Launcher-to-EXE relationship in SteamLauncher's settings because the custom launcher EXE will stay running the entire time the game is running (so the plugin will not get confused). I will include a simple example .bat file below that I use for one of my games.

This is a very simple batch file that I use to prevent games that 'require' admin privileges from running as admin ('Into the Breach' is the game in this example). It is a very simple example and would obviously need to be customized for your situation, but here it is:

@echo off

cmd /min /C "set __COMPAT_LAYER=RUNASINVOKER && cd "%~dp1" && "Breach.exe""

You would then save this .bat file next to your game EXE (ex: 'Breach-NonAdmin.bat'). You would then open 'Bat to Exe Converter', select the .bat file, set it to 'Invisible Application' under the 'Visibility' header, and click 'Compile'. Now you will have 'Breach-NonAdmin.exe' in your game's directory, and you would use this exe as your game's launcher exe.

image.thumb.png.56e71328c4200be7d173b84b56928341.pngHopefully you can find something that will work for you.

  • Thanks 2

Share this post


Link to post
Share on other sites

I don't think it's loading a launcher window, I think Steam just thinks the game application is a launcher window itself for whatever reason. If it was what you said, it wouldn't work when I deselect "Allow Desktop Configuration in Launcher" in my manual shortcut since Steam would see the program "close" immediately upon launching (if I'm understanding correctly), but that option works perfectly fine through Steam. If I use that option, it uses the controller config I set up until I close the window, returning to the desktop config, like any other application would. 

The problem is, for whatever reason, when I try to get LaunchBox w/ the SteamLauncher plugin to launch the shortcut I made through Steam, my "Allow Desktop Configuration in Launcher" setting gets overwritten and the "Manage Shortcut" option disappears entirely from that Steam shortcut.

I tried your suggestions just to make sure, but they didn't work. With the SteamLauncher settings, I tried setting BOTH options to the .exe since I don't have a launcher .exe for the program and nada. I imagine the .bat suggestion would probably work if I set the converted .bat to the launcher directory in the SteamLauncher settings, but I'm not used to messing around with .bat files or the converter program. I think I downloaded a newer version of the converter program you have, couldn't find the settings you pointed out, ended up breaking my .exe (found another copy thankfully). Guess I'll try messing with it some other time, too late tonight

Share this post


Link to post
Share on other sites

Figured it out! So I fianlly got around to trying it again, and I THINK I figured out the Bat-to-Exe method you mentioned for v3.2. "Visibility" was replaced with a drop down menu called "Exe-Format", and "Compile" is now "Convert". But... it didn't work for me. The .exe it created worked fine, but just launched the game like the normal .exe, and no matter which app I used to launch with, and no matter how I set it up in the SteamLauncher settings (including NOT using the settings and just launching from the created .exe), it wouldn't work for me.

BUT... I tried launching the game with the .bat file, didn't mess around with SteamLauncher settings, and it worked. So.... if anyone else has this (most likely pretty rare) problem where Steam recognizes the game window as a launcher window, just make that .bat, change "Breach.exe" to whatever .exe you're launching and set the .bat as the application path in LaunchBox. Thought it worked (mouse stopped responding so I assumed it defaulted to a controller configuration), but when I configured the controller in Steam and actually tried using it, I realized the controller just stopped responding while the window was the active window for some reason. I guess I'm going to give up for now and just launch that program specifically through Steam. 😢

Here's a link to the program (and particular version I'm using) in case I'm just being dumb and someone else wants to take a crack at it:

https://elona.en.uptodown.com/windows

Edited by alienhuntinyeti

Share this post


Link to post
Share on other sites
10 hours ago, alienhuntinyeti said:

Figured it out! So I fianlly got around to trying it again, and I THINK I figured out the Bat-to-Exe method you mentioned for v3.2. "Visibility" was replaced with a drop down menu called "Exe-Format", and "Compile" is now "Convert". But... it didn't work for me. The .exe it created worked fine, but just launched the game like the normal .exe, and no matter which app I used to launch with, and no matter how I set it up in the SteamLauncher settings (including NOT using the settings and just launching from the created .exe), it wouldn't work for me.

BUT... I tried launching the game with the .bat file, didn't mess around with SteamLauncher settings, and it worked. So.... if anyone else has this (most likely pretty rare) problem where Steam recognizes the game window as a launcher window, just make that .bat, change "Breach.exe" to whatever .exe you're launching and set the .bat as the application path in LaunchBox. Thought it worked (mouse stopped responding so I assumed it defaulted to a controller configuration), but when I configured the controller in Steam and actually tried using it, I realized the controller just stopped responding while the window was the active window for some reason. I guess I'm going to give up for now and just launch that program specifically through Steam. 😢

Here's a link to the program (and particular version I'm using) in case I'm just being dumb and someone else wants to take a crack at it:

https://elona.en.uptodown.com/windows

I'm still not entirely sure I understand your problem. There is only 1 "type" of non-Steam shortcut (in Steam) and there is no option in the non-Steam shortcut's properties to enable "Allow Desktop Configuration in Launcher". The non-Steam shortcuts that the plugin creates are the same as if you manually created a non-Steam shortcut in Steam by clicking the top menu item in this menu:

image.png.4dc8e224ebeff20ebf73c6565066c729.pngFurthermore, I am not aware of any mechanism within Steam that detects an exe as being a "launcher" or "not a launcher". Steam injects its overlay into the exe it launches (if it is not prevented from doing so) and sometimes it will inject its overlay into the child processes of that exe if the circumstances are correct.

When I have some time, I'll try to download the title and take a look at it, but I got to get the new SteamLauncher update out to y'all first. Essentially though, if you manually add the game's exe to Steam as a normal non-Steam shortcut (see image above) and the Steam overlay isn't present when you launch that non-Steam shortcut, there is nothing the plugin is going to be able to do to mitigate this (outside of things I mentioned in my original post for games that use a launcher exe: defining a "Launcher-to-EXE relationship" in the plugin settings, using Bat-to-Exe Converter, or using a solution such as GloSC/NSO-Manager/etc).

  • Like 2

Share this post


Link to post
Share on other sites

Like I said, for some absolutely stupid reason the option to toggle "Allow Desktop Configuration in Launcher" is ONLY in Steam's Big Picture Mode. I have no idea why. It's probably never been mentioned here before because honestly the options in the menu aren't all that useful for most applications.
2008347020_Screenshot(3).thumb.png.6f2ad30165e8bc232060cc1e2101bd24.pngThis is what led me to believe Steam was registering the .exe as a launcher, because when I DE-Select that option (on by default), my controller configuration works perfectly fine (but yeah, no overlay in the window). Also, I don't see any other windows open alongside the game, either before, during or after. (EDIT: just realized what I mean by "registering as a launcher" and what you mean by Steam injecting it's overlay is probably the same thing. If it can't inject it's overlay, it's a "launcher" as far as this option is concerned)

This is what the options look like with a SteamLauncher shortcut (had a HELL of a time getting the shortcut to even show in Big Picture Mode this time around for some reason, didn't have that problem before🤷‍♂️)1004394091_Screenshot(5).thumb.png.78d4ccf7b6d78859df7d7f09ce0aff9f.pngThe "Manage Shortcut" option disappears entirely for some reason.🤷‍♂️ 

With all that said, yeah, BigBox update's WAY more important than this, so don't let me distract you! Thanks for all the work, take your time and all that jazz.:D

(EDIT 2: just wanted to clarify, not expecting a "fix" or response to the issue again, just realized it was a communication breakdown [especially after the realization in the first edit] and wanted to explain the situation in case someone else asks about this in the same way as me. This post is more of a "Hey, look at this weird option" than anything anymore I guess)

Edited by alienhuntinyeti

Share this post


Link to post
Share on other sites

Just thought I'd mention an issue I encountered and the fix. 

 

When playing Witcher 3 GOG version with SteamLauncher it stopped working after a while. This was because it was launching from a shortcut that pointed to an exe in a subfolder. 

Going in to edit game and choosing the exe direct to launch from and then changing the root folder to to the exe folder fixed this for me. 

 

Just thought would throw it out there in case someone runs in to the same issue. 

 

Ps lahma you rock 

Share this post


Link to post
Share on other sites
On 10/20/2020 at 4:13 PM, JedExodus said:

Just thought I'd mention an issue I encountered and the fix. 

 

When playing Witcher 3 GOG version with SteamLauncher it stopped working after a while. This was because it was launching from a shortcut that pointed to an exe in a subfolder. 

Going in to edit game and choosing the exe direct to launch from and then changing the root folder to to the exe folder fixed this for me. 

 

Just thought would throw it out there in case someone runs in to the same issue. 

 

Ps lahma you rock 

Thanks for the feedback @JedExodus. Could you give me a little more info on what you mean by "stopped working after a while"? I've implemented specific support in the plugin for shortcut files (.lnk) so if there is some type of bug that is causing them not to work, I'd like to fix it asap. The LB "Import Windows Games" utility adds games to your LB library using shortcut files so I suspect a lot of people have games in their library that point to .lnk (shortcut) files. I will do some quick testing and see if I can't figure out what the issue is myself. Again, thanks for the report.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...