Jump to content
LaunchBox Community Forums

Recommended Posts

49 minutes ago, The_Keeper86 said:

For some reason the plugin will sometimes remove the emulator and instead add in its place "SteamLauncherProxy.exe" as the emulator. I had this problem in the past with PCSX2. Most likely the same issue here.

I tried changing the Emulator App Path but it keeps resetting back to "..\Plugins\SteamLauncher\SteamLauncherProxy.exe" when the SteamLauncher setting is turned on.

I'm guessing that this SteamLauncherProxy.exe is supposed to be used in some way but I have no idea how to indicate that rpcs3 is to be used as well. 

Similarly, I tried this on PS1 and PS2 games as well with the same result. I feel like I'm missing an obvious step here.

Edited by Aetavicus
Link to comment
Share on other sites

2 hours ago, Aetavicus said:

I tried changing the Emulator App Path but it keeps resetting back to "..\Plugins\SteamLauncher\SteamLauncherProxy.exe" when the SteamLauncher setting is turned on.

I'm guessing that this SteamLauncherProxy.exe is supposed to be used in some way but I have no idea how to indicate that rpcs3 is to be used as well. 

Similarly, I tried this on PS1 and PS2 games as well with the same result. I feel like I'm missing an obvious step here.

Yeah, I've had to change it a few times after it kept changing back myself in the past. Haven't had it happen in awhile though. Hopefully @Lahma can chime in on this.

Link to comment
Share on other sites

23 hours ago, Aetavicus said:

I am trying to get this plugin working for a PS3 game but have not been successful so far.

Here's what I did:

  1. Steam is running in the background and in-game overlay is enabled. (I don't use Big Picture mode)
  2. Downloaded the latest version from this forum (v0.9.3.0)
  3. Extracted the SteamLauncher into the plugin folder of LB
    • Currently placed at: C:\Emulation\LaunchBox\Plugins\SteamLauncher
  4. Launched LB and checked that the Steam Launcher setting under Tools is set to On
  5. Attempt to launch one of my PS3 games but an error message will appear saying "The file you specified for the emulator application path was not found".
    • This error only happens when the SteamLauncher setting is enabled.
    • When disabled, rpcs3 starts up and launches the game as per normal.
    • Took at look at the emulation app path and it is currently set to "..\Plugins\SteamLauncher\SteamLauncherProxy.exe" when SteamLauncher is enabled.
    • The sample command would be SteamLauncherProxy.exe "FULL\PATH\TO\ROM\FILE"

Is there something I am missing in here?

Sorry it took me so long to respond. The reason you're having problems is that you're not using the latest alpha I've posted here in the support thread. I know, I know... I haven't updated the plugin download page. I'm literally changing all of the documentation, logos, updating the Github, etc for the 1.0 release, so I've been putting off updating the main download page until that release is ready. If I would have suspected it would have taken anywhere close to the amount of time that is has to finish the 1.0 release, I definitely would have updated the plugin download page long ago. I probably need to go ahead and just do that... Sorry about that. I realize there is no way you would have known you would need to get the latest release that I've posted here in the support thread.

Anyways, with all that rambling out of the way, you need to be using this version:

SteamLauncher Alpha v0.9.7.3
http://bit.ly/SLv0973

Let me know if you have any problems.

  • Like 1
Link to comment
Share on other sites

4 hours ago, Aetavicus said:

I downloaded the version you linked and it's working fine now.

Tested it with both PS3 and PS2 games and it works perfectly. Thanks for the help!

You're very welcome! Always great to find another person who finds the plugin to be useful for their needs.

Link to comment
Share on other sites

Not sure whether this is reported but it seems that the plugin is unable to start the game if the game's title contains special alphabets.

I was testing out Xenosaga Episode II today and it just couldn't launch the game.

The full title of the game is Xenosaga Episode II: Jenseits von Gut und Böse and I believe the problem is with the very last word, Böse. Changing it to Bose caused the plugin to work again.

Update: The plugin could launch the game but resulted in a black screen and PCSX2 gave me the plugin setup window again. Fixed by renaming the folder containing the ROM file to remove any special alphabets as per above.

 

Edited by Aetavicus
Link to comment
Share on other sites

On 1/13/2021 at 6:15 PM, Lahma said:

Always great to find another person who finds the plugin to be useful for their needs.

This is an understatement on my part. I would not use Launchbox if not for your great plugin!

  • Thanks 1
  • Haha 1
Link to comment
Share on other sites

On 1/19/2021 at 11:34 AM, Aetavicus said:

Not sure whether this is reported but it seems that the plugin is unable to start the game if the game's title contains special alphabets.

I was testing out Xenosaga Episode II today and it just couldn't launch the game.

The full title of the game is Xenosaga Episode II: Jenseits von Gut und Böse and I believe the problem is with the very last word, Böse. Changing it to Bose caused the plugin to work again.

Update: The plugin could launch the game but resulted in a black screen and PCSX2 gave me the plugin setup window again. Fixed by renaming the folder containing the ROM file to remove any special alphabets as per above.

 

Hey @Aetavicus, that is disappointing to hear as I definitely implemented full UTF-8 support a very long time ago. Unsurprisingly, the first culprit which made me realize non-ASCII characters were not working correctly was Pokémon. I can't say I've ever come across an umlaut (¨) in any of my own game titles and this is the first instance I've heard of any problems with it. With that being said, I don't doubt your report at all as there is an undisputed bug in Steam's unicode character handling which is the entire reason there was an issue with titles such as Pokémon in the 1st place. In order to work around that bug in Steam, I have to mangle the UTF-8 encoding in my plugin before sending it to any Steam API method. Since it has been so long since I've dealt with the issue, I can't remember the particulars of it but it is possible that there may be some limitations as to what character sets it is capable of implementing (for example, it may support all UTF-8 characters but it may not be able to display unicode characters that require a full 16 bit representation). I will definitely look at it though to see if it can be fixed.

One thing you might look at in the meantime is if you can create a non-Steam shortcut within Steam itself using that character. If there is indeed no problem actually creating a non-Steam shortcut with that character in its name (or file path), its likely the problem is related in some way to the function I'm using to mangle the unicode bytes before sending them to a Steam API function. If you get a chance to try it, let me know what the results are. Otherwise, I'll look at it as soon as I can. Thank a lot for the report!

  • Like 1
Link to comment
Share on other sites

Hey @Lahma,

I an't seem to launch any emulators anymore.  Everything looks like it should work and they work when I turn steamlauncher off.

Here's my log.  It's failing to find some object...

 

2020-09-24 21:37:35 [Warning] [Config] [LoadConfigOrDefaults] - The config file was not found. Loading defaults.
2020-09-24 21:38:16 [Error] [ProxyEmulator] [FixLbGameStartupWindowZOrder] - Could not fix the LaunchBox game startup/shutdown window z order because no valid window handle could be found.
2020-09-24 21:38:16 [Error] [ProxyEmulator] [ShowHideLbStartupWindow] - Could not change the visibility of the LaunchBox game startup/shutdown window. No valid window handle could be found.
2020-09-24 21:38:16 [Error] [ProxyEmulator] [TryShowWindow] - Failed to show the main game window due to an invalid or missing window handle: Value cannot be null. (Parameter 'windowHandle')
2020-09-24 21:38:18 [Error] [ProxyEmulator] [ShowHideLbStartupWindow] - Could not change the visibility of the LaunchBox game startup/shutdown window. No valid window handle could be found.
2020-09-24 21:42:09 [Error] [ProxyEmulator] [FixLbGameStartupWindowZOrder] - Could not fix the LaunchBox game startup/shutdown window z order because no valid window handle could be found.
2020-09-24 21:42:09 [Error] [ProxyEmulator] [ShowHideLbStartupWindow] - Could not change the visibility of the LaunchBox game startup/shutdown window. No valid window handle could be found.
2020-09-24 21:42:09 [Error] [ProxyEmulator] [TryShowWindow] - Failed to show the main game window due to an invalid or missing window handle: Value cannot be null. (Parameter 'windowHandle')
2020-09-24 21:42:11 [Error] [ProxyEmulator] [ShowHideLbStartupWindow] - Could not change the visibility of the LaunchBox game startup/shutdown window. No valid window handle could be found.
2020-09-24 21:56:38 [Warning] [Config] [LoadConfigOrDefaults] - The config file was not found. Loading defaults.
2020-09-24 21:58:32 [Warning] [Config] [LoadConfigOrDefaults] - The config file was not found. Loading defaults.
2020-09-24 22:00:59 [Warning] [Config] [LoadConfigOrDefaults] - The config file was not found. Loading defaults.
2020-09-24 22:09:44 [Error] [ProxyEmulator] [FixLbGameStartupWindowZOrder] - Could not fix the LaunchBox game startup/shutdown window z order because no valid window handle could be found.
2020-09-24 22:09:44 [Error] [ProxyEmulator] [ShowHideLbStartupWindow] - Could not change the visibility of the LaunchBox game startup/shutdown window. No valid window handle could be found.
2020-09-24 22:09:44 [Error] [ProxyEmulator] [TryShowWindow] - Failed to show the main game window due to an invalid or missing window handle: Value cannot be null. (Parameter 'windowHandle')
2020-09-24 22:09:46 [Error] [ProxyEmulator] [ShowHideLbStartupWindow] - Could not change the visibility of the LaunchBox game startup/shutdown window. No valid window handle could be found.
2020-09-26 10:54:53 [Error] [GameLaunchingPlugin] [OnAfterGameLaunched] - An error occurred while creating/launching the Steam shortcut: Failed to get proxy arguments because no proxy process was found.
2020-09-26 10:58:59 [Error] [ProxyEmulator] [FixLbGameStartupWindowZOrder] - Could not fix the LaunchBox game startup/shutdown window z order because no valid window handle could be found.
2020-09-26 10:58:59 [Error] [ProxyEmulator] [ShowHideLbStartupWindow] - Could not change the visibility of the LaunchBox game startup/shutdown window. No valid window handle could be found.
2020-09-26 10:58:59 [Error] [ProxyEmulator] [TryShowWindow] - Failed to show the main game window due to an invalid or missing window handle: Value cannot be null. (Parameter 'windowHandle')
2020-09-26 10:59:01 [Error] [ProxyEmulator] [ShowHideLbStartupWindow] - Could not change the visibility of the LaunchBox game startup/shutdown window. No valid window handle could be found.
2020-09-26 10:59:03 [Error] [ProxyEmulator] [FixLbGameStartupWindowZOrder] - Could not fix the LaunchBox game startup/shutdown window z order because no valid window handle could be found.
2020-09-26 10:59:03 [Error] [ProxyEmulator] [ShowHideLbStartupWindow] - Could not change the visibility of the LaunchBox game startup/shutdown window. No valid window handle could be found.
2020-09-26 10:59:03 [Error] [ProxyEmulator] [TryShowWindow] - Failed to show the main game window due to an invalid or missing window handle: Value cannot be null. (Parameter 'windowHandle')
2020-09-26 10:59:05 [Error] [ProxyEmulator] [ShowHideLbStartupWindow] - Could not change the visibility of the LaunchBox game startup/shutdown window. No valid window handle could be found.
2020-09-26 12:30:34 [Error] [GameLaunchingPlugin] [OnAfterGameLaunched] - An error occurred while creating/launching the Steam shortcut: Failed to get proxy arguments because no proxy process was found.
2020-09-27 19:37:13 [Error] [ProxyEmulator] [FixLbGameStartupWindowZOrder] - Could not fix the LaunchBox game startup/shutdown window z order because no valid window handle could be found.
2020-09-27 19:37:13 [Error] [ProxyEmulator] [ShowHideLbStartupWindow] - Could not change the visibility of the LaunchBox game startup/shutdown window. No valid window handle could be found.
2020-09-27 19:37:13 [Error] [ProxyEmulator] [TryShowWindow] - Failed to show the main game window due to an invalid or missing window handle: Sequence contains no elements
2020-09-27 19:37:15 [Error] [ProxyEmulator] [ShowHideLbStartupWindow] - Could not change the visibility of the LaunchBox game startup/shutdown window. No valid window handle could be found.
2020-09-28 10:09:35 [Error] [GameLaunchingPlugin] [OnAfterGameLaunched] - An error occurred while creating/launching the Steam shortcut: Object reference not set to an instance of an object.
2020-09-28 13:19:38 [Error] [GameLaunchingPlugin] [OnAfterGameLaunched] - An error occurred while creating/launching the Steam shortcut: Failed to get proxy arguments because no proxy process was found.
2020-09-28 20:18:08 [Error] [GameLaunchingPlugin] [OnAfterGameLaunched] - An error occurred while creating/launching the Steam shortcut: Failed to get proxy arguments because no proxy process was found.
2020-09-28 21:17:26 [Error] [GameLaunchingPlugin] [OnAfterGameLaunched] - An error occurred while creating/launching the Steam shortcut: Failed to get proxy arguments string from SteamLauncherProxy.
2020-10-09 08:07:13 [Error] [GameLaunchingPlugin] [OnAfterGameLaunched] - An error occurred while creating/launching the Steam shortcut: Failed to get proxy arguments because no proxy process was found.
2020-10-09 18:09:56 [Error] [GameLaunchingPlugin] [OnAfterGameLaunched] - An error occurred while creating/launching the Steam shortcut: Failed to get proxy arguments because no proxy process was found.
2020-12-17 03:50:01 [Error] [GameLaunchingPlugin] [OnAfterGameLaunched] - An error occurred while creating/launching the Steam shortcut: Failed to get proxy arguments because no proxy process was found.
2021-01-22 08:58:25 [Error] [SteamContext] [InitClientShortcutsInterface] - Failed to retrieve a valid ClientShortcuts interface address. Aborting initialization.
2021-01-22 08:58:25 [Error] [GameLaunchingPlugin] [OnAfterGameLaunched] - An error occurred while creating/launching the Steam shortcut: Object reference not set to an instance of an object.
2021-01-22 08:58:33 [Error] [SteamContext] [InitClientShortcutsInterface] - Failed to retrieve a valid ClientShortcuts interface address. Aborting initialization.
2021-01-22 08:58:33 [Error] [GameLaunchingPlugin] [OnAfterGameLaunched] - An error occurred while creating/launching the Steam shortcut: Object reference not set to an instance of an object.
2021-01-22 08:58:44 [Error] [SteamContext] [InitClientShortcutsInterface] - Failed to retrieve a valid ClientShortcuts interface address. Aborting initialization.
2021-01-22 08:58:44 [Error] [GameLaunchingPlugin] [OnAfterGameLaunched] - An error occurred while creating/launching the Steam shortcut: Object reference not set to an instance of an object.
2021-01-22 08:59:52 [Error] [GameLaunchingPlugin] [OnAfterGameLaunched] - An error occurred while creating/launching the Steam shortcut: Failed to get proxy arguments because no proxy process was found.
2021-01-22 09:00:30 [Error] [SteamContext] [InitClientShortcutsInterface] - Failed to retrieve a valid ClientShortcuts interface address. Aborting initialization.
2021-01-22 09:00:30 [Error] [GameLaunchingPlugin] [OnAfterGameLaunched] - An error occurred while creating/launching the Steam shortcut: Object reference not set to an instance of an object.
2021-01-22 09:19:59 [Error] [SteamContext] [InitClientShortcutsInterface] - Failed to retrieve a valid ClientShortcuts interface address. Aborting initialization.
2021-01-22 09:19:59 [Error] [GameLaunchingPlugin] [OnAfterGameLaunched] - An error occurred while creating/launching the Steam shortcut: Object reference not set to an instance of an object.
2021-01-22 09:20:10 [Error] [SteamContext] [InitClientShortcutsInterface] - Failed to retrieve a valid ClientShortcuts interface address. Aborting initialization.
2021-01-22 09:20:10 [Error] [GameLaunchingPlugin] [OnAfterGameLaunched] - An error occurred while creating/launching the Steam shortcut: Object reference not set to an instance of an object.
2021-01-22 09:20:33 [Error] [SteamContext] [InitClientShortcutsInterface] - Failed to retrieve a valid ClientShortcuts interface address. Aborting initialization.
2021-01-22 09:20:33 [Error] [GameLaunchingPlugin] [OnAfterGameLaunched] - An error occurred while creating/launching the Steam shortcut: Object reference not set to an instance of an object.
2021-01-22 09:23:56 [Error] [GameLaunchingPlugin] [OnAfterGameLaunched] - An error occurred while creating/launching the Steam shortcut: Failed to get proxy arguments because no proxy process was found.
2021-01-22 09:24:31 [Error] [SteamContext] [InitClientShortcutsInterface] - Failed to retrieve a valid ClientShortcuts interface address. Aborting initialization.
2021-01-22 09:24:31 [Error] [GameLaunchingPlugin] [OnAfterGameLaunched] - An error occurred while creating/launching the Steam shortcut: Object reference not set to an instance of an object.
2021-01-22 09:26:23 [Error] [SteamContext] [InitClientShortcutsInterface] - Failed to retrieve a valid ClientShortcuts interface address. Aborting initialization.
2021-01-22 09:26:23 [Error] [GameLaunchingPlugin] [OnAfterGameLaunched] - An error occurred while creating/launching the Steam shortcut: Object reference not set to an instance of an object.
2021-01-22 09:26:30 [Error] [SteamContext] [InitClientShortcutsInterface] - Failed to retrieve a valid ClientShortcuts interface address. Aborting initialization.
2021-01-22 09:26:30 [Error] [GameLaunchingPlugin] [OnAfterGameLaunched] - An error occurred while creating/launching the Steam shortcut: Object reference not set to an instance of an object.
2021-01-22 09:27:50 [Error] [SteamContext] [InitClientShortcutsInterface] - Failed to retrieve a valid ClientShortcuts interface address. Aborting initialization.
2021-01-22 09:27:50 [Error] [GameLaunchingPlugin] [OnAfterGameLaunched] - An error occurred while creating/launching the Steam shortcut: Object reference not set to an instance of an object.
2021-01-22 09:28:36 [Error] [SteamContext] [InitClientShortcutsInterface] - Failed to retrieve a valid ClientShortcuts interface address. Aborting initialization.
2021-01-22 09:28:36 [Error] [GameLaunchingPlugin] [OnAfterGameLaunched] - An error occurred while creating/launching the Steam shortcut: Object reference not set to an instance of an object.
2021-01-22 09:30:44 [Error] [SteamContext] [InitClientShortcutsInterface] - Failed to retrieve a valid ClientShortcuts interface address. Aborting initialization.
2021-01-22 09:30:44 [Error] [GameLaunchingPlugin] [OnAfterGameLaunched] - An error occurred while creating/launching the Steam shortcut: Object reference not set to an instance of an object.
2021-01-22 09:31:21 [Error] [SteamContext] [InitClientShortcutsInterface] - Failed to retrieve a valid ClientShortcuts interface address. Aborting initialization.
2021-01-22 09:31:21 [Error] [GameLaunchingPlugin] [OnAfterGameLaunched] - An error occurred while creating/launching the Steam shortcut: Object reference not set to an instance of an object.
2021-01-22 09:36:23 [Error] [SteamContext] [InitClientShortcutsInterface] - Failed to retrieve a valid ClientShortcuts interface address. Aborting initialization.
2021-01-22 09:36:23 [Error] [GameLaunchingPlugin] [OnAfterGameLaunched] - An error occurred while creating/launching the Steam shortcut: Object reference not set to an instance of an object.
2021-01-22 09:47:32 [Error] [SteamContext] [InitClientShortcutsInterface] - Failed to retrieve a valid ClientShortcuts interface address. Aborting initialization.
2021-01-22 09:47:32 [Error] [GameLaunchingPlugin] [OnAfterGameLaunched] - An error occurred while creating/launching the Steam shortcut: Object reference not set to an instance of an object.
2021-01-22 09:56:57 [Error] [SteamContext] [InitClientShortcutsInterface] - Failed to retrieve a valid ClientShortcuts interface address. Aborting initialization.
2021-01-22 09:56:57 [Error] [GameLaunchingPlugin] [OnAfterGameLaunched] - An error occurred while creating/launching the Steam shortcut: Object reference not set to an instance of an object.
2021-01-22 09:57:21 [Error] [SteamContext] [InitClientShortcutsInterface] - Failed to retrieve a valid ClientShortcuts interface address. Aborting initialization.
2021-01-22 09:57:21 [Error] [GameLaunchingPlugin] [OnAfterGameLaunched] - An error occurred while creating/launching the Steam shortcut: Object reference not set to an instance of an object.
2021-01-22 09:59:25 [Error] [SteamContext] [InitClientShortcutsInterface] - Failed to retrieve a valid ClientShortcuts interface address. Aborting initialization.
2021-01-22 09:59:25 [Error] [GameLaunchingPlugin] [OnAfterGameLaunched] - An error occurred while creating/launching the Steam shortcut: Object reference not set to an instance of an object.
2021-01-22 10:00:16 [Error] [SteamContext] [InitClientShortcutsInterface] - Failed to retrieve a valid ClientShortcuts interface address. Aborting initialization.
2021-01-22 10:00:16 [Error] [GameLaunchingPlugin] [OnAfterGameLaunched] - An error occurred while creating/launching the Steam shortcut: Object reference not set to an instance of an object.
2021-01-22 10:01:43 [Error] [SteamContext] [InitClientShortcutsInterface] - Failed to retrieve a valid ClientShortcuts interface address. Aborting initialization.
2021-01-22 10:01:43 [Error] [GameLaunchingPlugin] [OnAfterGameLaunched] - An error occurred while creating/launching the Steam shortcut: Object reference not set to an instance of an object.

 

Link to comment
Share on other sites

On 1/22/2021 at 4:36 PM, Lahma said:

Hey @Aetavicus, that is disappointing to hear as I definitely implemented full UTF-8 support a very long time ago. Unsurprisingly, the first culprit which made me realize non-ASCII characters were not working correctly was Pokémon. I can't say I've ever come across an umlaut (¨) in any of my own game titles and this is the first instance I've heard of any problems with it. With that being said, I don't doubt your report at all as there is an undisputed bug in Steam's unicode character handling which is the entire reason there was an issue with titles such as Pokémon in the 1st place. In order to work around that bug in Steam, I have to mangle the UTF-8 encoding in my plugin before sending it to any Steam API method. Since it has been so long since I've dealt with the issue, I can't remember the particulars of it but it is possible that there may be some limitations as to what character sets it is capable of implementing (for example, it may support all UTF-8 characters but it may not be able to display unicode characters that require a full 16 bit representation). I will definitely look at it though to see if it can be fixed.

One thing you might look at in the meantime is if you can create a non-Steam shortcut within Steam itself using that character. If there is indeed no problem actually creating a non-Steam shortcut with that character in its name (or file path), its likely the problem is related in some way to the function I'm using to mangle the unicode bytes before sending them to a Steam API function. If you get a chance to try it, let me know what the results are. Otherwise, I'll look at it as soon as I can. Thank a lot for the report!

@Lahma

I tested this with Pokémon as you have mentioned and can confirm that it works in Steam natively.

I created a non-Steam game with the following parameters:

Title: Pokémon SoulSilver

Target: "D:\Media\Games\LaunchBox\Emulators\DeSmuME\DeSmuME-VS2019-x64-Release.exe"  "D:\Media\Games\LaunchBox\Games\Nintendo DS\Pokémon SoulSilver Version [2009]\Pokémon SoulSilver.nds"

Start In: "D:\Media\Games\LaunchBox\Emulators\DeSmuME\"

After clicking Play in Steam, the emulator opened and subsequently launched the game. The game title correctly shows up in my currently playing status.

Trying to launch the same title in Launchbox however will not work with the SteamLauncher plugin enabled. The icon for the SteamLauncherProxy shows up for a few seconds in the taskbar and then closes automatically.

Edited by Aetavicus
Link to comment
Share on other sites

12 hours ago, Lahma said:

@mrdead Are you using this version of the plugin?

SteamLauncher Alpha v0.9.7.3
http://bit.ly/SLv0973

Yeah. So after further testing it's only doing this with Retroarch.
AND I got a different error in the log today.
 

EDIT: On further further testing Retroarch seems to be the problem, not your plugin. Back to the mines.

2021-01-25 10:08:08 [Warning] [Config] [LoadConfigOrDefaults] - The config file was not found. Loading defaults.
2021-01-25 10:09:24 [Error] [GameLaunchingPlugin] [OnAfterGameLaunched] - An error occurred while creating/launching the Steam shortcut: Failed to get proxy arguments because no proxy process was found.

 

Edited by mrdead
Link to comment
Share on other sites

On 1/25/2021 at 10:24 AM, mrdead said:

Yeah. So after further testing it's only doing this with Retroarch.
AND I got a different error in the log today.
 

EDIT: On further further testing Retroarch seems to be the problem, not your plugin. Back to the mines.


2021-01-25 10:08:08 [Warning] [Config] [LoadConfigOrDefaults] - The config file was not found. Loading defaults.
2021-01-25 10:09:24 [Error] [GameLaunchingPlugin] [OnAfterGameLaunched] - An error occurred while creating/launching the Steam shortcut: Failed to get proxy arguments because no proxy process was found.

 

So just to close the loop on my own admittedly stupid issue just in case somebody else has the same problem:
These errors happen if you don't have the right cores set up in RetroArch in LaunchBox. Which wasn't a thing I knew you had to do.

Link to comment
Share on other sites

Crap, now I'M having problems launching emulators for some reason. Haven't really used LaunchBox for the past few months, so I haven't been keeping up with the updates... but I did download the latest alpha you linked (v0.9.7.3) and copied it into my Plugins/SteamLauncher folder. It's working great for the game I downloaded, but then I went to try out a GameCube game and nothing. Tried some of the other emulators and none of them worked. Turned off the SteamLauncher plugin and they work perfectly fine.

I didn't have a problem launching emulators before with this plugin, and I have no idea what's changed, especially since downloading the latest patch seemed to fix the same problem for someone above me. Very weird... I must be doing something stupid.

EDIT: I also want to note that I don't have an error message or anything, and it doesn't seem to change the path like it was for Aetavicus as far as I can tell. I just get the loading mouse cursor for a second, then nothing.

Edited by alienhuntinyeti
Link to comment
Share on other sites

3 hours ago, alienhuntinyeti said:

Crap, now I'M having problems launching emulators for some reason. Haven't really used LaunchBox for the past few months, so I haven't been keeping up with the updates... but I did download the latest alpha you linked (v0.9.7.3) and copied it into my Plugins/SteamLauncher folder. It's working great for the game I downloaded, but then I went to try out a GameCube game and nothing. Tried some of the other emulators and none of them worked. Turned off the SteamLauncher plugin and they work perfectly fine.

I didn't have a problem launching emulators before with this plugin, and I have no idea what's changed, especially since downloading the latest patch seemed to fix the same problem for someone above me. Very weird... I must be doing something stupid.

EDIT: I also want to note that I don't have an error message or anything, and it doesn't seem to change the path like it was for Aetavicus as far as I can tell. I just get the loading mouse cursor for a second, then nothing.

I tried this plugin the other day and had exactly the same issue, absolutely no game that uses a emulator will launch, no error, no nothing in fact.

Link to comment
Share on other sites

Sorry guys. I'm currently out of town (and have been for several days) so I'm not keeping an eye on the thread as closely as I usually do. I will check things on my end right now with the latest LaunchBox and Steam though just to ensure something hasn't broken the plugin. I'll post back here in a min.

Link to comment
Share on other sites

5 hours ago, alienhuntinyeti said:

No problemo, sorry for giving you extra work -.-

I just looked in the debug, and I think this could possibly help maybe?

2021-01-30 14:21:38 [Error] [GameLaunchingPlugin] [OnAfterGameLaunched] - An error occurred while creating/launching the Steam shortcut: Quota violation

debug.log 8.13 kB · 0 downloads

Huh... That is indeed an interesting error. I've never before seen that line, "Quota violation", in the debug log. With that being said, after a quick evaluation, it appears that something in the latest Steam update probably broke things. Since I'm not seeing that 'Quota violation' in my own log, I can't be sure what that is about, but the plugin isn't working for me either and it appears to be related to the plugin not being able to locate the correct vtable offset for 'GetIClientShortcuts' in the Steam client DLL. I just opened the latest steamclient.dll in IDA and I'm analyzing it to see what has changed. After a cursory inspection, it appears that there were a LOT of new entries added to the IClientEngine vtable. While my plugin has code that attempts to be "smart" about finding the correct vtable offset, I intentionally limit the number of vtable offsets it is allowed to investigate around a specified static offset value in order to prevent startup of the plugin from taking too long. I thought I set this value sufficiently high that even a major update to the vtable would not cause the offset to be outside of this range but it appears that my assumption may have been wrong (although, if that is the the only thing wrong, and simply adjusting this value will fix the problem, that will be comforting as that means my "smart" algorithm for finding the correct offset is still working and only a single range value needs to be modified). Let me do a bit more testing and I will get back to y'all.

  • Like 3
  • Thanks 2
Link to comment
Share on other sites

Just wanted to give you guys an update and let you know I found the source of the problem. I'm making the long drive home tomorrow (from being out of town for over a week) so I doubt I'll be able to put out the fix before then, but I'll try to post the update as quickly as I can.

  • Like 4
  • Thanks 3
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...