Jump to content
LaunchBox Community Forums

Recommended Posts

1 minute ago, JedExodus said:

Hey @rfj831@gmail.com I gave it a go as well but was unable to replicate the issue. My thought is that maybe the GDP (they look so cool btw) has some inbuilt software that could be messing with the focus?

On a sidenote BigBox does not work for me on the latest LB release, reverting back to the previous release it works grand. Wondering what other peoples experiences with this are?

 

On 8/25/2021 at 6:52 AM, Lahma said:

Hey @rfj831@gmail.com, I tested out Retroarch with the Duckstation core and I'm not having any issues with the Retroarch window losing focus. It is really hard for me to say what it could be without doing some further investigating some of which will require some info from you. For one, do you have "Prevent Steam Focus Stealing" enabled in the SteamLauncher options? Also, are you using Startup, Shutdown, and/or Pause screens in LB? I do all of my testing without Startup/Shutdown screens enabled. When you try other cores in Retroarch, you said you don't experience this same issue, right? You can try enabling debug logging, then run a game with the Duckstation core, then close Retroarch, close LB, and then upload the debug.log file to pastebin and send me the link. Honestly, I'm not sure how much help that will be but it is worth a try.

Additionally, if anyone else watching this thread could maybe try out the Duckstation core on Retroarch and let us know if you are or are not having issues with the Retroarch window losing focus, that would be super helpful. Maybe @JedExodus might offer to try it out? Thanks!

Thanks for trying. Yeah the WinMax is great but it does present some weird challenges. I will keep tinkering with it. It's not the end of the world. Just minor annoyances.

Link to comment
Share on other sites

On 8/25/2021 at 6:52 AM, Lahma said:

Hey @rfj831@gmail.com, I tested out Retroarch with the Duckstation core and I'm not having any issues with the Retroarch window losing focus. It is really hard for me to say what it could be without doing some further investigating some of which will require some info from you. For one, do you have "Prevent Steam Focus Stealing" enabled in the SteamLauncher options? Also, are you using Startup, Shutdown, and/or Pause screens in LB? I do all of my testing without Startup/Shutdown screens enabled. When you try other cores in Retroarch, you said you don't experience this same issue, right? You can try enabling debug logging, then run a game with the Duckstation core, then close Retroarch, close LB, and then upload the debug.log file to pastebin and send me the link. Honestly, I'm not sure how much help that will be but it is worth a try.

Additionally, if anyone else watching this thread could maybe try out the Duckstation core on Retroarch and let us know if you are or are not having issues with the Retroarch window losing focus, that would be super helpful. Maybe @JedExodus might offer to try it out? Thanks!

Oh wow nevermind I just noticed your suggestion about prevent steam focus stealing. I enabled it and it works now. I'm an idiot I never noticed it before. I guess there was a solution this whole time. Thanks so much! 

  • Like 1
Link to comment
Share on other sites

I've run into an issue and I'm not really sure what else to do.  I had this plugin working and then I went to launch a game last night and it failed to launch.  The last time I know for sure it worked was the night before.  The only changes I made to my system between it working and not working were tweaking some settings in the steam games that I had added within the games themselves, adding additional steam games and a couple other roms to LB, and I also had to make a change to the platforms.xml file as I had moved some directories around.  I thought that maybe that last one had an impact, but I can disable steamlauncher and the games launch without issue.  Below is the error I get when trying to launch a game with steamlauncher.

2021-08-28 09:00:19 [Error] [GameLaunchingPlugin] [OnAfterGameLaunched] - An error occurred while creating/launching the Steam shortcut: Failed to get proxy arguments because no proxy process was found.

Any help would be greatly appreciated.  This is a great project and I was loving using it.

Edit:  Turns out the issue was related to the changes I had made to the platforms.xml file.  Not sure how this broke it, but I was able to solve this issue by just removing the platforms.xml file from the data folder and then relaunching LB, it created a new xml file with default values.  After that I was able to launch games with steamlauncher enabled.  I even went back and changed the rom directories, from within LB instead of the xml, and all is still working.

Edited by bigguynak
Solved issue
  • Unusual Gem 1
Link to comment
Share on other sites

3 hours ago, bigguynak said:

I've run into an issue and I'm not really sure what else to do.  I had this plugin working and then I went to launch a game last night and it failed to launch.  The last time I know for sure it worked was the night before.  The only changes I made to my system between it working and not working were tweaking some settings in the steam games that I had added within the games themselves, adding additional steam games and a couple other roms to LB, and I also had to make a change to the platforms.xml file as I had moved some directories around.  I thought that maybe that last one had an impact, but I can disable steamlauncher and the games launch without issue.  Below is the error I get when trying to launch a game with steamlauncher.

2021-08-28 09:00:19 [Error] [GameLaunchingPlugin] [OnAfterGameLaunched] - An error occurred while creating/launching the Steam shortcut: Failed to get proxy arguments because no proxy process was found.

Any help would be greatly appreciated.  This is a great project and I was loving using it.

 

Are you on the latest Launchbox and are you trying to launch through BigBox?

On the latest version I can launch nothing through BigBox at all, rolling back to the previous LB version fixes it however

Link to comment
Share on other sites

32 minutes ago, JedExodus said:

Are you on the latest Launchbox and are you trying to launch through BigBox?

On the latest version I can launch nothing through BigBox at all, rolling back to the previous LB version fixes it however

I was not on the latest version when I started having the issue.  I had not updated between it working and when it stopped working.  I did try and update it today to see if that would fix it and that did not work either.  Also, the issue is with both bigbox and launchbox.

Link to comment
Share on other sites

Sorry this is probably a really noob question. I've just installed Steam launcher but cannot get any non-steam game to run.  For example I'll trying to launch a Cemu game from Launchbox and I get "The file you specified for the emulator application path was not found".  If I switch off the Steamlauncher plugin I can run the game fine.  The Steam launcher plugin obviously changes the emulators path settings.  I tried making Cemu a non-steam game shortcut but it still does not pick up the game.  Do I have to do something with the emulator application path settings in Launchbox?  

Just to give background I use my Steam controller to play BOTW so I can use the gyro function but I usually need to open steam in BPM and launch Launchbox from within Steam BPM to get the Steam controller to work and have access to the overlays.  It would be nice not to have to run BPM and run everything by just using Launchbox and the Steam Launcher plugin so I have access to the steam overlay etc

Link to comment
Share on other sites

Hey everyone.  I can't start games from BigBox anymore when Steam Launcher is enabled. I can start games from desktop mode so its not completely broken. I also saw another post talking about reverting back to an older version of LaunchBox so I tried that but then BigBox doesn't work at all. Any advice or help would be appreciated. Thanks

Link to comment
Share on other sites

On 8/29/2021 at 2:15 AM, 51mm5 said:

Sorry this is probably a really noob question. I've just installed Steam launcher but cannot get any non-steam game to run.  For example I'll trying to launch a Cemu game from Launchbox and I get "The file you specified for the emulator application path was not found".  If I switch off the Steamlauncher plugin I can run the game fine.  The Steam launcher plugin obviously changes the emulators path settings.  I tried making Cemu a non-steam game shortcut but it still does not pick up the game.  Do I have to do something with the emulator application path settings in Launchbox?  

Just to give background I use my Steam controller to play BOTW so I can use the gyro function but I usually need to open steam in BPM and launch Launchbox from within Steam BPM to get the Steam controller to work and have access to the overlays.  It would be nice not to have to run BPM and run everything by just using Launchbox and the Steam Launcher plugin so I have access to the steam overlay etc

Hey @51mm5, sorry about the long delay in responding. I've been super busy lately and just haven't had time to check the thread. On the plugin download page, there is info on how to contact me on Steam. I think that would be the easiest and most efficient way to try to figure out what issue you are having. Hit me up and we'll get it sorted out. Being a new user, I suspect the problem is something minor or just a misunderstanding in how things work.

Here is a link to the plugin download page which has my Steam contact info:

 

  • Like 1
Link to comment
Share on other sites

On 9/1/2021 at 10:00 AM, rfj831@gmail.com said:

Hey everyone.  I can't start games from BigBox anymore when Steam Launcher is enabled. I can start games from desktop mode so its not completely broken. I also saw another post talking about reverting back to an older version of LaunchBox so I tried that but then BigBox doesn't work at all. Any advice or help would be appreciated. Thanks

On 9/1/2021 at 10:00 AM, rfj831@gmail.com said:

On the latest version I can launch nothing through BigBox at all, rolling back to the previous LB version fixes it however

Hey @rfj831@gmail.com and @JedExodus, sorry for the long delay in responding. I'm looking into the issue with BigBox right now. I have no idea why a minor LB/BB update would break the plugin (and only in BB) but what's new, right? Story of my life... I'll update this post when I know more. Oh, and clearly something has gone wrong if reverting back to the previous version doesn't fix your issue with BB @rfj831@gmail.com... What steps did you take to revert to the previous update?

Link to comment
Share on other sites

On 9/4/2021 at 3:47 AM, Lahma said:

Hey @51mm5, sorry about the long delay in responding. I've been super busy lately and just haven't had time to check the thread. On the plugin download page, there is info on how to contact me on Steam. I think that would be the easiest and most efficient way to try to figure out what issue you are having. Hit me up and we'll get it sorted out. Being a new user, I suspect the problem is something minor or just a misunderstanding in how things work.

Here is a link to the plugin download page which has my Steam contact info:

 

Thanks mate. I've sent you a friend request on Steam.  My Steam names is Simms1000

Link to comment
Share on other sites

FYI everyone: I'm aware that the plugin is broken and I've already got LB fixed. Now I'm working on getting BB fixed. I am super sick right now.. Got a fever, sinus infection, etc.. I'm trying to get an update out as quick as possible though.

  • Thanks 7
Link to comment
Share on other sites

16 minutes ago, Lahma said:

FYI everyone: I'm aware that the plugin is broken and I've already got LB fixed. Now I'm working on getting BB fixed. I am super sick right now.. Got a fever, sinus infection, etc.. I'm trying to get an update out as quick as possible though.

Thanks for you work on this.  Take care of yourself though, we can wait.

  • Like 4
Link to comment
Share on other sites

On 9/15/2021 at 12:04 AM, Lahma said:

FYI everyone: I'm aware that the plugin is broken and I've already got LB fixed. Now I'm working on getting BB fixed. I am super sick right now.. Got a fever, sinus infection, etc.. I'm trying to get an update out as quick as possible though.

Health is the most import thing man! I hope you get well soon!

  • Thanks 1
Link to comment
Share on other sites

Just wanted to update everyone. I'm still pretty sick (haven't been this sick since I was a kid) but I finally figured out the issue with BigBox. The recent LB/BB update changed the version of a DLL it was using which has caused some unforeseen issues the plugin. I can't really explain why this DLL was updated while none of the other related .NET dlls were (they've been using v4.7 for a very long time and now, only this single DLL has been updated to v5.0 which causes issues because the v5.0 dll expects its own dependencies to be the same version but they aren't.) Regardless, I know what I need to do to fix the problem and I'm working on it now. The entire reason I was relying on the DLLs included with LB/BB instead of including them with the plugin was to save space and so I wouldn't have to start including a bunch of dependencies with the plugin itself. I guess in retrospect it really doesn't make that much of a difference anyways... whats a couple of more files in the zip package (and another couple of MB), right? While I'm at it, I think I'm going to go ahead and port my code to use Microsoft's newer version of this particular dependency. Previously I was using 'System.Management' (WMI) whereas Microsoft now recommends using Microsoft.Management.Infrastructure (MMI). Since I'm having to put the work in anyways, I'm going to go ahead and update things to use this new library. I'll try to get the update out in the next few days if I can. Sorry about the long wait... I definitely wasn't planning on being sick for over a week (I missed this entire week of work and it remains to be seen how much I'm going to miss next week). Thanks for your patience.

P.S. If the majority of you use only LaunchBox (as opposed to BigBox) and it would be helpful to have an update the fixes only LB, let me know. I would be happy to share a temporary update that will at least allow y'all to use LB until I get the update out that fixes both.

  • Thanks 6
  • Game On 1
Link to comment
Share on other sites

Quick update: I've got both LB and BB fixed now. I'm working on cleaning up a few other things before I post the new update but if anyone wants to test a debug build of the update right now, hit me up on Steam. It would actually be helpful to have a few people test it out before I post the update officially just to be sure there isn't any major bugs or anything (since I actually had to change quite a bit of code as well as migrate to a new library for this update).

  • Like 3
  • Thanks 3
Link to comment
Share on other sites

  • 2 weeks later...
  • 3 weeks later...
  • 4 weeks later...

Does the Steam launcher work with Rockstar Launcher games?  I have a steam controller so I rely on this wonderful plugin to have the Steam overlay work with my games so I can use the Steam controller.  I'm thinking of purchasing the newly released GTA Remastered Trilogy Auto Trilogy which is only available via the Rockstar launcher and not Steam but not sure if it will work well with Launch box and this plugin.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...