Jump to content
LaunchBox Community Forums

Recommended Posts

I am currently getting this error when I try to start launchbox. Not sure what is the issue. Should I just do download a new copy of launchbox and copy the entire folder in my current luanchBox folder?

 

Column name 'enabled' is defined for different mapping types.

App:     LaunchBox
Version: 8.0
Type:    System.Data.DataException
Site:    Void HandleAttributeColumn(System.Xml.Schema.XmlSchemaAttribute, System.Data.DataTable, Boolean)
Source:  System.Data

   at System.Data.XSDSchema.HandleAttributeColumn(XmlSchemaAttribute attrib, DataTable table, Boolean isBase)
   at System.Data.XSDSchema.HandleAttributes(XmlSchemaObjectCollection attributes, DataTable table, Boolean isBase)
   at System.Data.XSDSchema.HandleComplexType(XmlSchemaComplexType ct, DataTable table, ArrayList tableChildren, Boolean isNillable)
   at System.Data.XSDSchema.InstantiateTable(XmlSchemaElement node, XmlSchemaComplexType typeNode, Boolean isRef)
   at System.Data.XSDSchema.HandleTable(XmlSchemaElement node)
   at System.Data.XSDSchema.HandleDataSet(XmlSchemaElement node, Boolean isNewDataSet)
   at System.Data.XSDSchema.LoadSchema(XmlSchemaSet schemaSet, DataSet ds)
   at System.Data.DataSet.InferSchema(XmlDocument xdoc, String[] excludedNamespaces, XmlReadMode mode)
   at System.Data.DataSet.ReadXml(XmlReader reader, Boolean denyResolving)
   at System.Data.DataSet.ReadXml(String fileName)
   at (DataManager , String )
   at Unbroken.LaunchBox.Data.DataManager.LoadGames(String filePath)
   at (<>c__DisplayClass205_1 )
   at Unbroken.LaunchBox.Data.DataManager.<>c__DisplayClass205_1.<Load>b__1()
   at System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
   at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
   at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
   at System.Threading.ThreadHelper.ThreadStart()

Recent Log:

   11:44:50 AM Exception

Link to post
Share on other sites

looks like a bug to me. maybe you can try the last release before 8.0? unless @Jason Carr can give you something to try to stop the crash.

i'm guessing if you did a brand new 8.0 install to a new folder, you might not get that problem, at least not until you do whatever it is that is causing it.

Link to post
Share on other sites
48 minutes ago, Cadizking25 said:

Is there anyone that can help?. I have a paid launchbox and I can't even use it. constantly getting error on startup.

Yeah that is not a error I have seen before, so i'm not sure as to what is causing it. I have passed it onto Jason so hopefully he can work it out for you.

Link to post
Share on other sites
48 minutes ago, ckp said:

looks like a bug to me. maybe you can try the last release before 8.0? unless @Jason Carr can give you something to try to stop the crash.

i'm guessing if you did a brand new 8.0 install to a new folder, you might not get that problem, at least not until you do whatever it is that is causing it.

yea, I tried to download an older version of launchboxand and copied it into my current launchbox folder, but I still get the same bug error. I am able to launch launchbox when I download a new copy on its own, but when I use those files to override the ones in the folder that I use, I get the bug issue.

Link to post
Share on other sites

in your configured (not new install) install, you could try renaming your Launchbox\Data\settings.xml and starting up LB so the setting isnt there. Or rename  bigboxsettings.xml if BB is the problem. make sure LB/BB are closed before renaming the xml file.

Link to post
Share on other sites
5 minutes ago, ckp said:

in your configured (not new install) install, you could try renaming your Launchbox\Data\settings.xml and starting up LB so the setting isnt there. Or rename  bigboxsettings.xml if BB is the problem. make sure LB/BB are closed before renaming the xml file.

So if I rename the settings, would that affect any of my game configurations, also what should I rename it to?

Link to post
Share on other sites

you can rename to anything, like prepend __ to the first part of the file name. 

then when you launch it will start with default settings and it will create those files new. your games will still be there. worse case is you go into the options menu and change the settings how you like and hopefully don't get the one that causes this. you can always then delete the newly created settings.xml file and rename your back to use it along with the problem.

Link to post
Share on other sites
13 minutes ago, ckp said:

you can rename to anything, like prepend __ to the first part of the file name. 

then when you launch it will start with default settings and it will create those files new. your games will still be there. worse case is you go into the options menu and change the settings how you like and hopefully don't get the one that causes this. you can always then delete the newly created settings.xml file and rename your back to use it along with the problem.

So I did all that and it did not work. But I seem to be making a little headway, I remove Atari Cojag xml file and I stop getting the bug error, on startup.Instead, I now getting "it appears you do not have PCSX2 added to Launchbox which this plugin needs to function correctly" and launchbox continue in a loading loop.

Link to post
Share on other sites

Value of 'null' is not valid for 'filePath'.

App:     LaunchBox
Version: 8.0
Type:    System.ArgumentException
Site:    System.Drawing.Icon ExtractAssociatedIcon(System.String, Int32)
Source:  System.Drawing

   at System.Drawing.Icon.ExtractAssociatedIcon(String filePath, Int32 index)
   at PCSX2_Configurator.LaunchBoxPlugin.get_IconImage()
   at Unbroken.LaunchBox.Desktop.Forms.MainForm..ctor()
   at (String[] )
   at Unbroken.LaunchBox.Desktop.Program.Main(String[] args)

Recent Log:

   10:03:24 PM Exception

Link to post
Share on other sites
Just now, Jason Carr said:

This is an error loading games XML. I've never seen this error before; by chance did the XML of anything get modified outside of LaunchBox? What plugins do you have installed?

yes, the Atari Cojag xml is from Hyperspin. But I downloaded the PCSX2 plugin from Launchbox forum.

Link to post
Share on other sites

Do you have PCSX2 emulator added to LB? Is it named "PCSX2"?

Or maybe you changed something, like the path to your PCSX2 emulator? If you open your Sony Playstation 2.xml file, you will see the path that  is expected, to find pcsx2 inis folder, as well as pcsx2.exe, for games you have had the pcsx2 plugin set custom game configs for. 

Edited by ckp
Link to post
Share on other sites
51 minutes ago, ckp said:

Do you have PCSX2 emulator added to LB? Is it named "PCSX2"?

Or maybe you changed something, like the path to your PCSX2 emulator? If you open your Sony Playstation 2.xml file, you will see the path that  is expected, to find pcsx2 inis folder, as well as pcsx2.exe, for games you have had the pcsx2 plugin set custom game configs for. 

I running PCSX2 through RocketLauncher

Link to post
Share on other sites

So finally get launchbox running, after removing the plugin file. But all my emulator settings are gone, any idea why or how I could get it back?, when I go into manage emulators its empty. Also my background reset, basically all my setting rest and the games are not connected to any emulator.

Edited by Cadizking25
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...